aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2004-12-02 16:31:51 +0800
committervs <vs@FreeBSD.org>2004-12-02 16:31:51 +0800
commit4340994d3a6056462e36603c02eb60d417aba740 (patch)
tree5a7981a946debae9018f1735a5bf08bd82bd8adf /devel
parentc86349397e79e3751f99439f1a34d4039d83d9ec (diff)
downloadfreebsd-ports-gnome-4340994d3a6056462e36603c02eb60d417aba740.tar.gz
freebsd-ports-gnome-4340994d3a6056462e36603c02eb60d417aba740.tar.zst
freebsd-ports-gnome-4340994d3a6056462e36603c02eb60d417aba740.zip
- Fix building with nhc
- Use OPTIONS - Nuke 2-line pkg-plist
Diffstat (limited to 'devel')
-rw-r--r--devel/hs-drift/Makefile8
-rw-r--r--devel/hs-drift/files/patch-src::GenUtil.hs11
-rw-r--r--devel/hs-drift/pkg-plist2
3 files changed, 18 insertions, 3 deletions
diff --git a/devel/hs-drift/Makefile b/devel/hs-drift/Makefile
index 74412b1b0c0b..e4ec705bb939 100644
--- a/devel/hs-drift/Makefile
+++ b/devel/hs-drift/Makefile
@@ -14,6 +14,11 @@ DISTNAME= DrIFT-${PORTVERSION}
MAINTAINER= haskell@FreeBSD.org
COMMENT= A type sensitive preprocessor for Haskell
+OPTIONS= NHC98 "Build with nhc98" off \
+ GHC "Build with ghc" on
+
+.include <bsd.port.pre.mk>
+
.if !defined(WITH_NHC98)
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
.else
@@ -23,6 +28,7 @@ BUILD_DEPENDS= nhc98:${PORTSDIR}/lang/nhc98
HAS_CONFIGURE= yes
INFO= drift
+PLIST_FILES= bin/DrIFT bin/drift-ghc
.if !defined(WITH_NHC98)
CONFIGURE_ARGS+= --with-hc=ghc
@@ -38,4 +44,4 @@ pre-everything::
@${ECHO} ""
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/hs-drift/files/patch-src::GenUtil.hs b/devel/hs-drift/files/patch-src::GenUtil.hs
new file mode 100644
index 000000000000..2782535f8450
--- /dev/null
+++ b/devel/hs-drift/files/patch-src::GenUtil.hs
@@ -0,0 +1,11 @@
+--- src/GenUtil.hs.orig Thu Dec 2 09:16:02 2004
++++ src/GenUtil.hs Thu Dec 2 09:16:33 2004
+@@ -85,7 +85,7 @@
+ import Monad
+ import qualified IO
+ import qualified System
+-import Random(StdGen, newStdGen, randomR)
++import Random(StdGen, newStdGen, Random(randomR))
+ import Time
+
+ {-# SPECIALIZE snub :: [String] -> [String] #-}
diff --git a/devel/hs-drift/pkg-plist b/devel/hs-drift/pkg-plist
deleted file mode 100644
index ab074d12510d..000000000000
--- a/devel/hs-drift/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/DrIFT
-bin/drift-ghc