aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2006-03-24 01:15:23 +0800
committerleeym <leeym@FreeBSD.org>2006-03-24 01:15:23 +0800
commit5693aaa27102607fe0eae78bab86b5342dcba723 (patch)
tree3c4211dc3bff87c95d6c5f3dc0098cb564e86063 /devel
parent890755675ebb4848ea624c8e901a5188e13b0567 (diff)
downloadfreebsd-ports-gnome-5693aaa27102607fe0eae78bab86b5342dcba723.tar.gz
freebsd-ports-gnome-5693aaa27102607fe0eae78bab86b5342dcba723.tar.zst
freebsd-ports-gnome-5693aaa27102607fe0eae78bab86b5342dcba723.zip
- update dependency
- patch for Module::Info - bump PORTREVISION PR: 92345 Approved by: maintainer timeout
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Data-Dump-Streamer/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/devel/p5-Data-Dump-Streamer/Makefile b/devel/p5-Data-Dump-Streamer/Makefile
index e574fc324318..e0e133a7b080 100644
--- a/devel/p5-Data-Dump-Streamer/Makefile
+++ b/devel/p5-Data-Dump-Streamer/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Data-Dump-Streamer
PORTVERSION= 1.14
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Data
@@ -15,12 +16,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= mat@FreeBSD.org
COMMENT= Stream a highly accurate breadth first data dump in perl code form to a var or file
-BUILD_DEPENDS= ${SITE_PERL}/Algorithm/Diff.pm:${PORTSDIR}/devel/p5-Algorithm-Diff \
- ${SITE_PERL}/Text/Balanced.pm:${PORTSDIR}/textproc/p5-Text-Balanced \
- ${SITE_PERL}/B/Utils.pm:${PORTSDIR}/devel/p5-Module-Info
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
-BROKEN= Broken dependency
+RUN_DEPENDS= ${SITE_PERL}/Text/Balanced.pm:${PORTSDIR}/textproc/p5-Text-Balanced \
+ ${SITE_PERL}/B/BUtils.pm:${PORTSDIR}/devel/p5-Module-Info
+BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
PERL_CONFIGURE= yes
CONFIGURE_ARGS= DDS
@@ -29,11 +28,11 @@ MAN3= DDS.3 Data::Dump::Streamer.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500801
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Data/Dumper.pm:${PORTSDIR}/devel/p5-Data-Dumper
-.endif
+post-patch:
+ ${FIND} ${WRKSRC} -type f | ${XARGS} ${PERL} -pi -e 's,B::Utils,B::BUtils,g'
+
.if ${PERL_LEVEL} < 500600
-IGNORE="Need at least perl 5.6 to build"
+IGNORE= requires perl 5.6 or above
.endif
.include <bsd.port.post.mk>