aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-07-26 13:37:41 +0800
committerdanfe <danfe@FreeBSD.org>2013-07-26 13:37:41 +0800
commit687bbab5f102996e42bcfbe34eb2ddbe5ec7da0a (patch)
tree6185ae5055e6311f24d03f29aa5956f97e79635f /devel
parentc1e6f9b1282b29ade869dbab3f1768fbcc2443a6 (diff)
downloadfreebsd-ports-gnome-687bbab5f102996e42bcfbe34eb2ddbe5ec7da0a.tar.gz
freebsd-ports-gnome-687bbab5f102996e42bcfbe34eb2ddbe5ec7da0a.tar.zst
freebsd-ports-gnome-687bbab5f102996e42bcfbe34eb2ddbe5ec7da0a.zip
Fix parallel builds by sanitizing inner Makefiles and removing possible race
due to having two targets in ALL_TARGET. Instead, do the cleaning after the build. Reported by: pointyhat-west
Diffstat (limited to 'devel')
-rw-r--r--devel/openvex/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/devel/openvex/Makefile b/devel/openvex/Makefile
index da32dbe7cac3..e3bece247420 100644
--- a/devel/openvex/Makefile
+++ b/devel/openvex/Makefile
@@ -18,8 +18,22 @@ RUN_DEPENDS= vexctl:${PORTSDIR}/devel/roboctl \
sdcc:${PORTSDIR}/lang/sdcc \
gpasm:${PORTSDIR}/devel/gputils
+REINPLACE_ARGS= -i ""
+
MAN1= openvex.1 openvex-new-project.1
-ALL_TARGET= all clean
+post-patch:
+# Use make's -C option to descent into directories and fix parallel builds
+ @${REINPLACE_CMD} -e 's/^all:/& depend/ ; s/ make depend &&//' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -E 's/cd (.+)(;| &&) make/$$(MAKE) -C \1/' \
+ ${WRKSRC}/Advanced/Makefile ${WRKSRC}/Beginner/Makefile \
+ ${WRKSRC}/HiBob/Makefile ${WRKSRC}/Makefile
+# Apparently the work around for bug in pic18f8520.h is no longer needed and
+# breaks the build now; disable it for the time being
+ @${REINPLACE_CMD} -e 's/ifdef SDCC/if 0/' ${WRKSRC}/Lib/timer.h
+
+post-build:
+ $(MAKE) -C $(WRKSRC) clean
.include <bsd.port.mk>