aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-08-18 05:08:54 +0800
committermiwi <miwi@FreeBSD.org>2006-08-18 05:08:54 +0800
commit69eec87f62231af225e38fc460bfff4ac909d261 (patch)
treec93b33579c47f8496f5b2be0104dfadf113500ba /devel
parent18624d97a1d7a5306d35260e458679ec2aabdbea (diff)
downloadfreebsd-ports-gnome-69eec87f62231af225e38fc460bfff4ac909d261.tar.gz
freebsd-ports-gnome-69eec87f62231af225e38fc460bfff4ac909d261.tar.zst
freebsd-ports-gnome-69eec87f62231af225e38fc460bfff4ac909d261.zip
The Shell::Source allows arbitrary shell scripts, or other programs for
that matter, to be run and their environment to be inherited into a Perl program. WWW: http://search.cpan.org/dist/Shell-Source/ PR: ports/102021 Submitted by: Timur I. Bakeyev <timur(at)com.bat.ru> Approved by: krion (mentor)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Shell-Source/Makefile22
-rw-r--r--devel/p5-Shell-Source/distinfo3
-rw-r--r--devel/p5-Shell-Source/pkg-descr5
-rw-r--r--devel/p5-Shell-Source/pkg-plist7
5 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index acb838ef2844..3ff5cc5d794a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1314,6 +1314,7 @@
SUBDIR += p5-Shape
SUBDIR += p5-Shell-Base
SUBDIR += p5-Shell-Parser
+ SUBDIR += p5-Shell-Source
SUBDIR += p5-Smart-Comments
SUBDIR += p5-Sort-Array
SUBDIR += p5-Sort-ArrayOfArrays
diff --git a/devel/p5-Shell-Source/Makefile b/devel/p5-Shell-Source/Makefile
new file mode 100644
index 000000000000..ca1c7e959076
--- /dev/null
+++ b/devel/p5-Shell-Source/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: devel/p5-Shell-Source
+# Date created: 1 Aug 2006
+# Whom: Timur I. Bakeyev <bat@cpan.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Shell-Source
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Shell
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= bat@cpan.org
+COMMENT= Shell::Source - run programs and inherit environment changes
+
+PERL_CONFIGURE= yes
+
+MAN3= Shell::Source.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Shell-Source/distinfo b/devel/p5-Shell-Source/distinfo
new file mode 100644
index 000000000000..190fc2b3a7e0
--- /dev/null
+++ b/devel/p5-Shell-Source/distinfo
@@ -0,0 +1,3 @@
+MD5 (Shell-Source-0.01.tar.gz) = 85d6bad141cdd780856478676423ed25
+SHA256 (Shell-Source-0.01.tar.gz) = 0ce8ce6429ff01c20a7fb451a2d646a4408e5e93dc819baa7b96185ba2af80c1
+SIZE (Shell-Source-0.01.tar.gz) = 3947
diff --git a/devel/p5-Shell-Source/pkg-descr b/devel/p5-Shell-Source/pkg-descr
new file mode 100644
index 000000000000..fa659c269d74
--- /dev/null
+++ b/devel/p5-Shell-Source/pkg-descr
@@ -0,0 +1,5 @@
+The Shell::Source allows arbitrary shell scripts, or other programs for
+that matter, to be run and their environment to be inherited into a Perl
+program.
+
+WWW: http://search.cpan.org/dist/Shell-Source/
diff --git a/devel/p5-Shell-Source/pkg-plist b/devel/p5-Shell-Source/pkg-plist
new file mode 100644
index 000000000000..9d5590a6f955
--- /dev/null
+++ b/devel/p5-Shell-Source/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Shell/Source.pm
+%%SITE_PERL%%/Shell/t/Basic.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Shell/Source/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Shell/Source
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Shell
+@dirrmtry %%SITE_PERL%%/Shell/t
+@dirrmtry %%SITE_PERL%%/Shell