aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-08-08 11:40:34 +0800
committerkris <kris@FreeBSD.org>2003-08-08 11:40:34 +0800
commit71115ae217fd2ce25e6a6ac616585ffcebfeb428 (patch)
tree61d7d710bb4d56d6c6a76823e0681c6436e69f8a /devel
parenta95a11cb16d0bb4b0b6984212b6740a3610a0ff2 (diff)
downloadfreebsd-ports-gnome-71115ae217fd2ce25e6a6ac616585ffcebfeb428.tar.gz
freebsd-ports-gnome-71115ae217fd2ce25e6a6ac616585ffcebfeb428.tar.zst
freebsd-ports-gnome-71115ae217fd2ce25e6a6ac616585ffcebfeb428.zip
As announced on May 6, remove the broken devel/uds port
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/uds/Makefile39
-rw-r--r--devel/uds/distinfo1
-rw-r--r--devel/uds/files/patch-uds::alloc.cc33
-rw-r--r--devel/uds/files/patch-uds::fdbuf.cc10
-rw-r--r--devel/uds/files/patch-uds::io_util.hh47
-rw-r--r--devel/uds/files/patch-uds::packetsocket.cc19
-rw-r--r--devel/uds/files/patch-uds::procstream.cc12
-rw-r--r--devel/uds/files/patch-uds::sockbase.cc10
-rw-r--r--devel/uds/files/patch-uds::streamsocket.cc10
-rw-r--r--devel/uds/files/patch-uds::sys_util.hh10
-rw-r--r--devel/uds/pkg-descr23
-rw-r--r--devel/uds/pkg-plist72
13 files changed, 0 insertions, 287 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8dcda45bb67a..cf689be0da56 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1008,7 +1008,6 @@
SUBDIR += tvision
SUBDIR += uclmmbase
SUBDIR += ucpp
- SUBDIR += uds
SUBDIR += uisp
SUBDIR += umbrello
SUBDIR += upnp
diff --git a/devel/uds/Makefile b/devel/uds/Makefile
deleted file mode 100644
index 3bf122edd644..000000000000
--- a/devel/uds/Makefile
+++ /dev/null
@@ -1,39 +0,0 @@
-# ex:ts=8
-# New ports collection makefile for: uds
-# Date created: Feb 27, 2001
-# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= uds
-PORTVERSION= 1.0.6
-CATEGORIES= devel
-MASTER_SITES= http://frost.flewid.de/dist/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= UDS (Useful Development Stuff) Collection
-
-BROKEN= "Does not compile"
-
-USE_REINPLACE= yes
-USE_GCC= 3.1
-USE_GMAKE= yes
-USE_LIBTOOL= yes
-INSTALLS_SHLIB= yes
-
-pre-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
-
- @${FIND} ${WRKSRC} -name 'Makefile.in' | ${XARGS} ${REINPLACE_CMD} -e \
- 's|install-data-hook|#install-data-hook|g ; \
- s|-D_REENTRANT|-D_REENTRANT ${PTHREAD_CFLAGS}|g ; \
- s|-lpthread|${PTHREAD_LIBS}|g'
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}
-.endif
-
-.include <bsd.port.mk>
diff --git a/devel/uds/distinfo b/devel/uds/distinfo
deleted file mode 100644
index eeab1cc7d7b5..000000000000
--- a/devel/uds/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (uds-1.0.6.tar.gz) = a6996e317c4898deddc620a7e0a903da
diff --git a/devel/uds/files/patch-uds::alloc.cc b/devel/uds/files/patch-uds::alloc.cc
deleted file mode 100644
index 15ca46404bb9..000000000000
--- a/devel/uds/files/patch-uds::alloc.cc
+++ /dev/null
@@ -1,33 +0,0 @@
---- uds/alloc.cc.orig Thu Sep 5 10:07:25 2002
-+++ uds/alloc.cc Thu Sep 5 10:08:48 2002
-@@ -27,26 +27,26 @@
-
-
- void*
--operator new ( size_t size )
-+operator new ( size_t size ) throw ( std::bad_alloc )
- {
- return uds::sentinel().Allocate( size );
- }
-
- void*
--operator new [] ( size_t size )
-+operator new [] ( size_t size ) throw ( std::bad_alloc )
- {
- return uds::sentinel().Allocate( size );
- }
-
- void
--operator delete ( void* p )
-+operator delete ( void* p ) throw ()
- {
- if ( p )
- uds::sentinel().Release( p );
- }
-
- void
--operator delete [] ( void* p )
-+operator delete [] ( void* p ) throw ()
- {
- if ( p )
- uds::sentinel().Release( p );
diff --git a/devel/uds/files/patch-uds::fdbuf.cc b/devel/uds/files/patch-uds::fdbuf.cc
deleted file mode 100644
index 9a58debe0611..000000000000
--- a/devel/uds/files/patch-uds::fdbuf.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- uds/fdbuf.cc.orig Thu Sep 5 10:23:14 2002
-+++ uds/fdbuf.cc Thu Sep 5 10:23:23 2002
-@@ -22,6 +22,7 @@
-
- // includes
-
-+#include <sys/types.h>
- #include <sys/socket.h>
- #include <uds/stdexcpt.hh>
- #include <uds/fdbuf.hh>
diff --git a/devel/uds/files/patch-uds::io_util.hh b/devel/uds/files/patch-uds::io_util.hh
deleted file mode 100644
index 3e86e2906432..000000000000
--- a/devel/uds/files/patch-uds::io_util.hh
+++ /dev/null
@@ -1,47 +0,0 @@
---- uds/io_util.hh.orig Thu Sep 5 10:14:44 2002
-+++ uds/io_util.hh Thu Sep 5 10:21:14 2002
-@@ -27,8 +27,7 @@
-
- #include <uds/fdstream.hh>
- #include <uds/stdexcpt.hh>
--#include <byteswap.h>
--#include <endian.h>
-+#include <sys/endian.h>
- #include <limits>
- #include <unistd.h>
-
-@@ -45,33 +44,10 @@
- end_little = 1234, ///< little-endian
- end_big = 4321, ///< big-endian
- end_net = end_big, ///< network byte order
-- end_host = __BYTE_ORDER ///< host byte order
-+ end_host = BYTE_ORDER ///< host byte order
- };
-
- typedef unsigned endianess_t;
--
--
--// the following bswap* functions need to be defined since
--// gcc (at least 2.95.3) aborts with an error if the bswap_* macros are
--// used inside of a template function and expand to assembly code.
--
--inline u_int16_t
--bswap16( u_int16_t x )
--{
-- return bswap_16( x );
--}
--
--inline u_int32_t
--bswap32( u_int32_t x )
--{
-- return bswap_32( x );
--}
--
--inline u_int64_t
--bswap64( u_int64_t x )
--{
-- return bswap_64( x );
--}
-
-
- /** changes the endianess of an integral type
diff --git a/devel/uds/files/patch-uds::packetsocket.cc b/devel/uds/files/patch-uds::packetsocket.cc
deleted file mode 100644
index cbc67757ff7e..000000000000
--- a/devel/uds/files/patch-uds::packetsocket.cc
+++ /dev/null
@@ -1,19 +0,0 @@
---- uds/packetsocket.cc.orig Thu Sep 5 02:36:31 2002
-+++ uds/packetsocket.cc Thu Sep 5 02:37:03 2002
-@@ -22,6 +22,7 @@
-
- // includes
-
-+#include <sys/types.h>
- #include <netinet/in.h>
- #include <sys/socket.h>
- #include <uds/packetsocket.hh>
-@@ -163,7 +164,7 @@
- &si_len ) );
- d.assign( msg, sz );
-
-- hostent* he = gethostbyaddr( &si.sin_addr, sizeof( si.sin_addr ), AF_INET );
-+ hostent* he = gethostbyaddr( (const char *)&si.sin_addr, sizeof( si.sin_addr ), AF_INET );
-
- if ( he )
- {
diff --git a/devel/uds/files/patch-uds::procstream.cc b/devel/uds/files/patch-uds::procstream.cc
deleted file mode 100644
index 1b0d68eb0c76..000000000000
--- a/devel/uds/files/patch-uds::procstream.cc
+++ /dev/null
@@ -1,12 +0,0 @@
---- uds/procstream.cc.orig Tue Feb 27 13:50:01 2001
-+++ uds/procstream.cc Tue Feb 27 13:50:08 2001
-@@ -22,8 +22,8 @@
-
- // includes
-
--#include <sys/socket.h>
- #include <sys/types.h>
-+#include <sys/socket.h>
- #include <sys/wait.h>
- #include <uds/procstream.hh>
- #include <uds/sys_util.hh>
diff --git a/devel/uds/files/patch-uds::sockbase.cc b/devel/uds/files/patch-uds::sockbase.cc
deleted file mode 100644
index b0d36cb57fb4..000000000000
--- a/devel/uds/files/patch-uds::sockbase.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- uds/sockbase.cc.orig Thu May 10 19:57:08 2001
-+++ uds/sockbase.cc Thu May 10 19:57:26 2001
-@@ -25,6 +25,7 @@
- #include "config.h"
- #ifdef HAVE_SOCKET
-
-+#include <sys/types.h>
- #include <netinet/in.h>
- #include <sys/socket.h>
- #include <sys/un.h>
diff --git a/devel/uds/files/patch-uds::streamsocket.cc b/devel/uds/files/patch-uds::streamsocket.cc
deleted file mode 100644
index af2615419f98..000000000000
--- a/devel/uds/files/patch-uds::streamsocket.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- uds/streamsocket.cc.orig Thu Sep 5 02:38:14 2002
-+++ uds/streamsocket.cc Thu Sep 5 02:38:24 2002
-@@ -25,6 +25,7 @@
- #include "config.h"
- #ifdef HAVE_SOCKET
-
-+#include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <sys/un.h>
diff --git a/devel/uds/files/patch-uds::sys_util.hh b/devel/uds/files/patch-uds::sys_util.hh
deleted file mode 100644
index 7791ea54448c..000000000000
--- a/devel/uds/files/patch-uds::sys_util.hh
+++ /dev/null
@@ -1,10 +0,0 @@
---- uds/sys_util.hh.orig Tue Feb 27 13:54:05 2001
-+++ uds/sys_util.hh Tue Feb 27 13:57:50 2001
-@@ -25,6 +25,7 @@
-
- // includes
-
-+#include <sys/types.h>
- #include <uds/stdexcpt.hh>
-
- using namespace std;
diff --git a/devel/uds/pkg-descr b/devel/uds/pkg-descr
deleted file mode 100644
index 5e7aa7c8556c..000000000000
--- a/devel/uds/pkg-descr
+++ /dev/null
@@ -1,23 +0,0 @@
-The UDS (Useful Development Stuff) Collection is a C++ library that
-assists you while developing and debugging programs. It was developed
-as part of Frost. Features were only added when needed, but it
-provides already a nice bunch of features.
-
-Features:
- - Automatic search for memory leaks
- - Logging of memory [de]allocations
- - Zombie objects
- - Exception system for (almost) fatal errors. A core can be dumped
- when the exception is thrown.
- - Action, FinalAction, and VRemember
- - Function objects that are more flexible than STL function objects
- - Threads, Mutexes, Semaphores Posix Threads wrapper classes
- - Socket Stream class
- - ProcStream class (new)
- - Classes for reference counting that make it easy to implement
- copy-on-write and garbage collection.
- - Simple pseudo-random number generators
- - Several "convenience functions" to create temporary file names;
- open files, fork, wait etc. and throw an exception if something goes wrong
-
-WWW: http://frost.flewid.de/uds/
diff --git a/devel/uds/pkg-plist b/devel/uds/pkg-plist
deleted file mode 100644
index c01e2edf4ecc..000000000000
--- a/devel/uds/pkg-plist
+++ /dev/null
@@ -1,72 +0,0 @@
-include/uds/action.hh
-include/uds/alloc.hh
-include/uds/auto_ptr.hh
-include/uds/btrace.hh
-include/uds/check_ptr.hh
-include/uds/childdiag.hh
-include/uds/collector.hh
-include/uds/dcast.hh
-include/uds/diagnose.hh
-include/uds/errnodiag.hh
-include/uds/exception.hh
-include/uds/exit.hh
-include/uds/fdbuf.hh
-include/uds/fdstream.hh
-include/uds/fileinfo.hh
-include/uds/filestream.hh
-include/uds/flex_func.hh
-include/uds/functional.hh
-include/uds/idep.hh
-include/uds/init.hh
-include/uds/io_util.hh
-include/uds/log.hh
-include/uds/md5.h
-include/uds/packetsocket.hh
-include/uds/procstream.hh
-include/uds/random.hh
-include/uds/refcounter.hh
-include/uds/sentinel.hh
-include/uds/sockbase.hh
-include/uds/stdexcpt.hh
-include/uds/stl_ext.hh
-include/uds/stl_util.hh
-include/uds/str_util.hh
-include/uds/streamsocket.hh
-include/uds/swanpipe.hh
-include/uds/sys_util.hh
-include/uds/thread.hh
-include/uds/thread_nreent.hh
-include/uds/thread_reent.hh
-include/uds/time.hh
-include/uds/uds.hh
-@dirrm include/uds
-lib/libuds.a
-lib/libuds.la
-lib/libuds.so
-lib/libuds.so.2
-lib/libudsthread.a
-lib/libudsthread.la
-lib/libudsthread.so
-lib/libudsthread.so.2
-%%PORTDOCS%%share/doc/uds/config.html
-%%PORTDOCS%%share/doc/uds/contributing.html
-%%PORTDOCS%%share/doc/uds/download.html
-%%PORTDOCS%%share/doc/uds/features.html
-%%PORTDOCS%%share/doc/uds/history.html
-%%PORTDOCS%%share/doc/uds/index.html
-%%PORTDOCS%%share/doc/uds/relnotes.html
-%%PORTDOCS%%share/doc/uds/todo.html
-%%PORTDOCS%%@dirrm share/doc/uds
-share/uds/udsdeff.cc
-@dirrm share/uds
-share/aclocal/uds_base.m4
-share/aclocal/uds_check.m4
-share/aclocal/uds_daemon.m4
-share/aclocal/uds_debug.m4
-share/aclocal/uds_def.m4
-share/aclocal/uds_extra.m4
-share/aclocal/uds_flex.m4
-share/aclocal/uds_opt.m4
-share/aclocal/uds_paths.m4
-share/aclocal/uds_profile.m4
-share/aclocal/uds_prog.m4