aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2006-11-26 12:09:23 +0800
committerjylefort <jylefort@FreeBSD.org>2006-11-26 12:09:23 +0800
commit7161fb0f1bd909f5488677e34e26a54b8fdc6ed8 (patch)
tree4c3046c86c62be298c68a70d5bdce7acc50417fc /devel
parent22c9397797ce59582b8a7a5fad38a01d420e2fb8 (diff)
downloadfreebsd-ports-gnome-7161fb0f1bd909f5488677e34e26a54b8fdc6ed8.tar.gz
freebsd-ports-gnome-7161fb0f1bd909f5488677e34e26a54b8fdc6ed8.tar.zst
freebsd-ports-gnome-7161fb0f1bd909f5488677e34e26a54b8fdc6ed8.zip
- Update openthreads to 1.5
- Update openproducer to 1.1 and move to LOCALBASE - Update osg to 1.2 and move to LOCALBASE - Take maintainerships PR: ports/105729 Submitted by: jylefort Approved by: maintainers
Diffstat (limited to 'devel')
-rw-r--r--devel/openthreads/Makefile26
-rw-r--r--devel/openthreads/distinfo3
-rw-r--r--devel/openthreads/files/patch-Make::makedefs29
-rw-r--r--devel/openthreads/files/patch-Make::makerules20
-rw-r--r--devel/openthreads/files/patch-Make_instrules20
-rw-r--r--devel/openthreads/pkg-descr2
6 files changed, 4 insertions, 96 deletions
diff --git a/devel/openthreads/Makefile b/devel/openthreads/Makefile
index d5e85168a8d9..14a20558543c 100644
--- a/devel/openthreads/Makefile
+++ b/devel/openthreads/Makefile
@@ -6,31 +6,13 @@
#
PORTNAME= openthreads
-PORTVERSION= 1.4.2
+PORTVERSION= 1.5
CATEGORIES= devel
-MASTER_SITES= http://www.openscenegraph.org/downloads/snapshots/
-#
-# the following master distribution contains the version of OpenThreads
-# as described above by PORTVERSION and PORTREVISION.
-DISTNAME= OSG_OP_OT-1.0
-
-MAINTAINER= yinjieh@csie.nctu.edu.tw
-COMMENT= A library which provides OO thread interface for C++ programmers
-USE_ZIP= yes
-USE_GMAKE= yes
-USE_LDCONFIG= yes
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT= A library which provides a C++ object-oriented thread interface
-MAKEFILE= GNUmakefile
WRKSRC= ${WRKDIR}/${DISTNAME}/OpenThreads
-MAKE_ENV+= FREEBSD_ARCH="${ARCH}" PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}"
-
-# Optimisation/Debug flags:
-# opt = optimised ($OPTF added)
-# debug = debug ($DBGF added)
-# opt is default
-#
-ALL_TARGET= opt
+.include "${.CURDIR}/../../graphics/osg/bsd.osg.mk"
.include <bsd.port.mk>
diff --git a/devel/openthreads/distinfo b/devel/openthreads/distinfo
deleted file mode 100644
index 76e06764f857..000000000000
--- a/devel/openthreads/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (OSG_OP_OT-1.0.zip) = dfb3eca46b32625602dabe9aa46c6b6f
-SHA256 (OSG_OP_OT-1.0.zip) = c39572c72d9ed7b7a34a36779bcf56180ba2917926f6f658b5af1824eeb3b6a6
-SIZE (OSG_OP_OT-1.0.zip) = 5036053
diff --git a/devel/openthreads/files/patch-Make::makedefs b/devel/openthreads/files/patch-Make::makedefs
deleted file mode 100644
index 3b88ff96e5ec..000000000000
--- a/devel/openthreads/files/patch-Make::makedefs
+++ /dev/null
@@ -1,29 +0,0 @@
---- Make/makedefs.orig Sat Dec 10 09:49:24 2005
-+++ Make/makedefs Wed Sep 27 19:05:17 2006
-@@ -264,15 +264,22 @@
- CXX = g++
- endif
- DEPARG = -MM
-- INC += -I/usr/local/include -I/usr/X11R6/include
-- DEF += -W -Wall
-+ INC += -I${LOCALBASE}/include -I${X11BASE}/include
-+ DEF += -W -Wall ${PTHREAD_CFLAGS}
- OPTF = -O2
- DBGF = -g
- SHARED = -shared
- ARCH = 32
- ARCHARGS =
-- INST_LOCATION = /usr/local
-- INST_SHARE = /usr/share/OpenThreads
-+ INST_SYS_PREFIX = $(PREFIX)
-+ INST_SHARE_PREFIX = $(DATADIR)
-+ LINKARGS = -L${X11BASE}/lib -L${LOCALBASE}/lib -rpath ${LOCALBASE}/lib -rpath ${X11BASE}/lib ${PTHREAD_LIBS}
-+ INST_LOCATION = $(INST_SYS_PREFIX)
-+ INST_SHARE = $(INST_SHARE_PREFIX)
-+ INST_DEMOS = $(EXAMPLESDIR)/bin
-+ INST_SRC = $(EXAMPLESDIR)/src
-+ INST_DOC = $(DOCSDIR)
-+ INST_DATA = $(DATADIR)
- endif
-
- #### MacOS X specific definitions
diff --git a/devel/openthreads/files/patch-Make::makerules b/devel/openthreads/files/patch-Make::makerules
deleted file mode 100644
index 2bee63d69776..000000000000
--- a/devel/openthreads/files/patch-Make::makerules
+++ /dev/null
@@ -1,20 +0,0 @@
---- Make/makerules.orig Thu Oct 16 19:39:35 2003
-+++ Make/makerules Thu Oct 16 19:40:50 2003
-@@ -89,7 +89,7 @@
- $(EXEC:=.opt) :
- @[ -d $(OPTDIR) ] || mkdir $(OPTDIR)
- @cd $(OPTDIR); \
-- $(MAKE) -f ../GNUmakefile DOF=$(OPTF) TOPDIR=../${TOPDIR} \
-+ $(MAKE) -f ../GNUmakefile "DOF=$(OPTF)" TOPDIR=../${TOPDIR} \
- THISDIR=../$(THISDIR)\
- MAKEDEPEND=Makedepend $(EXEC)
- @$(MAKE) LNSRC=$(OPTDIR)/$(EXEC) LNDEST=$(BININST)/$(OS)$(ARCH)/$(EXEC) __link
-@@ -98,7 +98,7 @@
- $(LIB:=.opt) :
- @[ -d $(OPTDIR) ] || mkdir $(OPTDIR)
- @cd $(OPTDIR);\
-- $(MAKE) -f ../$(MAKEFILE) DOF=$(OPTF) TOPDIR=../${TOPDIR} \
-+ $(MAKE) -f ../$(MAKEFILE) "DOF=$(OPTF)" TOPDIR=../${TOPDIR} \
- THISDIR=../$(THISDIR)\
- MAKEDEPEND=Makedepend $(LIB)
- @$(MAKE) LNSRC=$(OPTDIR)/$(LIB).$(LIB_EXT) LNDEST=$(LIBINST)/$(OS)$(ARCH)/$(LIB).$(LIB_EXT) __link
diff --git a/devel/openthreads/files/patch-Make_instrules b/devel/openthreads/files/patch-Make_instrules
deleted file mode 100644
index 3a8bc29af332..000000000000
--- a/devel/openthreads/files/patch-Make_instrules
+++ /dev/null
@@ -1,20 +0,0 @@
---- Make/instrules.orig Thu Dec 8 22:28:18 2005
-+++ Make/instrules Mon Sep 25 19:17:55 2006
-@@ -28,13 +28,13 @@
-
- __inst_headers:
- @[ -d $(INST_INCLUDE)/OpenThreads ] || mkdir -p $(INST_INCLUDE)/OpenThreads
-- for f in include/OpenThreads/* ; do\
-- if [ ! -d $$f ];\
-- then\
-+ for f in include/OpenThreads/* ; do \
-+ if [ ! -d $$f ]; \
-+ then \
- [ "`head -1 $$f | cut -c 1-12`" = "/* -*-c++-*-" ] && \
- echo $(INSTRCMD) $$f $(INST_INCLUDE)/OpenThreads; \
- $(INSTRCMD) $$f $(INST_INCLUDE)/OpenThreads; \
-- fi;\
-+ fi; \
- done
-
-
diff --git a/devel/openthreads/pkg-descr b/devel/openthreads/pkg-descr
index 06433aa4c44b..1226571c32a8 100644
--- a/devel/openthreads/pkg-descr
+++ b/devel/openthreads/pkg-descr
@@ -5,5 +5,3 @@ designed around "swappable" thread models which are defined at compile-time in
a shared object library.
WWW: http://openthreads.sourceforge.net/
-
-Maintainer: "Ying-Chieh Chen" <yinjieh@csie.nctu.edu.tw>