aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2008-03-22 21:28:15 +0800
committerleeym <leeym@FreeBSD.org>2008-03-22 21:28:15 +0800
commit71a92f0401a4f87d6db72a4ab48749838052a9bf (patch)
tree6b29d85f9ecd8780ea1eb78a37f91e116ba35393 /devel
parent23ee3071a7b4480aa2ac4597926150a081e557a4 (diff)
downloadfreebsd-ports-gnome-71a92f0401a4f87d6db72a4ab48749838052a9bf.tar.gz
freebsd-ports-gnome-71a92f0401a4f87d6db72a4ab48749838052a9bf.tar.zst
freebsd-ports-gnome-71a92f0401a4f87d6db72a4ab48749838052a9bf.zip
- make YAML and XS/C required, not optional
- bump PORTREVISION Noticed by: pav Pointy hat to: leeym Submitted by: leeym Approved by: clsung
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Module-Build/Makefile20
1 files changed, 5 insertions, 15 deletions
diff --git a/devel/p5-Module-Build/Makefile b/devel/p5-Module-Build/Makefile
index 6fa11c9595ac..6a0a43aaaa61 100644
--- a/devel/p5-Module-Build/Makefile
+++ b/devel/p5-Module-Build/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Module-Build
PORTVERSION= 0.28.08
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -16,13 +16,13 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.(..)$/\1/}
MAINTAINER= clsung@FreeBSD.org
COMMENT= Build and install Perl modules
+RUN_DEPENDS= p5-YAML>=0.35:${PORTSDIR}/textproc/p5-YAML \
+ p5-ExtUtils-CBuilder>=0.15:${PORTSDIR}/devel/p5-ExtUtils-CBuilder \
+ p5-ExtUtils-ParseXS>=1.02:${PORTSDIR}/devel/p5-ExtUtils-ParseXS
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_MODBUILD= yes
-OPTIONS= YAML "Use YAML.pm to write META.yml files" off \
- C "Compile/link C & XS code" off
-
.if !defined(NOPORTDOCS)
PORTDOCS= Changes INSTALL README
@@ -59,14 +59,4 @@ MAN3= Module::Build.3 \
Module::Build::YAML.3
MAN1= config_data.1
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_YAML)
-RUN_DEPENDS+= p5-YAML>=0.35:${PORTSDIR}/textproc/p5-YAML
-.endif
-
-.if defined(WITH_C)
-RUN_DEPENDS+= p5-ExtUtils-CBuilder>=0.15:${PORTSDIR}/devel/p5-ExtUtils-CBuilder
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>