aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-09-02 13:41:50 +0800
committerbsam <bsam@FreeBSD.org>2013-09-02 13:41:50 +0800
commit76068bedb30bd66dfe3e9cc6d7d202042d4f871c (patch)
tree329b9860cec2b8bc443912ad4a52d7732ffc9db3 /devel
parentc2ec996ddec2412e5140b829f58ba8dd3bb0a038 (diff)
downloadfreebsd-ports-gnome-76068bedb30bd66dfe3e9cc6d7d202042d4f871c.tar.gz
freebsd-ports-gnome-76068bedb30bd66dfe3e9cc6d7d202042d4f871c.tar.zst
freebsd-ports-gnome-76068bedb30bd66dfe3e9cc6d7d202042d4f871c.zip
1. Introduce using iconv with arguments:
. lib (default, implicit); . build, . patch. The default is the same, all existing ports stay valid. 2. Introduce variable ICONV_CMD with default to ${LOCALBASE}/bin/iconv. It is intended to get the value of /usr/bin/iconv at recent 10.x. 3. Adopt all ports to using USES+= icomv:build and iconv:patch and change iconv (executable) at Makefile commands to ${ICONV_CMD} at those ports. Submitted by: bsam (me, via e-mail) Approved by: portmgr (bapt)
Diffstat (limited to 'devel')
-rw-r--r--devel/common_lib/Makefile6
-rw-r--r--devel/liblangtag/Makefile3
2 files changed, 4 insertions, 5 deletions
diff --git a/devel/common_lib/Makefile b/devel/common_lib/Makefile
index cb2d5394300b..1d79b9bd5c61 100644
--- a/devel/common_lib/Makefile
+++ b/devel/common_lib/Makefile
@@ -9,8 +9,7 @@ MAINTAINER= olgeni@FreeBSD.org
COMMENT= Library of commonly used Erlang functions
BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang \
- txt2tags:${PORTSDIR}/textproc/txt2tags \
- iconv:${PORTSDIR}/converters/libiconv
+ txt2tags:${PORTSDIR}/textproc/txt2tags
RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang
PLIST_SUB= VERSION="${PORTVERSION}"
@@ -24,6 +23,7 @@ GH_TAGNAME= ${PORTVERSION}
USE_GMAKE= yes
USE_DOS2UNIX= Makefile
ALL_TARGET= compile doc
+USES= iconv:build
MAN1= common_lib.1
MAN3= cl_application.3 cl_binary.3 cl_calendar.3 cl_consumer.3 \
@@ -37,7 +37,7 @@ post-extract:
do-install:
.for manpage in ${MAN1} ${MAN3}
- @iconv -f UTF-8 -t ISO-8859-1 ${WRKSRC}/doc/man/${manpage} > ${WRKSRC}/doc/man/${manpage}.iconv
+ @${ICONV_CMD} -f UTF-8 -t ISO-8859-1 ${WRKSRC}/doc/man/${manpage} > ${WRKSRC}/doc/man/${manpage}.iconv
.endfor
.for manpage in ${MAN1}
@${INSTALL_MAN} ${WRKSRC}/doc/man/${manpage}.iconv ${MAN1PREFIX}/man/man1/${manpage}
diff --git a/devel/liblangtag/Makefile b/devel/liblangtag/Makefile
index 45c710c9fbb9..7ede75c36bda 100644
--- a/devel/liblangtag/Makefile
+++ b/devel/liblangtag/Makefile
@@ -13,7 +13,6 @@ COMMENT= An interface library to access tags for identifying languages
LICENSE= LGPL3 MPL
LICENSE_COMB= dual
-BUILD_DEPENDS= iconv:${PORTSDIR}/converters/libiconv
LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2
GNU_CONFIGURE= yes
@@ -21,7 +20,7 @@ USE_AUTOTOOLS= libtool
USE_BZIP2= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
-USES= pathfix pkgconfig
+USES= iconv:build pathfix pkgconfig
CONFIGURE_ARGS= --disable-introspection