aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-03-16 12:06:48 +0800
committeredwin <edwin@FreeBSD.org>2004-03-16 12:06:48 +0800
commit82eea87e47f93aff8267a8049d58883daf5056e2 (patch)
tree698c45d8e99b9c36daaa3f5b9a1ffa963c355707 /devel
parent7d46f2fe595647f3754710ae5a1cece278ae8faa (diff)
downloadfreebsd-ports-gnome-82eea87e47f93aff8267a8049d58883daf5056e2.tar.gz
freebsd-ports-gnome-82eea87e47f93aff8267a8049d58883daf5056e2.tar.zst
freebsd-ports-gnome-82eea87e47f93aff8267a8049d58883daf5056e2.zip
devel/sdl12: upgrading to 1.2.7 + some fixes.
- upgrade to 1.2.7 - add a knob WITH_NAS - fix dependences to aalib & svgalib - use standard DOCSDIR & EXAMPLESDIR - fix plist for NOPORTDOCS - distribute README-SDL.txt. PR: Based on ports/57475 Submitted by: Thierry Thomas <thierry@pompo.net> Reviewed by: kris@ with a build on bento
Diffstat (limited to 'devel')
-rw-r--r--devel/sdl12/Makefile45
-rw-r--r--devel/sdl12/distinfo4
-rw-r--r--devel/sdl12/files/patch-ac30
-rw-r--r--devel/sdl12/files/patch-ag32
-rw-r--r--devel/sdl12/files/patch-ah33
-rw-r--r--devel/sdl12/files/patch-ai12
-rw-r--r--devel/sdl12/files/patch-aj62
-rw-r--r--devel/sdl12/files/patch-joystick::bsd::SDL_sysjoystick.c165
-rw-r--r--devel/sdl12/files/patch-src::video::SDL_stretch.c18
-rw-r--r--devel/sdl12/pkg-descr2
-rw-r--r--devel/sdl12/pkg-plist9
11 files changed, 134 insertions, 278 deletions
diff --git a/devel/sdl12/Makefile b/devel/sdl12/Makefile
index 22ef7ea11a6d..bd957adcf30b 100644
--- a/devel/sdl12/Makefile
+++ b/devel/sdl12/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sdl
-PORTVERSION= 1.2.5
-PORTREVISION= 3
+PORTVERSION= 1.2.7
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= http://www.libsdl.org/release/
@@ -23,18 +22,26 @@ INSTALLS_SHLIB= yes
USE_REINPLACE= yes
USE_LIBTOOL_VER= 13
WANT_GNOME= yes
-CONFIGURE_ENV= NASM="${LOCALBASE}/bin/nasm" \
- PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}"
+CONFIGURE_ENV= NASM="${LOCALBASE}/bin/nasm" \
+ PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}" \
+ LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-video-aalib \
- --disable-nas
+ --target=
-CFLAGS+= ${PTHREAD_CFLAGS}
+CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.if !defined(NOPORTDOCS)
PORTDOCS= *
.endif
+OPTIONS= NAS "Include support for the Network Audio System" Off \
+ X11 "Include support for X11" On \
+ GL "Include support for OpenGL" Off
+
+.include <bsd.port.pre.mk>
+
.if exists(/usr/lib/libvgl.so.3)
CONFIGURE_ARGS+=--enable-video-vgl
DISPLAY_MSG= ${CAT} ${PKGMESSAGE}
@@ -44,10 +51,16 @@ PKGMESSAGE= /I/hate/ports/Mk/bsd.port.mk
DISPLAY_MSG= ${DO_NADA}
.endif
-.if !defined(WITHOUT_X11)
+.if defined(WITH_NAS)
+LIB_DEPENDS+= audio.2:${PORTSDIR}/audio/nas
+.else
+CONFIGURE_ARGS+=--disable-nas
+.endif
+
+.if defined(WITH_X11)
USE_XLIB= yes
.endif
-.if defined(WITHOUT_GL)
+.if !defined(WITH_GL)
CONFIGURE_ARGS+=--disable-video-opengl
.else
USE_GL= yes
@@ -60,8 +73,6 @@ CFLAGS+= -DHAVE_LIBUSBHID_H
CONFIGURE_ENV+= USB_LIBS=-lusb
.endif
-.include <bsd.port.pre.mk>
-
MAN3!= ${CAT} ${FILESDIR}/man3
.if (${ARCH} != "i386")
@@ -86,6 +97,11 @@ CONFIGURE_ARGS+=--enable-arts
CONFIGURE_ARGS+=--disable-arts
.endif
+post-patch:
+ @${REINPLACE_CMD} 's|sdl-config|sdl11-config|g' \
+ ${WRKSRC}/test/configure
+ @${RM} ${WRKSRC}/test/configure.bak
+
pre-configure:
@${FIND} ${WRKSRC} -type f -name Makefile.in | ${XARGS} ${TOUCH}
@@ -99,11 +115,14 @@ post-configure:
post-install:
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/test/* ${EXAMPLESDIR}
+ @${INSTALL_SCRIPT} ${WRKSRC}/test/configure ${EXAMPLESDIR}
+ @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}/docs
-.for file in BUGS COPYING CREDITS README WhatsNew docs.html
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.for f in BUGS COPYING CREDITS README README-SDL.txt WhatsNew docs.html
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
@cd ${WRKSRC}/docs; ${TAR} cf - `${ECHO_CMD} [^Mm]*` | \
(cd ${DOCSDIR}/docs; ${TAR} --unlink -xf - )
.endif
diff --git a/devel/sdl12/distinfo b/devel/sdl12/distinfo
index 7ac9a54a8fbe..db7e423b1626 100644
--- a/devel/sdl12/distinfo
+++ b/devel/sdl12/distinfo
@@ -1,2 +1,2 @@
-MD5 (SDL-1.2.5.tar.gz) = cacacf4e4cca546de168fedc23b9b44b
-SIZE (SDL-1.2.5.tar.gz) = 1854550
+MD5 (SDL-1.2.7.tar.gz) = d29b34b6ba3ed213893fc9d8d35e357a
+SIZE (SDL-1.2.7.tar.gz) = 2470936
diff --git a/devel/sdl12/files/patch-ac b/devel/sdl12/files/patch-ac
index 81c1a6c8de4f..234eed10fe84 100644
--- a/devel/sdl12/files/patch-ac
+++ b/devel/sdl12/files/patch-ac
@@ -1,21 +1,15 @@
-
-$FreeBSD$
-
---- configure.orig Sun Oct 6 23:35:02 2002
-+++ configure Fri Jun 27 22:19:43 2003
-@@ -674,9 +674,9 @@
+--- configure.orig Mon Feb 23 08:32:33 2004
++++ configure Mon Mar 8 16:17:17 2004
+@@ -19138,7 +19138,7 @@
- # libtool versioning
- LT_RELEASE=$SDL_MAJOR_VERSION.$SDL_MINOR_VERSION
--LT_CURRENT=`expr $SDL_MICRO_VERSION - $SDL_INTERFACE_AGE`
-+LT_CURRENT=$SDL_INTERFACE_AGE
- LT_REVISION=$SDL_INTERFACE_AGE
--LT_AGE=`expr $SDL_BINARY_AGE - $SDL_INTERFACE_AGE`
-+LT_AGE=$SDL_INTERFACE_AGE
+ # This can be used to rebuild libtool when needed
+-LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++LIBTOOL_DEPS="--disable-ltlibs /usr/local/share/libtool13/ltmain.sh"
-
-@@ -2794,7 +2794,7 @@
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -21171,7 +21171,7 @@
SDL_CFLAGS=""
@@ -24,7 +18,7 @@ $FreeBSD$
case "$target" in
-@@ -5840,8 +5840,8 @@
+@@ -25926,8 +25926,8 @@
# pthread_cflags="-D_REENTRANT -D_THREAD_SAFE"
;;
*-*-freebsd*)
@@ -35,11 +29,11 @@ $FreeBSD$
;;
*-*-netbsd*)
pthread_cflags="-I/usr/pkg/include -D_REENTRANT"
-@@ -6946,7 +6946,9 @@
+@@ -28401,7 +28401,9 @@
CFLAGS="$CFLAGS -DHAVE_USBHID_H"
fi
if test x$have_libusb_h = xyes; then
-+ if x$have_libusbhid_h = xno; then
++ if test x$have_libusbhid_h = xno; then
CFLAGS="$CFLAGS -DHAVE_LIBUSB_H"
+ fi
fi
diff --git a/devel/sdl12/files/patch-ag b/devel/sdl12/files/patch-ag
index 303d3b2889e9..ac69a60f0726 100644
--- a/devel/sdl12/files/patch-ag
+++ b/devel/sdl12/files/patch-ag
@@ -1,24 +1,26 @@
---- src/Makefile.in.orig Fri Mar 31 08:31:12 2000
-+++ src/Makefile.in Sun Apr 23 23:45:07 2000
-@@ -118,10 +118,10 @@
+--- src/Makefile.in.orig Mon Feb 23 08:32:05 2004
++++ src/Makefile.in Mon Mar 8 18:41:14 2004
+@@ -296,12 +296,12 @@
DIST_SUBDIRS = $(CORE_SUBDIRS) $(EXTRA_SUBDIRS)
# The SDL library target
-lib_LTLIBRARIES = libSDL.la
+lib_LTLIBRARIES = libSDL-1.1.la
-
libSDL_la_SOURCES = $(GENERAL_SRCS)
--libSDL_la_LDFLAGS = -release $(LT_RELEASE) -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
-+libSDL_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
-
- libSDL_la_LIBADD = main/libarch.la @SDL_EXTRALIBS@ @SYSTEM_LIBS@
-
-@@ -239,7 +239,7 @@
-
- maintainer-clean-libtool:
+ libSDL_la_LDFLAGS = \
+ -no-undefined \
+- -release $(LT_RELEASE) \
+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
++# -release $(LT_RELEASE) \
--libSDL.la: $(libSDL_la_OBJECTS) $(libSDL_la_DEPENDENCIES)
-+libSDL-1.1.la: $(libSDL_la_OBJECTS) $(libSDL_la_DEPENDENCIES)
+ libSDL_la_LIBADD = \
+ main/libarch.la \
+@@ -383,7 +383,7 @@
+ echo "rm -f \"$${dir}/so_locations\""; \
+ rm -f "$${dir}/so_locations"; \
+ done
+-libSDL.la: $(libSDL_la_OBJECTS) $(libSDL_la_DEPENDENCIES)
++libSDL-1.1.la: $(libSDL_la_OBJECTS) $(libSDL_la_DEPENDENCIES)
$(LINK) -rpath $(libdir) $(libSDL_la_LDFLAGS) $(libSDL_la_OBJECTS) $(libSDL_la_LIBADD) $(LIBS)
- # This directory's subdirectories are mostly independent; you can cd
+ mostlyclean-compile:
diff --git a/devel/sdl12/files/patch-ah b/devel/sdl12/files/patch-ah
index 04b4bdce3748..93855790593f 100644
--- a/devel/sdl12/files/patch-ah
+++ b/devel/sdl12/files/patch-ah
@@ -1,29 +1,26 @@
-
-$FreeBSD$
-
---- src/main/Makefile.in.orig Thu Nov 8 09:28:02 2001
-+++ src/main/Makefile.in Tue Nov 13 15:48:40 2001
-@@ -117,7 +117,7 @@
+--- src/main/Makefile.in.orig Mon Feb 23 08:32:20 2004
++++ src/main/Makefile.in Mon Mar 8 15:59:18 2004
+@@ -319,7 +319,7 @@
# Build a separate library containing the main() entry point.
-lib_LIBRARIES = libSDLmain.a
+lib_LIBRARIES = libSDLmain-1.1.a
- @TARGET_MACOSX_TRUE@MAINLIB_ARCH_SRCS = SDLMain.m SDLMain.h
- @TARGET_MACOSX_FALSE@MAINLIB_ARCH_SRCS = SDL_main.c
+ @TARGET_MACOSX_FALSE@@TARGET_QTOPIA_FALSE@@TARGET_WIN32_FALSE@MAINLIB_ARCH_SRCS = dummy/SDL_dummy_main.c
+ @TARGET_MACOSX_FALSE@@TARGET_QTOPIA_TRUE@@TARGET_WIN32_FALSE@MAINLIB_ARCH_SRCS = qtopia/SDL_qtopia_main.cc
+ @TARGET_MACOSX_TRUE@@TARGET_WIN32_FALSE@MAINLIB_ARCH_SRCS = macosx/SDLMain.m macosx/SDLMain.h
+@@ -393,10 +393,10 @@
-@@ -264,10 +264,10 @@
-
- maintainer-clean-libtool:
-
--libSDLmain.a: $(libSDLmain_a_OBJECTS) $(libSDLmain_a_DEPENDENCIES)
+ clean-libLIBRARIES:
+ -test -z "$(lib_LIBRARIES)" || rm -f $(lib_LIBRARIES)
+-libSDLmain.a: $(libSDLmain_a_OBJECTS) $(libSDLmain_a_DEPENDENCIES)
- -rm -f libSDLmain.a
-- $(AR) cru libSDLmain.a $(libSDLmain_a_OBJECTS) $(libSDLmain_a_LIBADD)
+- $(libSDLmain_a_AR) libSDLmain.a $(libSDLmain_a_OBJECTS) $(libSDLmain_a_LIBADD)
- $(RANLIB) libSDLmain.a
-+libSDLmain-1.1.a: $(libSDLmain_a_OBJECTS) $(libSDLmain_a_DEPENDENCIES)
++libSDLmain-1.1.a: $(libSDLmain_a_OBJECTS) $(libSDLmain_a_DEPENDENCIES)
+ -rm -f libSDLmain-1.1.a
-+ $(AR) cru libSDLmain-1.1.a $(libSDLmain_a_OBJECTS) $(libSDLmain_a_LIBADD)
++ $(libSDLmain_a_AR) libSDLmain-1.1.a $(libSDLmain_a_OBJECTS) $(libSDLmain_a_LIBADD)
+ $(RANLIB) libSDLmain-1.1.a
- mostlyclean-noinstLTLIBRARIES:
-
+ clean-noinstLTLIBRARIES:
+ -test -z "$(noinst_LTLIBRARIES)" || rm -f $(noinst_LTLIBRARIES)
diff --git a/devel/sdl12/files/patch-ai b/devel/sdl12/files/patch-ai
index 6084e7e540c3..797e6bc54295 100644
--- a/devel/sdl12/files/patch-ai
+++ b/devel/sdl12/files/patch-ai
@@ -1,11 +1,11 @@
---- include/Makefile.in.orig Sun Apr 23 22:34:25 2000
-+++ include/Makefile.in Sun Apr 23 22:34:43 2000
-@@ -106,7 +106,7 @@
- with_gcc = @with_gcc@
- with_gnu_ld = @with_gnu_ld@
+--- include/Makefile.in.orig Mon Feb 23 08:32:04 2004
++++ include/Makefile.in Mon Mar 8 16:00:11 2004
+@@ -256,7 +256,7 @@
+ target_vendor = @target_vendor@
+ # The directory where the include files will be installed
-libSDLincludedir = $(includedir)/SDL
+libSDLincludedir = $(includedir)/SDL11
# Which header files to install
- libSDLinclude_HEADERS = SDL.h SDL_active.h SDL_audio.h SDL_byteorder.h SDL_cdrom.h SDL_copying.h SDL_endian.h SDL_error.h SDL_events.h SDL_joystick.h SDL_keyboard.h SDL_keysym.h SDL_main.h SDL_mouse.h SDL_mutex.h SDL_quit.h SDL_rwops.h SDL_syswm.h SDL_thread.h SDL_timer.h SDL_types.h SDL_version.h SDL_video.h begin_code.h close_code.h
+ libSDLinclude_HEADERS = \
diff --git a/devel/sdl12/files/patch-aj b/devel/sdl12/files/patch-aj
index 1aea9b14afdd..057d3a9e88cd 100644
--- a/devel/sdl12/files/patch-aj
+++ b/devel/sdl12/files/patch-aj
@@ -1,33 +1,46 @@
-
-$FreeBSD$
-
---- Makefile.in.orig Fri Jan 5 22:18:18 2001
-+++ Makefile.in Wed Jan 24 12:02:04 2001
-@@ -44,10 +44,10 @@
-
- top_builddir = .
-
+--- Makefile.in.orig Mon Feb 23 08:32:04 2004
++++ Makefile.in Mon Mar 8 16:01:47 2004
+@@ -81,7 +81,7 @@
+ GZIP_ENV = --best
+ distuninstallcheck_listfiles = find . -type f -print
+ distcleancheck_listfiles = find . -type f -print
-ACLOCAL = @ACLOCAL@
++ACLOCAL = #@ACLOCAL@
+ ALLOCA = @ALLOCA@
+ AMDEP_FALSE = @AMDEP_FALSE@
+ AMDEP_TRUE = @AMDEP_TRUE@
+@@ -93,9 +93,9 @@
+ ASFLAGS = @ASFLAGS@
+ AUDIO_DRIVERS = @AUDIO_DRIVERS@
+ AUDIO_SUBDIRS = @AUDIO_SUBDIRS@
-AUTOCONF = @AUTOCONF@
--AUTOMAKE = @AUTOMAKE@
-AUTOHEADER = @AUTOHEADER@
-+ACLOCAL = #@ACLOCAL@
+-AUTOMAKE = @AUTOMAKE@
+AUTOCONF = #@AUTOCONF@
-+AUTOMAKE = #@AUTOMAKE@
+AUTOHEADER = #@AUTOHEADER@
-
- INSTALL = @INSTALL@
- INSTALL_PROGRAM = @INSTALL_PROGRAM@
-@@ -110,7 +110,7 @@
- DIST_SUBDIRS = $(SUBDIRS) docs
++AUTOMAKE = #@AUTOMAKE@
+ AWK = @AWK@
+ CC = @CC@
+ CCAS = @CCAS@
+@@ -285,7 +285,7 @@
+ DIST_SUBDIRS = $(SUBDIRS)
# SDL runtime configuration script
-bin_SCRIPTS = sdl-config
+bin_SCRIPTS = sdl11-config
# All the rest of the distributed files
- EXTRA_DIST = BUGS TODO COPYING CREDITS INSTALL README README-SDL.txt README.Win32 README.MacOS README.MacOSX VisualC.html VisualC.zip CWprojects.sea.hqx MPWmake.sea.hqx WhatsNew docs.html sdl.m4 autogen.sh strip_fPIC.sh
-@@ -118,7 +118,7 @@
+ EXTRA_DIST = \
+@@ -321,7 +321,7 @@
+ EpocBuildFiles.zip \
+ WhatsNew \
+ docs.html \
+- sdl.m4 \
++ sdl11.m4 \
+ SDL.spec \
+ autogen.sh \
+ strip_fPIC.sh
+@@ -329,7 +329,7 @@
# M4 macro file for inclusion with autoconf
m4datadir = $(datadir)/aclocal
@@ -35,4 +48,13 @@ $FreeBSD$
+m4data_DATA = sdl11.m4
# Create a CVS snapshot that people can run update -d on
- CVSROOT = :pserver:guest@cvs.lokigames.com:/cvs
+ CVSROOT = :pserver:guest@libsdl.org:/home/sdlweb/libsdl.org/cvs
+@@ -369,7 +369,7 @@
+ cd $(srcdir) && $(AUTOCONF)
+ $(ACLOCAL_M4): $(am__aclocal_m4_deps)
+ cd $(srcdir) && $(ACLOCAL) $(ACLOCAL_AMFLAGS)
+-sdl-config: $(top_builddir)/config.status $(srcdir)/sdl-config.in
++sdl11-config: $(top_builddir)/config.status $(srcdir)/sdl-config.in
+ cd $(top_builddir) && $(SHELL) ./config.status $@
+ SDL.spec: $(top_builddir)/config.status $(srcdir)/SDL.spec.in
+ cd $(top_builddir) && $(SHELL) ./config.status $@
diff --git a/devel/sdl12/files/patch-joystick::bsd::SDL_sysjoystick.c b/devel/sdl12/files/patch-joystick::bsd::SDL_sysjoystick.c
deleted file mode 100644
index 9dd750180e4f..000000000000
--- a/devel/sdl12/files/patch-joystick::bsd::SDL_sysjoystick.c
+++ /dev/null
@@ -1,165 +0,0 @@
-
-$FreeBSD$
-
---- src/joystick/bsd/SDL_sysjoystick.c.orig Sat Oct 5 08:32:49 2002
-+++ src/joystick/bsd/SDL_sysjoystick.c Mon Jul 14 21:12:23 2003
-@@ -53,6 +53,11 @@
- #include <libusbhid.h>
- #endif
-
-+#ifdef __FreeBSD__
-+#include <osreldate.h>
-+#include <sys/joystick.h>
-+#endif
-+
- #include "SDL_error.h"
- #include "SDL_joystick.h"
- #include "SDL_sysjoystick.h"
-@@ -192,7 +197,18 @@
- joy->hwdata = hw;
- hw->fd = fd;
- hw->path = strdup(path);
-- hw->type = BSDJOY_UHID;
-+ if (! strncmp(path, "/dev/joy", 8))
-+ {
-+ hw->type = BSDJOY_JOY;
-+ joy->naxes = 2;
-+ joy->nbuttons = 2;
-+ joy->nhats = 0;
-+ joy->nballs = 0;
-+ joydevnames[joy->index] = strdup("Gameport joystick");
-+ goto usbend;
-+ }
-+ else
-+ hw->type = BSDJOY_UHID;
- hw->repdesc = hid_get_report_desc(fd);
- if (hw->repdesc == NULL) {
- SDL_SetError("%s: USB_GET_REPORT_DESC: %s", hw->path,
-@@ -201,6 +217,7 @@
- }
-
- rep = &hw->inreport;
-+ rep->rid = 0;
- if (report_alloc(rep, hw->repdesc, REPORT_INPUT) < 0) {
- goto usberr;
- }
-@@ -210,7 +227,7 @@
- goto usberr;
- }
-
--#ifdef USBHID_NEW
-+#if defined(USBHID_NEW) || (defined(__FreeBSD__) && __FreeBSD_version >= 500111)
- hdata = hid_start_parse(hw->repdesc, 1 << hid_input, rep->rid);
- #else
- hdata = hid_start_parse(hw->repdesc, 1 << hid_input);
-@@ -275,6 +292,7 @@
- }
- hid_end_parse(hdata);
-
-+usbend:
- /* The poll blocks the event thread. */
- fcntl(fd, F_SETFL, O_NONBLOCK);
-
-@@ -294,13 +312,62 @@
- struct report *rep;
- int nbutton, naxe = -1;
- Sint32 v;
-+ struct joystick gameport;
-+ static int x, y, xmin=0xffff, ymin=0xffff, xmax=0, ymax=0;
-+
-+ if (!strncmp(joy->hwdata->path, "/dev/joy", 8)) {
-+ if (read(joy->hwdata->fd, &gameport, sizeof(gameport)) != sizeof(gameport)) {
-+ return;
-+ }
-+ if (abs(x - gameport.x) > 8) {
-+ x = gameport.x;
-+ if (x < xmin) {
-+ xmin = x;
-+ }
-+ if (x > xmax) {
-+ xmax = x;
-+ }
-+ if (xmin == xmax) {
-+ xmin--;
-+ xmax++;
-+ }
-+ v = (Sint32)x;
-+ v -= (xmax + xmin + 1)/2;
-+ v *= 32768/((xmax - xmin + 1)/2);
-+ SDL_PrivateJoystickAxis(joy, 0, v);
-+ }
-+ if (abs(y - gameport.y) > 8) {
-+ y = gameport.y;
-+ if (y < ymin) {
-+ ymin = y;
-+ }
-+ if (y > ymax) {
-+ ymax = y;
-+ }
-+ if (ymin == ymax) {
-+ ymin--;
-+ ymax++;
-+ }
-+ v = (Sint32)y;
-+ v -= (ymax + ymin + 1)/2;
-+ v *= 32768/((ymax - ymin + 1)/2);
-+ SDL_PrivateJoystickAxis(joy, 1, v);
-+ }
-+ if (gameport.b1 != joy->buttons[0]) {
-+ SDL_PrivateJoystickButton(joy, 0, gameport.b1);
-+ }
-+ if (gameport.b2 != joy->buttons[1]) {
-+ SDL_PrivateJoystickButton(joy, 1, gameport.b2);
-+ }
-+ return;
-+ }
-
- rep = &joy->hwdata->inreport;
-
- if (read(joy->hwdata->fd, REP_BUF_DATA(rep), rep->size) != rep->size) {
- return;
- }
--#ifdef USBHID_NEW
-+#if defined(USBHID_NEW) || (defined(__FreeBSD__) && __FreeBSD_version >= 500111)
- hdata = hid_start_parse(joy->hwdata->repdesc, 1 << hid_input, rep->rid);
- #else
- hdata = hid_start_parse(joy->hwdata->repdesc, 1 << hid_input);
-@@ -370,8 +437,10 @@
- void
- SDL_SYS_JoystickClose(SDL_Joystick *joy)
- {
-- report_free(&joy->hwdata->inreport);
-- hid_dispose_report_desc(joy->hwdata->repdesc);
-+ if (strncmp(joy->hwdata->path, "/dev/joy", 8)) {
-+ report_free(&joy->hwdata->inreport);
-+ hid_dispose_report_desc(joy->hwdata->repdesc);
-+ }
- close(joy->hwdata->fd);
- free(joy->hwdata->path);
- free(joy->hwdata);
-@@ -399,11 +468,24 @@
- {
- int len;
-
--#ifdef USBHID_NEW
-+#ifdef __FreeBSD__
-+# if (__FreeBSD_version >= 470000)
-+# if ((__FreeBSD_version <= 500111) && (__FreeBSD_version >= 480000))
-+ len = hid_report_size(rd, r->rid, repinfo[repind].kind);
-+# else
-+ len = hid_report_size(rd, repinfo[repind].kind, r->rid);
-+# endif
-+# else
- len = hid_report_size(rd, repinfo[repind].kind, &r->rid);
-+#endif
- #else
-+# ifdef USBHID_NEW
-+ len = hid_report_size(rd, repinfo[repind].kind, &r->rid);
-+# else
- len = hid_report_size(rd, repinfo[repind].kind, r->rid);
-+# endif
- #endif
-+
- if (len < 0) {
- SDL_SetError("Negative HID report size");
- return (-1);
diff --git a/devel/sdl12/files/patch-src::video::SDL_stretch.c b/devel/sdl12/files/patch-src::video::SDL_stretch.c
deleted file mode 100644
index 4bb10b67a2a0..000000000000
--- a/devel/sdl12/files/patch-src::video::SDL_stretch.c
+++ /dev/null
@@ -1,18 +0,0 @@
-
-$FreeBSD$
-
---- src/video/SDL_stretch.c 2003/07/14 18:17:21 1.1
-+++ src/video/SDL_stretch.c 2003/07/14 18:18:39
-@@ -261,9 +261,9 @@
- break;
- default:
- #ifdef __GNUC__
-- __asm__ __volatile__ ("
-- call _copy_row
-- "
-+ __asm__ __volatile__ (""
-+ " call _copy_row"
-+ ""
- : "=&D" (u1), "=&S" (u2)
- : "0" (dstp), "1" (srcp)
- : "memory" );
diff --git a/devel/sdl12/pkg-descr b/devel/sdl12/pkg-descr
index 30ea42683300..30cb7e9b4da6 100644
--- a/devel/sdl12/pkg-descr
+++ b/devel/sdl12/pkg-descr
@@ -1,5 +1,3 @@
-Unstable development version of the SDL library.
-
This library is designed to make it easy to write games that run on UNIX,
Win32 and BeOS using the various native high-performance media interfaces,
(for video, audio, etc) and presenting a single source-code level API to
diff --git a/devel/sdl12/pkg-plist b/devel/sdl12/pkg-plist
index 0fe3c9286443..5cb052b5e40e 100644
--- a/devel/sdl12/pkg-plist
+++ b/devel/sdl12/pkg-plist
@@ -5,6 +5,7 @@ include/SDL11/SDL_audio.h
include/SDL11/SDL_byteorder.h
include/SDL11/SDL_cdrom.h
include/SDL11/SDL_copying.h
+include/SDL11/SDL_cpuinfo.h
include/SDL11/SDL_endian.h
include/SDL11/SDL_error.h
include/SDL11/SDL_events.h
@@ -12,6 +13,7 @@ include/SDL11/SDL_getenv.h
include/SDL11/SDL_joystick.h
include/SDL11/SDL_keyboard.h
include/SDL11/SDL_keysym.h
+include/SDL11/SDL_loadso.h
include/SDL11/SDL_main.h
include/SDL11/SDL_mouse.h
include/SDL11/SDL_mutex.h
@@ -28,8 +30,9 @@ include/SDL11/SDL_video.h
include/SDL11/begin_code.h
include/SDL11/close_code.h
lib/libSDL-1.1.a
+lib/libSDL-1.1.la
lib/libSDL-1.1.so
-lib/libSDL-1.1.so.5
+lib/libSDL-1.1.so.7
lib/libSDLmain-1.1.a
share/aclocal/sdl11.m4
%%EXAMPLESDIR%%/COPYING
@@ -50,6 +53,7 @@ share/aclocal/sdl11.m4
%%EXAMPLESDIR%%/loopwave.c
%%EXAMPLESDIR%%/missing
%%EXAMPLESDIR%%/mkinstalldirs
+%%EXAMPLESDIR%%/moose.dat
%%EXAMPLESDIR%%/picture.xbm
%%EXAMPLESDIR%%/sail.bmp
%%EXAMPLESDIR%%/sample.bmp
@@ -57,6 +61,8 @@ share/aclocal/sdl11.m4
%%EXAMPLESDIR%%/testalpha.c
%%EXAMPLESDIR%%/testbitmap.c
%%EXAMPLESDIR%%/testcdrom.c
+%%EXAMPLESDIR%%/testcpuinfo.c
+%%EXAMPLESDIR%%/testdyngl.c
%%EXAMPLESDIR%%/testerror.c
%%EXAMPLESDIR%%/testgamma.c
%%EXAMPLESDIR%%/testgl.c
@@ -65,6 +71,7 @@ share/aclocal/sdl11.m4
%%EXAMPLESDIR%%/testkeys.c
%%EXAMPLESDIR%%/testlock.c
%%EXAMPLESDIR%%/testoverlay.c
+%%EXAMPLESDIR%%/testoverlay2.c
%%EXAMPLESDIR%%/testpalette.c
%%EXAMPLESDIR%%/testsem.c
%%EXAMPLESDIR%%/testsprite.c