aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-12-22 21:27:46 +0800
committerijliao <ijliao@FreeBSD.org>2002-12-22 21:27:46 +0800
commit8d8e5fb54e012ee02146fdb350f02deefab72564 (patch)
tree7c84e3ef0748bc06016260e3253178a42342c0ba /devel
parent43ad343dbb1a2dc06e008c8815f876e092c28aff (diff)
downloadfreebsd-ports-gnome-8d8e5fb54e012ee02146fdb350f02deefab72564.tar.gz
freebsd-ports-gnome-8d8e5fb54e012ee02146fdb350f02deefab72564.tar.zst
freebsd-ports-gnome-8d8e5fb54e012ee02146fdb350f02deefab72564.zip
fix build on -current
PR: 46461 Submitted by: Ports Fury
Diffstat (limited to 'devel')
-rw-r--r--devel/regexx/Makefile8
-rw-r--r--devel/regexx/files/patch-examples::simple.cc10
-rw-r--r--devel/regexx/files/patch-src::regex.hh47
3 files changed, 60 insertions, 5 deletions
diff --git a/devel/regexx/Makefile b/devel/regexx/Makefile
index a07ba4828fcc..9c771502c133 100644
--- a/devel/regexx/Makefile
+++ b/devel/regexx/Makefile
@@ -16,12 +16,10 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
-USE_LIBTOOL= yes
-USE_AUTOMAKE= yes
-USE_AUTOCONF= yes
-
USE_GMAKE= yes
-
+USE_AUTOMAKE_VER= 14
+USE_AUTOCONF_VER= 213
+USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
.include <bsd.port.mk>
diff --git a/devel/regexx/files/patch-examples::simple.cc b/devel/regexx/files/patch-examples::simple.cc
new file mode 100644
index 000000000000..504f5d61509a
--- /dev/null
+++ b/devel/regexx/files/patch-examples::simple.cc
@@ -0,0 +1,10 @@
+--- examples/simple.cc.orig Tue Mar 13 23:42:21 2001
++++ examples/simple.cc Sun Dec 22 03:09:56 2002
+@@ -30,6 +30,7 @@
+ #include <regexx.hh>
+
+ using namespace regexx;
++using namespace std;
+
+ //
+ // This is the function to pass to replace() in
diff --git a/devel/regexx/files/patch-src::regex.hh b/devel/regexx/files/patch-src::regex.hh
new file mode 100644
index 000000000000..a34c40bb818f
--- /dev/null
+++ b/devel/regexx/files/patch-src::regex.hh
@@ -0,0 +1,47 @@
+--- src/regexx.hh.orig Tue Mar 13 23:42:21 2001
++++ src/regexx.hh Sun Dec 22 03:08:47 2002
+@@ -94,7 +94,7 @@
+
+ };
+
+- inline ostream& operator<<(ostream& _o, RegexxMatchAtom& _rxxma)
++ inline std::ostream& operator<<(std::ostream& _o, RegexxMatchAtom& _rxxma)
+ {
+ return _o << _rxxma.str();
+ }
+@@ -161,7 +161,7 @@
+
+ };
+
+- inline ostream& operator<<(ostream& _o, RegexxMatch& _rxxm)
++ inline std::ostream& operator<<(std::ostream& _o, RegexxMatch& _rxxm)
+ {
+ return (_o << _rxxm.str());
+ }
+@@ -566,7 +566,7 @@
+ }
+
+ inline const std::string&
+- Regexx::replacef(std::string (*_func)(const RegexxMatch&), int _flags = 0)
++ Regexx::replacef(std::string (*_func)(const RegexxMatch&), int _flags)
+ throw(CompileException)
+ {
+ exec(_flags&~nomatch);
+@@ -580,7 +580,7 @@
+ inline const std::string&
+ Regexx::replacef(const std::string& _expr,
+ std::string (*_func)(const RegexxMatch&),
+- int _flags = 0)
++ int _flags)
+ throw(CompileException)
+ {
+ expr(_expr);
+@@ -590,7 +590,7 @@
+ inline const std::string&
+ Regexx::replacef(const std::string& _str, const std::string& _expr,
+ std::string (*_func)(const RegexxMatch&),
+- int _flags = 0)
++ int _flags)
+ throw(CompileException)
+ {
+ str(_str);