aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-11-11 22:08:08 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-11-11 22:08:08 +0800
commit9e37628e24045028e0a79abf63df6ad962cca9cf (patch)
tree89649e1b3da8e28a4e9f79f2bf411b8f5af5befc /devel
parent9f591309225f83c5a9e5f083d9c1abb6c451531d (diff)
downloadfreebsd-ports-gnome-9e37628e24045028e0a79abf63df6ad962cca9cf.tar.gz
freebsd-ports-gnome-9e37628e24045028e0a79abf63df6ad962cca9cf.tar.zst
freebsd-ports-gnome-9e37628e24045028e0a79abf63df6ad962cca9cf.zip
- Add p5-UUID-Random-Patch-UseMRS 0.01
UUID::Random::Patch::UseMRS makes UUID::Random use rand() from Math::Random::Secure instead of the default rand() that comes with Perl. It is useful for creating cryptographically secure UUID's. On the other hand, as a note, this makes generate() around 20 times slower. After you use this module, use UUID::Random as usual. WWW: http://search.cpan.org/dist/UUID-Random-Patch-UseMRS/ PR: ports/182322 Submitted by: Henk van Oers <hvo.pm@xs4all.nl>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-UUID-Random-Patch-UseMRS/Makefile23
-rw-r--r--devel/p5-UUID-Random-Patch-UseMRS/distinfo2
-rw-r--r--devel/p5-UUID-Random-Patch-UseMRS/pkg-descr8
-rw-r--r--devel/p5-UUID-Random-Patch-UseMRS/pkg-plist5
5 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ce23fdfeabd4..d672592c8c57 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2975,6 +2975,7 @@
SUBDIR += p5-UNIVERSAL-which
SUBDIR += p5-UUID
SUBDIR += p5-UUID-Random
+ SUBDIR += p5-UUID-Random-Patch-UseMRS
SUBDIR += p5-UUID-Tiny
SUBDIR += p5-Uniq
SUBDIR += p5-Unix-Statgrab
diff --git a/devel/p5-UUID-Random-Patch-UseMRS/Makefile b/devel/p5-UUID-Random-Patch-UseMRS/Makefile
new file mode 100644
index 000000000000..c25183660b0b
--- /dev/null
+++ b/devel/p5-UUID-Random-Patch-UseMRS/Makefile
@@ -0,0 +1,23 @@
+# Created by: Henk van Oers <hvo.pm@xs4all.nl>
+# $FreeBSD$
+
+PORTNAME= UUID-Random-Patch-UseMRS
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Make UUID::Random use Math::Random::Secure::rand()
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Math-Random-Secure>=0:${PORTSDIR}/math/p5-Math-Random-Secure \
+ p5-UUID-Random>=0:${PORTSDIR}/devel/p5-UUID-Random
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_PERL5= modbuild
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/devel/p5-UUID-Random-Patch-UseMRS/distinfo b/devel/p5-UUID-Random-Patch-UseMRS/distinfo
new file mode 100644
index 000000000000..a5d750e879da
--- /dev/null
+++ b/devel/p5-UUID-Random-Patch-UseMRS/distinfo
@@ -0,0 +1,2 @@
+SHA256 (UUID-Random-Patch-UseMRS-0.01.tar.gz) = 85f28345a9c2ee287f3c1283d5c6ec5b49a305c64c1b45bce9d8b8373a93dd73
+SIZE (UUID-Random-Patch-UseMRS-0.01.tar.gz) = 9810
diff --git a/devel/p5-UUID-Random-Patch-UseMRS/pkg-descr b/devel/p5-UUID-Random-Patch-UseMRS/pkg-descr
new file mode 100644
index 000000000000..35343c5803ed
--- /dev/null
+++ b/devel/p5-UUID-Random-Patch-UseMRS/pkg-descr
@@ -0,0 +1,8 @@
+UUID::Random::Patch::UseMRS makes UUID::Random use rand() from
+Math::Random::Secure instead of the default rand() that comes with Perl. It is
+useful for creating cryptographically secure UUID's. On the other hand, as a
+note, this makes generate() around 20 times slower.
+
+After you use this module, use UUID::Random as usual.
+
+WWW: http://search.cpan.org/dist/UUID-Random-Patch-UseMRS/
diff --git a/devel/p5-UUID-Random-Patch-UseMRS/pkg-plist b/devel/p5-UUID-Random-Patch-UseMRS/pkg-plist
new file mode 100644
index 000000000000..045e48d2dbe7
--- /dev/null
+++ b/devel/p5-UUID-Random-Patch-UseMRS/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/UUID/Random/Patch/UseMRS.pm
+%%PERL5_MAN3%%/UUID::Random::Patch::UseMRS.3.gz
+@dirrmtry %%SITE_PERL%%/UUID/Random/Patch
+@dirrmtry %%SITE_PERL%%/UUID/Random
+@dirrmtry %%SITE_PERL%%/UUID