aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2007-02-15 00:52:40 +0800
committerale <ale@FreeBSD.org>2007-02-15 00:52:40 +0800
commita831e75341abd2dc0c318aad39a73e488774f265 (patch)
treeef72269bde2140a9b2b78affc22befd8e7960ea7 /devel
parent1fb971a29a0feaa852dc2a199f30147688f56cda (diff)
downloadfreebsd-ports-gnome-a831e75341abd2dc0c318aad39a73e488774f265.tar.gz
freebsd-ports-gnome-a831e75341abd2dc0c318aad39a73e488774f265.tar.zst
freebsd-ports-gnome-a831e75341abd2dc0c318aad39a73e488774f265.zip
The Subversive project is a brand new Eclipse plug-in that provides
Subversion support. From a user point of view, Subversive provides Subversion support similar to CVS support, which is already part of the standard Eclipse platform. The main use cases, which are familiar to CVS users, are: * Connection to the repository using different connection types * Repository browsing * Check-out * Synchronization * Commiting * Update * Resolving conflicts * Adding to the list of ignored resources WWW: http://www.polarion.org/index.php?page=overview&project=subversive
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/Subversive/Makefile34
-rw-r--r--devel/Subversive/distinfo3
-rw-r--r--devel/Subversive/pkg-descr19
4 files changed, 57 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 669b2774ddeb..271e05375d14 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -8,6 +8,7 @@
SUBDIR += ORBit2
SUBDIR += ORBit2-reference
SUBDIR += SpecTcl
+ SUBDIR += Subversive
SUBDIR += ZendOptimizer
SUBDIR += a2dev
SUBDIR += aap
diff --git a/devel/Subversive/Makefile b/devel/Subversive/Makefile
new file mode 100644
index 000000000000..9167feaaeaef
--- /dev/null
+++ b/devel/Subversive/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: Subversive
+# Date created: 14 Feb 2007
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Subversive
+DISTVERSION= 1.1.0.RC5
+CATEGORIES= devel java
+MASTER_SITES= http://www.polarion.org/projects/subversive/download/1.1/builds/
+DISTNAME= ${PORTNAME}_${DISTVERSION}-LocalUpdateSite
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= An Eclipse plug-in that provides Subversion support
+
+RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse \
+ svn:${PORTSDIR}/devel/subversion
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+JAVA_OS= native
+
+do-install:
+ @${MKDIR} ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/plugins ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/features ${PREFIX}/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s features plugins -not -type d) | \
+ ${SED} -ne 's,^,eclipse/,p' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/devel/Subversive/distinfo b/devel/Subversive/distinfo
new file mode 100644
index 000000000000..4e5b69607915
--- /dev/null
+++ b/devel/Subversive/distinfo
@@ -0,0 +1,3 @@
+MD5 (Subversive_1.1.0.RC5-LocalUpdateSite.zip) = d054727a6b6eb1b42c51ce2dc2e4058d
+SHA256 (Subversive_1.1.0.RC5-LocalUpdateSite.zip) = d8e025a3a14787c7d204a8713fa662003c6af5f1f1f41300951e73a57c913b57
+SIZE (Subversive_1.1.0.RC5-LocalUpdateSite.zip) = 6275463
diff --git a/devel/Subversive/pkg-descr b/devel/Subversive/pkg-descr
new file mode 100644
index 000000000000..d8c42630fc3b
--- /dev/null
+++ b/devel/Subversive/pkg-descr
@@ -0,0 +1,19 @@
+The Subversive project is a brand new Eclipse plug-in that provides
+Subversion support. From a user point of view, Subversive provides
+Subversion support similar to CVS support, which is already part of
+the standard Eclipse platform.
+
+The main use cases, which are familiar to CVS users, are:
+ * Connection to the repository using different connection types
+ * Repository browsing
+ * Check-out
+ * Synchronization
+ * Commiting
+ * Update
+ * Resolving conflicts
+ * Adding to the list of ignored resources
+
+WWW: http://www.polarion.org/index.php?page=overview&project=subversive
+
+- Alex Dupre
+ale@FreeBSD.org