aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2001-11-15 13:58:49 +0800
committerpetef <petef@FreeBSD.org>2001-11-15 13:58:49 +0800
commitc2397384bb105c7bd4d8b7ab0308fd517b5925bc (patch)
treee4e347d7e8104b26cf1101a0be1a10ff66b2f7fb /devel
parente016c5f655acf008917d4a1a7dc739277b572121 (diff)
downloadfreebsd-ports-gnome-c2397384bb105c7bd4d8b7ab0308fd517b5925bc.tar.gz
freebsd-ports-gnome-c2397384bb105c7bd4d8b7ab0308fd517b5925bc.tar.zst
freebsd-ports-gnome-c2397384bb105c7bd4d8b7ab0308fd517b5925bc.zip
- add NOPORTDOCS support & install documentation
- minor indentation fix in pkg-descr - add @comment $FreeBSD$ to pkg-plist & sort PR: 31543 Submitted by: maintainer
Diffstat (limited to 'devel')
-rw-r--r--devel/gengetopt/Makefile8
-rw-r--r--devel/gengetopt/pkg-descr2
-rw-r--r--devel/gengetopt/pkg-plist45
3 files changed, 32 insertions, 23 deletions
diff --git a/devel/gengetopt/Makefile b/devel/gengetopt/Makefile
index d51d06971ba6..6fc63059424f 100644
--- a/devel/gengetopt/Makefile
+++ b/devel/gengetopt/Makefile
@@ -19,4 +19,12 @@ USE_GMAKE= yes
MAN1= gengetopt.1
+.if defined(NOPORTDOCS)
+do-install:
+ @cd ${INSTALL_WRKSRC}/src && ${SETENV} ${MAKE_ENV} ${GMAKE} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} install
+ @cd ${INSTALL_WRKSRC}/doc && ${SETENV} ${MAKE_ENV} ${GMAKE} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} install-man
+.endif
+
.include <bsd.port.mk>
diff --git a/devel/gengetopt/pkg-descr b/devel/gengetopt/pkg-descr
index 6c698b226423..3b442cd148fa 100644
--- a/devel/gengetopt/pkg-descr
+++ b/devel/gengetopt/pkg-descr
@@ -3,7 +3,7 @@ the command line options, validate them and fill a struct.
Thus your program can now handle options such as:
-myprog --input foo.c -o foo.o --no-tabs -i 100 *.class
+ myprog --input foo.c -o foo.o --no-tabs -i 100 *.class
And both long options (those that start with --) and short options (start
with - and consist of only one character) can be handled. For standards
diff --git a/devel/gengetopt/pkg-plist b/devel/gengetopt/pkg-plist
index f5181fc9ce8e..18688e98b39f 100644
--- a/devel/gengetopt/pkg-plist
+++ b/devel/gengetopt/pkg-plist
@@ -1,27 +1,28 @@
+@comment $FreeBSD$
bin/gengetopt
-share/doc/gengetopt/examples/sample1.ggo
-share/doc/gengetopt/examples/sample2.ggo
-share/doc/gengetopt/examples/main1.cc
-share/doc/gengetopt/examples/main2.c
-share/doc/gengetopt/examples/cmdline1.c
-share/doc/gengetopt/examples/cmdline1.h
-share/doc/gengetopt/examples/cmdline2.c
-share/doc/gengetopt/examples/cmdline2.h
-share/doc/gengetopt/gengetopt.html
-share/doc/gengetopt/cmdline1.c.html
-share/doc/gengetopt/man_getopt.html
-share/doc/gengetopt/no_getopt_long.txt
-share/doc/gengetopt/ChangeLog
-share/doc/gengetopt/COPYING
-share/doc/gengetopt/NEWS
-share/doc/gengetopt/THANKS
-share/doc/gengetopt/INSTALL
-share/doc/gengetopt/README
-share/doc/gengetopt/LICENSE
+%%PORTDOCS%%share/doc/gengetopt/COPYING
+%%PORTDOCS%%share/doc/gengetopt/ChangeLog
+%%PORTDOCS%%share/doc/gengetopt/INSTALL
+%%PORTDOCS%%share/doc/gengetopt/LICENSE
+%%PORTDOCS%%share/doc/gengetopt/NEWS
+%%PORTDOCS%%share/doc/gengetopt/README
+%%PORTDOCS%%share/doc/gengetopt/THANKS
+%%PORTDOCS%%share/doc/gengetopt/cmdline1.c.html
+%%PORTDOCS%%share/doc/gengetopt/examples/cmdline1.c
+%%PORTDOCS%%share/doc/gengetopt/examples/cmdline1.h
+%%PORTDOCS%%share/doc/gengetopt/examples/cmdline2.c
+%%PORTDOCS%%share/doc/gengetopt/examples/cmdline2.h
+%%PORTDOCS%%share/doc/gengetopt/examples/main1.cc
+%%PORTDOCS%%share/doc/gengetopt/examples/main2.c
+%%PORTDOCS%%share/doc/gengetopt/examples/sample1.ggo
+%%PORTDOCS%%share/doc/gengetopt/examples/sample2.ggo
+%%PORTDOCS%%share/doc/gengetopt/gengetopt.html
+%%PORTDOCS%%share/doc/gengetopt/man_getopt.html
+%%PORTDOCS%%share/doc/gengetopt/no_getopt_long.txt
share/gengetopt/alloca.c
-share/gengetopt/getopt.h
share/gengetopt/getopt.c
+share/gengetopt/getopt.h
share/gengetopt/getopt1.c
-@dirrm share/doc/gengetopt/examples
-@dirrm share/doc/gengetopt
@dirrm share/gengetopt
+%%PORTDOCS%%@dirrm share/doc/gengetopt/examples
+%%PORTDOCS%%@dirrm share/doc/gengetopt