aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2013-09-02 21:26:34 +0800
committertijl <tijl@FreeBSD.org>2013-09-02 21:26:34 +0800
commitca2a2263a744b7c6f6f551ba68906f43afe04522 (patch)
tree724d013a376d218986fefc586ed681b8c219eeb7 /devel
parentd44d174b995274dd9e8ddc49b959e3790c47ce71 (diff)
downloadfreebsd-ports-gnome-ca2a2263a744b7c6f6f551ba68906f43afe04522.tar.gz
freebsd-ports-gnome-ca2a2263a744b7c6f6f551ba68906f43afe04522.tar.zst
freebsd-ports-gnome-ca2a2263a744b7c6f6f551ba68906f43afe04522.zip
Two imake related changes:
1) Move -a from XMKMF command variable to a new XMKMF_ARGS variable. For ports that don't need -a introduce USES=imake:notall. This way ports no longer have to redefine XMKMF. 2) xmkmf -a runs imake with the flags in IMAKECPPFLAGS as extra arguments to set CPP, CC and CXX. This creates the top Makefile, and then xmkmf runs make Makefiles. This Makefiles target runs imake for each subdirectory but these imake invocations did not have the flags from IMAKECPPFLAGS so the resulting makefiles used the wrong C preprocessor when clang is used (/usr/bin/cpp instead of /usr/local/bin/tradcpp). Instead of letting xmkmf pass IMAKECPPFLAGS from the environment to imake let imake handle IMAKECPPFLAGS itself just like it handles IMAKEINCLUDE. This exposed configure errors in x11-clocks/mouseclock and x11-wm/fvwm. Approved by: portmgr (bapt)
Diffstat (limited to 'devel')
-rw-r--r--devel/imake/Makefile1
-rw-r--r--devel/imake/files/patch-imake.c21
-rw-r--r--devel/imake/files/patch-xmkmf.cpp24
3 files changed, 19 insertions, 27 deletions
diff --git a/devel/imake/Makefile b/devel/imake/Makefile
index 6e2b3111285e..be0a13e36a2d 100644
--- a/devel/imake/Makefile
+++ b/devel/imake/Makefile
@@ -3,6 +3,7 @@
PORTNAME= imake
PORTVERSION= 1.0.6
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel
diff --git a/devel/imake/files/patch-imake.c b/devel/imake/files/patch-imake.c
index ff5609748481..6fc194f876a5 100644
--- a/devel/imake/files/patch-imake.c
+++ b/devel/imake/files/patch-imake.c
@@ -1,6 +1,21 @@
---- imake.c.orig Tue Jan 30 14:57:37 2007
-+++ imake.c Tue Jan 30 14:55:59 2007
-@@ -1153,29 +1153,17 @@
+--- imake.c.orig 2013-07-23 06:53:04.000000000 +0200
++++ imake.c 2013-08-31 14:57:48.000000000 +0200
+@@ -531,6 +531,14 @@
+ AddCppArg(p);
+ }
+ }
++ if ((p = getenv("IMAKECPPFLAGS"))) {
++ AddCppArg(p);
++ for (; *p; p++)
++ if (*p == ' ') {
++ *p++ = '\0';
++ AddCppArg(p);
++ }
++ }
+ if ((p = getenv("IMAKECPP")))
+ cpp = p;
+ if ((p = getenv("IMAKEMAKE")))
+@@ -1142,29 +1150,17 @@
int mib[2];
size_t len;
int osrel = 0;
diff --git a/devel/imake/files/patch-xmkmf.cpp b/devel/imake/files/patch-xmkmf.cpp
deleted file mode 100644
index 75e496452af7..000000000000
--- a/devel/imake/files/patch-xmkmf.cpp
+++ /dev/null
@@ -1,24 +0,0 @@
---- xmkmf.cpp.orig 2012-03-08 06:47:32.000000000 +0100
-+++ xmkmf.cpp 2013-06-28 11:55:04.174394058 +0200
-@@ -8,7 +8,7 @@
- topdir=
- curdir=.
- do_all=
--imake_defines=
-+imake_defines="${IMAKECPPFLAGS}"
-
- while [ $# -gt 0 ]
- do
-@@ -64,3 +64,12 @@
- imake $imake_defines $args
- ;;
- esac
-+
-+if [ -f "Makefile" ];then
-+ if [ -n "$CC" ];then
-+ sed -i "" -e "s| CC = cc| CC = $CC|" Makefile
-+ fi
-+ if [ -n "$CXX" ];then
-+ sed -i "" -e "s| CXX = c++| CXX = $CXX|" Makefile
-+ fi
-+fi