aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2015-10-08 22:48:57 +0800
committerpawel <pawel@FreeBSD.org>2015-10-08 22:48:57 +0800
commitcd01b7a94a46cfdf02ca9f98e3e88777d1efc8b6 (patch)
treef00e27e1543863a0973c85b1823937aa7719d160 /devel
parent2df9f9ac11f73da2ad7ccbd664db6ea6c08ba859 (diff)
downloadfreebsd-ports-gnome-cd01b7a94a46cfdf02ca9f98e3e88777d1efc8b6.tar.gz
freebsd-ports-gnome-cd01b7a94a46cfdf02ca9f98e3e88777d1efc8b6.tar.zst
freebsd-ports-gnome-cd01b7a94a46cfdf02ca9f98e3e88777d1efc8b6.zip
- Convert to USES=autoreconf [1]
- Use options helpers for LUA option PR: 202809 [1] Submitted by: takefu@airport.fm [1]
Diffstat (limited to 'devel')
-rw-r--r--devel/swig13/Makefile21
1 files changed, 8 insertions, 13 deletions
diff --git a/devel/swig13/Makefile b/devel/swig13/Makefile
index cf3c77ce99f7..5ab2404943b5 100644
--- a/devel/swig13/Makefile
+++ b/devel/swig13/Makefile
@@ -11,7 +11,7 @@ PKGNAMESUFFIX= 13
MAINTAINER= ports@FreeBSD.org
COMMENT= Simplified Wrapper and Interface Generator
-USE_AUTOTOOLS= autoconf:env
+USES= autoreconf:build
GNU_CONFIGURE= yes
VER= ${PORTVERSION:R}
@@ -33,18 +33,13 @@ PORTDATA= *
OPTIONS_DEFINE= LUA DOCS EXAMPLES
OPTIONS_DEFAULT=DOCS EXAMPLES
-LUA_DESC= Enable Lua support
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MLUA}
-USES+= lua:51
-CONFIGURE_ARGS+=--with-lua=${LUA_BINDIR}/lua \
- --with-luaincl=${LUA_INCDIR} \
- --with-lualib=${LUA_LIBDIR}
-.else
-CONFIGURE_ARGS+=--without-lua
-.endif
+LUA_DESC= Lua support
+LUA_USES= lua:51
+LUA_CONFIGURE_ON= --with-lua=${LUA_BINDIR}/lua \
+ --with-luaincl=${LUA_INCDIR} \
+ --with-lualib=${LUA_LIBDIR}
+LUA_CONFIGURE_OFF= --without-lua
OCTAVE_VER_CMD= ${LOCALBASE}/bin/octave-config -v 2>/dev/null || ${TRUE}
@@ -68,4 +63,4 @@ post-install:
cd ${WRKSRC}/Doc && ${COPYTREE_SHARE} '*' ${STAGEDIR}${DOCSDIR}/${PORTVERSION}
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>