aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2003-06-02 18:15:12 +0800
committerskv <skv@FreeBSD.org>2003-06-02 18:15:12 +0800
commitcf099f83dd70698c7cb4e28685eb2ab05f281e7f (patch)
tree68f5fe3e7adfe3400af46001aad9cb64a385c1ea /devel
parent5b6583a9a1c36e4a6c36a808fca3e3426ecb8368 (diff)
downloadfreebsd-ports-gnome-cf099f83dd70698c7cb4e28685eb2ab05f281e7f.tar.gz
freebsd-ports-gnome-cf099f83dd70698c7cb4e28685eb2ab05f281e7f.tar.zst
freebsd-ports-gnome-cf099f83dd70698c7cb4e28685eb2ab05f281e7f.zip
Add p5-POE-Session-MultiDispatch 1.3,
callback dispatch for session events.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-POE-Session-MultiDispatch/Makefile26
-rw-r--r--devel/p5-POE-Session-MultiDispatch/distinfo1
-rw-r--r--devel/p5-POE-Session-MultiDispatch/pkg-descr18
-rw-r--r--devel/p5-POE-Session-MultiDispatch/pkg-plist5
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index bd6b19b67110..8adba032045e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -617,6 +617,7 @@
SUBDIR += p5-POE-Component-Pcap
SUBDIR += p5-POE-Component-RSS
SUBDIR += p5-POE-Session-Cascading
+ SUBDIR += p5-POE-Session-MultiDispatch
SUBDIR += p5-PPerl
SUBDIR += p5-PV
SUBDIR += p5-Parallel-ForkManager
diff --git a/devel/p5-POE-Session-MultiDispatch/Makefile b/devel/p5-POE-Session-MultiDispatch/Makefile
new file mode 100644
index 000000000000..cf89e8dad1e9
--- /dev/null
+++ b/devel/p5-POE-Session-MultiDispatch/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: POE-Session-MultiDispatch
+# Date created: 02 June 2003
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Session-MultiDispatch
+PORTVERSION= 1.3
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Callback dispatch for session events
+
+RUN_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Session::MultiDispatch.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-POE-Session-MultiDispatch/distinfo b/devel/p5-POE-Session-MultiDispatch/distinfo
new file mode 100644
index 000000000000..c06c7e5809e7
--- /dev/null
+++ b/devel/p5-POE-Session-MultiDispatch/distinfo
@@ -0,0 +1 @@
+MD5 (POE-Session-MultiDispatch-1.3.tar.gz) = 59b2e2614c3a048d4ad5d0bd87ecd044
diff --git a/devel/p5-POE-Session-MultiDispatch/pkg-descr b/devel/p5-POE-Session-MultiDispatch/pkg-descr
new file mode 100644
index 000000000000..5e11a12d9ded
--- /dev/null
+++ b/devel/p5-POE-Session-MultiDispatch/pkg-descr
@@ -0,0 +1,18 @@
+POE::Session::MultiDispatch is a drop in replacement for POE::Session
+that adds callback dispatch functionality to POE sessions. Each event
+may have multiple handlers associated with it. Fine control over the
+order of execution is available using helper methods that extend the
+interface of a POE::Session.
+
+POE::Session::MultiDispatch uses POE::Session as a base class. When
+multiple callbacks are registered for an event, only the last callback
+survives, all the others are clobbered. POE::Session::MultiDispatch is
+much nicer to your registered callbacks, it keeps them all in the order
+they were defined. When an event is triggered, all the callbacks are
+then executed in that same order (unless you muck around with said
+order).
+
+WWW: http://search.cpan.org/dist/POE-Session-MultiDispatch/
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/devel/p5-POE-Session-MultiDispatch/pkg-plist b/devel/p5-POE-Session-MultiDispatch/pkg-plist
new file mode 100644
index 000000000000..9fa3358dede4
--- /dev/null
+++ b/devel/p5-POE-Session-MultiDispatch/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Session/MultiDispatch/.packlist
+%%SITE_PERL%%/POE/Session/MultiDispatch.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Session/MultiDispatch
+@unexec rmdir %D/%%SITE_PERL%%/POE 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE 2>/dev/null || true