aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2014-09-29 06:58:51 +0800
committeravilla <avilla@FreeBSD.org>2014-09-29 06:58:51 +0800
commitcfed9a313d685fe527f94d7dfebfd6ab43e59ad5 (patch)
tree3519e27224702b200392e2556264193fb94f359e /devel
parent6de5b606b2435d81e521c00291d6d9c461f537cf (diff)
downloadfreebsd-ports-gnome-cfed9a313d685fe527f94d7dfebfd6ab43e59ad5.tar.gz
freebsd-ports-gnome-cfed9a313d685fe527f94d7dfebfd6ab43e59ad5.tar.zst
freebsd-ports-gnome-cfed9a313d685fe527f94d7dfebfd6ab43e59ad5.zip
- Update libplist to 1.11.
- Split libusbmuxd.so into comms/libusbmuxd and update to 1.0.9. - Update libimobiledevice to 1.1.6. - Update usbmuxd to Git snapshot (~1.0.9). - Document usbmuxd upgrade process. This marks an important refactoring effort for proper iOS 7 support. It's packed with new features, tools, speed improvements, code refactoring, crash fixes, memory leak fixes and much more.
Diffstat (limited to 'devel')
-rw-r--r--devel/libplist/Makefile35
-rw-r--r--devel/libplist/distinfo4
-rw-r--r--devel/libplist/files/patch-configure11
-rw-r--r--devel/libplist/files/patch-src__Dictionary.cpp11
-rw-r--r--devel/libplist/pkg-plist12
-rw-r--r--devel/py-libplist/Makefile27
-rw-r--r--devel/py-libplist/files/CMakeLists.txt14
-rw-r--r--devel/py-libplist/pkg-plist10
8 files changed, 55 insertions, 69 deletions
diff --git a/devel/libplist/Makefile b/devel/libplist/Makefile
index f3990bbe5790..ae0609c4ce13 100644
--- a/devel/libplist/Makefile
+++ b/devel/libplist/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= libplist
-PORTVERSION= 1.10
-PORTREVISION?= 1
+PORTVERSION= 1.11
+PORTREVISION?= 0
CATEGORIES?= devel
MASTER_SITES= http://www.libimobiledevice.org/downloads/
@@ -13,13 +13,14 @@ LICENSE?= LGPL21
SLAVE_PORT?= no
-USES= cmake pkgconfig tar:bzip2
+USES+= compiler libtool pathfix pkgconfig tar:bzip2
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
-.if ${SLAVE_PORT} == "no"
+.if ${SLAVE_PORT} == no
USE_GNOME= libxml2
-CMAKE_ARGS= -DENABLE_CYTHON:BOOL=False \
- -DENABLE_SWIG:BOOL=False
+CONFIGURE_ARGS= --without-cython
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= ${LOCALBASE}/lib
@@ -27,20 +28,18 @@ PORTDOCS= AUTHORS NEWS README
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
-post-patch:
-# Required for iconv headers (included by libxml2). Do not add to
-# CFLAGS as it may break updates from old versions.
- @${REINPLACE_CMD} -e 's,$${LIBXML2_INCLUDE_DIR},$${LIBXML2_INCLUDE_DIR} ${LOCALBASE}/include,' \
- ${WRKSRC}/src/CMakeLists.txt
- @${REINPLACE_CMD} -e 's,$${CMAKE_INSTALL_LIBDIR}/pkgconfig,libdata/pkgconfig,' \
- ${WRKSRC}/CMakeLists.txt
-
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-.endif # ${SLAVE_PORT} == "no"
+.endif # ${SLAVE_PORT} == no
+
+.include <bsd.port.pre.mk>
+
+pre-build:
+.if ${CHOSEN_COMPILER_TYPE} == gcc && ${COMPILER_VERSION} < 45
+ @${REINPLACE_CMD} -e '/__attribute__/ s,deprecated(x),deprecated(),' \
+ ${WRKSRC}/include/plist/plist.h
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/libplist/distinfo b/devel/libplist/distinfo
index 0a4b90d43530..061ee7362997 100644
--- a/devel/libplist/distinfo
+++ b/devel/libplist/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libplist-1.10.tar.bz2) = f44c52a0f8065d41d44772a7484f93bc5e7da21a8f4a9ad3f38a36b827eeff0b
-SIZE (libplist-1.10.tar.bz2) = 82519
+SHA256 (libplist-1.11.tar.bz2) = 28e1518eeea054f4eec9a1c93d9575d56193b290c53c1b753773a5e0add95235
+SIZE (libplist-1.11.tar.bz2) = 355365
diff --git a/devel/libplist/files/patch-configure b/devel/libplist/files/patch-configure
new file mode 100644
index 000000000000..af91a292f882
--- /dev/null
+++ b/devel/libplist/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2014-02-11 16:37:02 UTC
++++ configure
+@@ -16625,7 +16625,7 @@
+ py_version=$PYTHON_VERSION
+ else
+ py_version=`$PYTHON -c "import sys; \
+- print(sys.version[:3]")`
++ print(sys.version[:3])"`
+ fi
+ fi
+
diff --git a/devel/libplist/files/patch-src__Dictionary.cpp b/devel/libplist/files/patch-src__Dictionary.cpp
deleted file mode 100644
index 24814fd8f1d3..000000000000
--- a/devel/libplist/files/patch-src__Dictionary.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/Dictionary.cpp.orig 2013-03-19 17:34:11.000000000 +0100
-+++ ./src/Dictionary.cpp 2013-09-06 21:56:58.185535926 +0200
-@@ -151,7 +151,7 @@
- _map[key] = clone;
- return _map.find(key);
- }
-- return iterator(NULL);
-+ return iterator();
- }
-
- void Dictionary::Remove(Node* node)
diff --git a/devel/libplist/pkg-plist b/devel/libplist/pkg-plist
index 37f69eab8a2c..9a5e9e6122ab 100644
--- a/devel/libplist/pkg-plist
+++ b/devel/libplist/pkg-plist
@@ -1,5 +1,4 @@
bin/plistutil
-bin/plistutil-1.10
include/plist/Array.h
include/plist/Boolean.h
include/plist/Data.h
@@ -14,12 +13,13 @@ include/plist/Structure.h
include/plist/Uid.h
include/plist/plist++.h
include/plist/plist.h
+lib/libplist++.a
lib/libplist++.so
-lib/libplist++.so.1
-lib/libplist++.so.1.1.10
+lib/libplist++.so.2
+lib/libplist++.so.2.0.0
+lib/libplist.a
lib/libplist.so
-lib/libplist.so.1
-lib/libplist.so.1.1.10
+lib/libplist.so.2
+lib/libplist.so.2.0.0
libdata/pkgconfig/libplist++.pc
libdata/pkgconfig/libplist.pc
-@dirrm include/plist
diff --git a/devel/py-libplist/Makefile b/devel/py-libplist/Makefile
index 213a67e7090f..5265722ed85b 100644
--- a/devel/py-libplist/Makefile
+++ b/devel/py-libplist/Makefile
@@ -8,10 +8,10 @@ MAINTAINER= avilla@FreeBSD.org
COMMENT= Python bindings for libplist
LIB_DEPENDS= libplist.so:${PORTSDIR}/${MASTER_PORT}
-BUILD_DEPENDS= cython:${PORTSDIR}/lang/cython \
- swig2.0:${PORTSDIR}/devel/swig20
+BUILD_DEPENDS= cython:${PORTSDIR}/lang/cython
-USE_PYTHON= yes
+USES= python
+CONFIGURE_ENV= PYTHON_LDFLAGS="`pkg-config --libs python-${PYTHON_VER}`"
SLAVE_PORT= yes
MASTERDIR= ${.CURDIR:H:H}/devel/libplist
# Required to reference installed libplist.
@@ -19,11 +19,22 @@ CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
PLIST= ${.CURDIR}/pkg-plist
-FILESDIR= ${.CURDIR}/files
-post-patch:
- @${CP} ${FILESDIR}/CMakeLists.txt ${WRKSRC}
- @${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},' \
- ${WRKSRC}/CMakeLists.txt
+BUILD_WRKSRC= ${WRKSRC}/cython
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+PLIST_FILES= include/plist/cython/plist.pxd \
+ ${PYTHONPREFIX_SITELIBDIR:S,^${PREFIX}/,,}/plist.a \
+ ${PYTHONPREFIX_SITELIBDIR:S,^${PREFIX}/,,}/plist.so
+
+pre-configure:
+ @${REINPLACE_CMD} -e 's,../src/libplist.la,-lplist,' \
+ -e 's,$$(plist_la_DEPENDENCIES),,' \
+ ${BUILD_WRKSRC}/Makefile.in
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/plist/cython
+ ${INSTALL_DATA} ${INSTALL_WRKSRC}/plist.pxd \
+ ${STAGEDIR}${PREFIX}/include/plist/cython
.include "${MASTERDIR}/Makefile"
diff --git a/devel/py-libplist/files/CMakeLists.txt b/devel/py-libplist/files/CMakeLists.txt
deleted file mode 100644
index ef4acd1df70e..000000000000
--- a/devel/py-libplist/files/CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
-set(CMAKE_MODULE_PATH
- ${CMAKE_SOURCE_DIR}/cmake
- ${CMAKE_SOURCE_DIR}/cmake/modules)
-
-# Required by SWIG.
-include_directories(/usr/local/include)
-
-find_package(Cython REQUIRED)
-find_package(SWIG REQUIRED)
-find_package(PythonInterp REQUIRED)
-find_package(PythonLibs REQUIRED)
-
-add_subdirectory(cython)
-add_subdirectory(swig)
diff --git a/devel/py-libplist/pkg-plist b/devel/py-libplist/pkg-plist
deleted file mode 100644
index 94bab6f8aee3..000000000000
--- a/devel/py-libplist/pkg-plist
+++ /dev/null
@@ -1,10 +0,0 @@
-include/plist/cython/plist.pxd
-include/plist/swig/plist.i
-%%PYTHON_SITELIBDIR%%/plist.so
-%%PYTHON_SITELIBDIR%%/plist/__init__.py
-%%PYTHON_SITELIBDIR%%/plist/_plist.so
-%%PYTHON_SITELIBDIR%%/plist/plist.py
-@dirrm %%PYTHON_SITELIBDIR%%/plist
-@dirrm include/plist/swig
-@dirrm include/plist/cython
-@dirrmtry include/plist