aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-02-17 07:49:30 +0800
committermiwi <miwi@FreeBSD.org>2008-02-17 07:49:30 +0800
commitd96c4c5cbb1524ac8ccb8653770a73f7c5896619 (patch)
tree5574b12e4092e4bb33c1aa30a32fbad60ca00c11 /devel
parente2dfc3bec6d50dee413f506782ec17cefcb326be (diff)
downloadfreebsd-ports-gnome-d96c4c5cbb1524ac8ccb8653770a73f7c5896619.tar.gz
freebsd-ports-gnome-d96c4c5cbb1524ac8ccb8653770a73f7c5896619.tar.zst
freebsd-ports-gnome-d96c4c5cbb1524ac8ccb8653770a73f7c5896619.zip
This moudles adds self and args keywords in your Perl OO module. It's
really just handy helpers to get rid of: my $self = shift; Basically, self is just eqaul to $_[0], and args is just $_[1..$#_]. WWW: http://search.cpan.org/dist/self/ PR: ports/120190 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-self/Makefile24
-rw-r--r--devel/p5-self/distinfo3
-rw-r--r--devel/p5-self/pkg-descr8
-rw-r--r--devel/p5-self/pkg-plist4
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5a2ea636d3ff..70256bd26fb4 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1750,6 +1750,7 @@
SUBDIR += p5-prefork
SUBDIR += p5-reaper
SUBDIR += p5-rpm-build-perl
+ SUBDIR += p5-self
SUBDIR += p5-subatom
SUBDIR += p5-threads
SUBDIR += p5-threads-shared
diff --git a/devel/p5-self/Makefile b/devel/p5-self/Makefile
new file mode 100644
index 000000000000..5c6db395af29
--- /dev/null
+++ b/devel/p5-self/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-self
+# Date created: 2008-02-01
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= self
+PORTVERSION= 0.15
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/G/GU/GUGOD/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Provides "self" and "args" keywords in your OO program
+
+RUN_DEPENDS= ${SITE_PERL}/Sub/Exporter.pm:${PORTSDIR}/devel/p5-Sub-Exporter
+
+PERL_CONFIGURE= yes
+
+MAN3= self.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-self/distinfo b/devel/p5-self/distinfo
new file mode 100644
index 000000000000..1d133263fe88
--- /dev/null
+++ b/devel/p5-self/distinfo
@@ -0,0 +1,3 @@
+MD5 (self-0.15.tar.gz) = 15de5484c9533ad48f38f562ad747366
+SHA256 (self-0.15.tar.gz) = 56b3b52ffc4c1d70f5198ea1e11184052eec55697884fd5a287923afd778606d
+SIZE (self-0.15.tar.gz) = 14874
diff --git a/devel/p5-self/pkg-descr b/devel/p5-self/pkg-descr
new file mode 100644
index 000000000000..7decf31270c9
--- /dev/null
+++ b/devel/p5-self/pkg-descr
@@ -0,0 +1,8 @@
+This moudles adds self and args keywords in your Perl OO module. It's
+really just handy helpers to get rid of:
+
+ my $self = shift;
+
+Basically, self is just eqaul to $_[0], and args is just $_[1..$#_].
+
+WWW: http://search.cpan.org/dist/self/
diff --git a/devel/p5-self/pkg-plist b/devel/p5-self/pkg-plist
new file mode 100644
index 000000000000..b4069e349bb3
--- /dev/null
+++ b/devel/p5-self/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/self/.packlist
+%%SITE_PERL%%/self.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/self