aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2010-04-16 02:00:49 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2010-04-16 02:00:49 +0800
commite936e2a64743bc7d873c3af737cd27b5ec064317 (patch)
tree8cbd30e284a7f17659b028d2650e80047b746609 /devel
parent02fe2b0f9a9855e04cd188e34de980a06bba6dec (diff)
downloadfreebsd-ports-gnome-e936e2a64743bc7d873c3af737cd27b5ec064317.tar.gz
freebsd-ports-gnome-e936e2a64743bc7d873c3af737cd27b5ec064317.tar.zst
freebsd-ports-gnome-e936e2a64743bc7d873c3af737cd27b5ec064317.zip
An alternative Git GUI with an emphasis on graphical
representation of data and actions. It can: * Browse revision history * Commit changes * Show colorized diff of changes in revisions * Handles extremely large projects very well WWW: http://trac.novowork.com/gitg/wiki I'm taking maintainership of this port as submitter doesn't have access to FreeBSD box to properly test it (discussed via private email). PR: 144999 Submitted by: kipz <somicide@gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/gitg/Makefile31
-rw-r--r--devel/gitg/distinfo3
-rw-r--r--devel/gitg/pkg-descr9
-rw-r--r--devel/gitg/pkg-plist58
5 files changed, 102 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index aedc928e976d..9b0498a3991a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -460,6 +460,7 @@
SUBDIR += gir-repository-libnotify
SUBDIR += gir-repository-libsoup
SUBDIR += git
+ SUBDIR += gitg
SUBDIR += gittrac
SUBDIR += glade2
SUBDIR += glade3
diff --git a/devel/gitg/Makefile b/devel/gitg/Makefile
new file mode 100644
index 000000000000..1e4e37e729a3
--- /dev/null
+++ b/devel/gitg/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: gitg
+# Date created: 2010-03-19
+# Whom: kipz <somicide@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gitg
+PORTVERSION= 0.0.6
+CATEGORIES= devel deskutils gnome
+MASTER_SITES= http://trac.novowork.com/gitg/raw-attachment/wiki/Releases/ \
+ http://mirror.amdmi3.ru/distfiles/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= GTK-based git repository viewer
+
+RUN_DEPENDS= git>=1.7.0.2:${PORTSDIR}/devel/git
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gconf2 gtk20 gtksourceview2 gnomehack
+USE_GETTEXT= yes
+MAKE_JOBS_SAFE= yes
+
+INSTALLS_ICONS= yes
+GCONF_SCHEMAS= gitg.schemas
+
+MAN1= gitg.1
+
+.include <bsd.port.mk>
diff --git a/devel/gitg/distinfo b/devel/gitg/distinfo
new file mode 100644
index 000000000000..a4b420f1f43e
--- /dev/null
+++ b/devel/gitg/distinfo
@@ -0,0 +1,3 @@
+MD5 (gitg-0.0.6.tar.bz2) = 5aab2b6fc97d72f2063f91f12dc014d8
+SHA256 (gitg-0.0.6.tar.bz2) = 1b4ae8f61ce0ba12e12645eca87799076dae961ca03a3906c35686aa3287e0bd
+SIZE (gitg-0.0.6.tar.bz2) = 455034
diff --git a/devel/gitg/pkg-descr b/devel/gitg/pkg-descr
new file mode 100644
index 000000000000..630d6116ac45
--- /dev/null
+++ b/devel/gitg/pkg-descr
@@ -0,0 +1,9 @@
+An alternative Git GUI with an emphasis on graphical
+representation of data and actions. It can:
+
+ * Browse revision history
+ * Commit changes
+ * Show colorized diff of changes in revisions
+ * Handles extremely large projects very well
+
+WWW: http://trac.novowork.com/gitg/wiki
diff --git a/devel/gitg/pkg-plist b/devel/gitg/pkg-plist
new file mode 100644
index 000000000000..b2f02efe2b9a
--- /dev/null
+++ b/devel/gitg/pkg-plist
@@ -0,0 +1,58 @@
+bin/gitg
+share/applications/gitg.desktop
+%%DATADIR%%/icons/gitg.svg
+%%DATADIR%%/icons/gitg128x128.png
+%%DATADIR%%/icons/gitg16x16.png
+%%DATADIR%%/icons/gitg22x22.png
+%%DATADIR%%/icons/gitg24x24.png
+%%DATADIR%%/icons/gitg32x32.png
+%%DATADIR%%/icons/gitg48x48.png
+%%DATADIR%%/icons/gitg64x64.png
+%%DATADIR%%/language-specs/gitgdiff.lang
+%%DATADIR%%/styles/gitgstyle.xml
+%%DATADIR%%/ui/gitg-commit-menu.ui
+%%DATADIR%%/ui/gitg-menus.xml
+%%DATADIR%%/ui/gitg-preferences.ui
+%%DATADIR%%/ui/gitg-repository.ui
+%%DATADIR%%/ui/gitg-tag.ui
+%%DATADIR%%/ui/gitg-ui.xml
+%%DATADIR%%/ui/gitg-window.ui
+share/icons/hicolor/16x16/apps/gitg.png
+share/icons/hicolor/22x22/apps/gitg.png
+share/icons/hicolor/24x24/apps/gitg.png
+share/icons/hicolor/32x32/apps/gitg.png
+share/icons/hicolor/48x48/apps/gitg.png
+share/icons/hicolor/icon-theme.cache
+share/icons/hicolor/scalable/apps/gitg.svg
+share/locale/da/LC_MESSAGES/gitg.mo
+share/locale/de/LC_MESSAGES/gitg.mo
+share/locale/en_GB/LC_MESSAGES/gitg.mo
+share/locale/es/LC_MESSAGES/gitg.mo
+share/locale/fr/LC_MESSAGES/gitg.mo
+share/locale/gl/LC_MESSAGES/gitg.mo
+share/locale/it/LC_MESSAGES/gitg.mo
+share/locale/lt/LC_MESSAGES/gitg.mo
+share/locale/nl/LC_MESSAGES/gitg.mo
+share/locale/pa/LC_MESSAGES/gitg.mo
+share/locale/sl/LC_MESSAGES/gitg.mo
+share/locale/sv/LC_MESSAGES/gitg.mo
+@dirrmtry share/icons/hicolor/scalable/apps
+@dirrmtry share/icons/hicolor/scalable
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/24x24/apps
+@dirrmtry share/icons/hicolor/24x24
+@dirrmtry share/icons/hicolor/22x22/apps
+@dirrmtry share/icons/hicolor/22x22
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrm %%DATADIR%%/ui
+@dirrm %%DATADIR%%/styles
+@dirrm %%DATADIR%%/language-specs
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%
+@dirrmtry share/applications