aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-04-29 21:03:08 +0800
committerclsung <clsung@FreeBSD.org>2006-04-29 21:03:08 +0800
commit0eda09160b579802b1b2c264b54197f12b39649e (patch)
treeee031bf9ec38c60bf4ace7d8677d5fcdca6c4d3c /devel
parentb80e51826c59356c643889023203444e21a80ffd (diff)
downloadfreebsd-ports-gnome-0eda09160b579802b1b2c264b54197f12b39649e.tar.gz
freebsd-ports-gnome-0eda09160b579802b1b2c264b54197f12b39649e.tar.zst
freebsd-ports-gnome-0eda09160b579802b1b2c264b54197f12b39649e.zip
requires newer perl to build and run. I have a patch to make it
build on perl 5.005, but then the module can not load. already informed the author. until a fix comes, make it requires newer perl. PR: 96502 Submitted by: maintainer (Rong-En Fan)
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Module-ScanDeps/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/devel/p5-Module-ScanDeps/Makefile b/devel/p5-Module-ScanDeps/Makefile
index 12e273330e1c..77395a3913ec 100644
--- a/devel/p5-Module-ScanDeps/Makefile
+++ b/devel/p5-Module-ScanDeps/Makefile
@@ -24,4 +24,11 @@ pre-install:
@${REINPLACE_CMD} -e \
's|/usr/bin/perl|${PERL}|' ${WRKSRC}/script/scandeps.pl
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# workaround
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or above to build and run
+.endif
+
+.include <bsd.port.post.mk>