aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlme <lme@FreeBSD.org>2007-09-20 01:21:13 +0800
committerlme <lme@FreeBSD.org>2007-09-20 01:21:13 +0800
commit151f2d5400991d15034b6ddf63176ec47b6d9224 (patch)
treea9a7c9318eacfe036e652fe02b2a7bfb1a00510f /devel
parent894c45471018980463ca32ea2b23e4f6dea63f55 (diff)
downloadfreebsd-ports-gnome-151f2d5400991d15034b6ddf63176ec47b6d9224.tar.gz
freebsd-ports-gnome-151f2d5400991d15034b6ddf63176ec47b6d9224.tar.zst
freebsd-ports-gnome-151f2d5400991d15034b6ddf63176ec47b6d9224.zip
mkimage adds a header to a kernel image with information and checksums for
the u-boot bootloader used in embedded systems. WWW: http://www.denx.de/wiki/UBoot PR: ports/116442 Submitted by: Markus NĂ¼nnerich <mn (at) bsdgroup.de> Approved by: miwi (mentor)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/u-boot/Makefile31
-rw-r--r--devel/u-boot/distinfo3
-rw-r--r--devel/u-boot/files/BSDmakefile11
-rw-r--r--devel/u-boot/pkg-descr4
5 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f6dcc8e694f7..4e679d4ea292 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2259,6 +2259,7 @@
SUBDIR += trio
SUBDIR += truc
SUBDIR += tvision
+ SUBDIR += u-boot
SUBDIR += uclmmbase
SUBDIR += ucpp
SUBDIR += udis86
diff --git a/devel/u-boot/Makefile b/devel/u-boot/Makefile
new file mode 100644
index 000000000000..b3b9ac5ecf32
--- /dev/null
+++ b/devel/u-boot/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: u-boot-mkimage
+# Date created: 18 September 2007
+# Whom: Marius Nuennerich <mn@bsdgroup.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= u-boot
+PORTVERSION= 1.2.0
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.denx.de/pub/u-boot/ \
+ http://people.bsdgroup.de/~as/freebsd/distfiles/
+PKGNAMESUFFIX= -mkimage
+
+MAINTAINER= mn@bsdgroup.de
+COMMENT= The mkimage utility of the u-boot bootloader
+
+USE_BZIP2= yes
+
+PLIST_FILES= bin/mkimage
+
+do-patch:
+ @${CP} ${PATCHDIR}/BSDmakefile ${WRKSRC}/tools
+
+do-build:
+ @cd ${WRKSRC}/tools && make
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tools/mkimage ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/devel/u-boot/distinfo b/devel/u-boot/distinfo
new file mode 100644
index 000000000000..4c22a4b69835
--- /dev/null
+++ b/devel/u-boot/distinfo
@@ -0,0 +1,3 @@
+SHA256 (u-boot-1.2.0.tar.bz2) = 62192ddf019c5d24f6538b33c9e69b6e5792bf5b0f464c0149061e2f0871108b
+MD5 (u-boot-1.2.0.tar.bz2) = 17aeee76ca4c07887bbfea8a52d40884
+SIZE (u-boot-1.2.0.tar.bz2) = 6929112
diff --git a/devel/u-boot/files/BSDmakefile b/devel/u-boot/files/BSDmakefile
new file mode 100644
index 000000000000..8db790b3ed88
--- /dev/null
+++ b/devel/u-boot/files/BSDmakefile
@@ -0,0 +1,11 @@
+CFLAGS+= -I../include -DUSE_HOSTCC
+
+all: mkimage
+
+mkimage: mkimage.o crc32.o
+ $(CC) $(CFLAGS) -o $(.TARGET) $(.ALLSRC)
+
+crc32.o: ../lib_generic/crc32.c ../include/zlib.h
+
+clean:
+ rm -f mkimage mkimage.o crc32.o
diff --git a/devel/u-boot/pkg-descr b/devel/u-boot/pkg-descr
new file mode 100644
index 000000000000..90047a866393
--- /dev/null
+++ b/devel/u-boot/pkg-descr
@@ -0,0 +1,4 @@
+mkimage adds a header to a kernel image with information and checksums for
+the u-boot bootloader used in embedded systems.
+
+WWW: http://www.denx.de/wiki/UBoot