aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authornbm <nbm@FreeBSD.org>2000-08-01 22:06:30 +0800
committernbm <nbm@FreeBSD.org>2000-08-01 22:06:30 +0800
commit1885a1b06e25afa994c8289816e90290488e069e (patch)
tree93acf84786ee30e220057f1a05b803443b4a7c57 /devel
parentcf9d143d2df932609439f1639dd4c096c4c8652c (diff)
downloadfreebsd-ports-gnome-1885a1b06e25afa994c8289816e90290488e069e.tar.gz
freebsd-ports-gnome-1885a1b06e25afa994c8289816e90290488e069e.tar.zst
freebsd-ports-gnome-1885a1b06e25afa994c8289816e90290488e069e.zip
Add p5-B-Graph, a perl module for displaying perl-internals information
with a graph layout tool (such as Dot and VGC, apparently). PR: ports/20164 Submitted by: Leo Kim <leo@florida.sarang.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-B-Graph/Makefile24
-rw-r--r--devel/p5-B-Graph/distinfo1
-rw-r--r--devel/p5-B-Graph/pkg-comment1
-rw-r--r--devel/p5-B-Graph/pkg-descr11
-rw-r--r--devel/p5-B-Graph/pkg-plist3
6 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 02897d57c099..3a5253af6069 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -178,6 +178,7 @@
SUBDIR += oaf
SUBDIR += omniORB
SUBDIR += p5-AppConfig
+ SUBDIR += p5-B-Graph
SUBDIR += p5-BSD-Resource
SUBDIR += p5-C-Scan
SUBDIR += p5-Class-MethodMaker
diff --git a/devel/p5-B-Graph/Makefile b/devel/p5-B-Graph/Makefile
new file mode 100644
index 000000000000..16bb028ee226
--- /dev/null
+++ b/devel/p5-B-Graph/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-B-Graph
+# Date created: 24-Jul-2000
+# Whom: Leo Kim <leo@florida.sarang.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= B-Graph
+PORTVERSION= 0.50
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR=B
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= leo@florida.sarang.net
+
+USE_PERL5= YES
+MAN3= B::Graph.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/devel/p5-B-Graph/distinfo b/devel/p5-B-Graph/distinfo
new file mode 100644
index 000000000000..168a21169ee9
--- /dev/null
+++ b/devel/p5-B-Graph/distinfo
@@ -0,0 +1 @@
+MD5 (B-Graph-0.50.tar.gz) = 875887e2fec91221704e89f72745a821
diff --git a/devel/p5-B-Graph/pkg-comment b/devel/p5-B-Graph/pkg-comment
new file mode 100644
index 000000000000..b26b031b109d
--- /dev/null
+++ b/devel/p5-B-Graph/pkg-comment
@@ -0,0 +1 @@
+Perl Compiler backend to diagram OP trees
diff --git a/devel/p5-B-Graph/pkg-descr b/devel/p5-B-Graph/pkg-descr
new file mode 100644
index 000000000000..270713f4ab8f
--- /dev/null
+++ b/devel/p5-B-Graph/pkg-descr
@@ -0,0 +1,11 @@
+This module is a layer between the perl-internals-examining parts of
+Malcolm Beattie's perl compiler (the B::* classes) and your favorite
+graph layout tool (currently Dot and VGC are supported, but adding
+others would be easy). It examines the internal structures that perl
+builds to represent your code (OPs and SVs), and generates
+specifications for multicolored boxes and arrows to represent them.
+
+WWW: http://search.cpan.org/search?module=B::Graph
+
+- Leo Kim
+leo@florida.sarang.net
diff --git a/devel/p5-B-Graph/pkg-plist b/devel/p5-B-Graph/pkg-plist
new file mode 100644
index 000000000000..1eb204af74bb
--- /dev/null
+++ b/devel/p5-B-Graph/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/B/Graph.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/B/Graph/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/B/Graph