aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2001-10-27 04:38:19 +0800
committertobez <tobez@FreeBSD.org>2001-10-27 04:38:19 +0800
commit1c4d8cb313671b471c852a657ffcd137dff4b409 (patch)
tree296fcccba9609653f0ea5e8d381c4e6ee6a131b5 /devel
parent2a77e21587908cbd48ff56176b4a104a84f387e9 (diff)
downloadfreebsd-ports-gnome-1c4d8cb313671b471c852a657ffcd137dff4b409.tar.gz
freebsd-ports-gnome-1c4d8cb313671b471c852a657ffcd137dff4b409.tar.zst
freebsd-ports-gnome-1c4d8cb313671b471c852a657ffcd137dff4b409.zip
Update to 1.11; fix pkg-plist; make better pkg-descr; assume
maintainership.
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-BSD-Resource/Makefile4
-rw-r--r--devel/p5-BSD-Resource/distinfo2
-rw-r--r--devel/p5-BSD-Resource/pkg-comment2
-rw-r--r--devel/p5-BSD-Resource/pkg-descr82
-rw-r--r--devel/p5-BSD-Resource/pkg-plist11
5 files changed, 21 insertions, 80 deletions
diff --git a/devel/p5-BSD-Resource/Makefile b/devel/p5-BSD-Resource/Makefile
index 9e6b996e7ea6..0203b50e09fb 100644
--- a/devel/p5-BSD-Resource/Makefile
+++ b/devel/p5-BSD-Resource/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= BSD-Resource
-PORTVERSION= 1.10
+PORTVERSION= 1.11
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= BSD
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= tobez@FreeBSD.org
PERL_CONFIGURE= yes
diff --git a/devel/p5-BSD-Resource/distinfo b/devel/p5-BSD-Resource/distinfo
index be94e437a4a4..8b3d9298b787 100644
--- a/devel/p5-BSD-Resource/distinfo
+++ b/devel/p5-BSD-Resource/distinfo
@@ -1 +1 @@
-MD5 (BSD-Resource-1.10.tar.gz) = 15f3cab33e0a284274fc4507d0b9f3cd
+MD5 (BSD-Resource-1.11.tar.gz) = 8e914e1d7a5ef5a710d304ed66b17697
diff --git a/devel/p5-BSD-Resource/pkg-comment b/devel/p5-BSD-Resource/pkg-comment
index 739272f7b04d..ec7a91caf999 100644
--- a/devel/p5-BSD-Resource/pkg-comment
+++ b/devel/p5-BSD-Resource/pkg-comment
@@ -1 +1 @@
-Perl5 module to access BSD process resource limit and priority functions
+Perl module to access BSD process resource limit and priority functions
diff --git a/devel/p5-BSD-Resource/pkg-descr b/devel/p5-BSD-Resource/pkg-descr
index 8f80148bc37e..9a9a7540f93d 100644
--- a/devel/p5-BSD-Resource/pkg-descr
+++ b/devel/p5-BSD-Resource/pkg-descr
@@ -1,78 +1,18 @@
- getrusage
+This Perl extension implements the BSD process resource limit functions
- For a detailed description about the values returned by
- getrusage() please consult your usual C programming
- documentation about getrusage() and also the header file
- sys/resource.h. The $ru_who argument is either
- RUSAGE_SELF (the current process) or RUSAGE_CHILDREN (all
- the child processes of the current process). On some
- (very few) systems (those supporting both getrusage() and
- the POSIX threads) there is also RUSAGE_THREAD. The
- BSD::Resource supports the _THREAD flag if it is present
- but understands nothing about the POSIX threads
- themselves.
+ getrusage() getrlimit() setrlimit()
- Note 1: officially HP-UX 9 does not support getrusage() at
- all but for the time being, it does seem to.
+and the BSD process priority functions. These are available also via
+core Perl but here we do more tricks so that the PRIO_* are available.
- Note 2: Solaris claims in sys/rusage.h that the ixrss and
- the isrss fields are always zero.
+ getpriority() setpriority()
- getrlimit
+Also is provided
- Processes have soft and hard resource limits. At soft
- limit they receive a signal (XCPU or XFSZ, normally) they
- can trap and handle and at hard limit they will be
- ruthlessly killed by the KILL signal. The $resource
- argument can be one of
+ times()
- RLIMIT_CPU RLIMIT_FSIZE
- RLIMIT_DATA RLIMIT_STACK RLIMIT_CORE RLIMIT_RSS
- RLIMIT_NOFILE RLIMIT_OPEN_MAX
- RLIMIT_AS RLIMIT_VMEM
+which provides the same functionality as the one in core Perl, only with
+better time resolution.
- The last two pairs (NO_FILE, OPEN_MAX) and (AS, VMEM) mean
- the same, the former being the BSD names and the latter
- SVR4 names. Two meta-resource-symbols might exist
-
- RLIM_NLIMITS
- RLIM_INFINITY
-
- NLIMITS being the number of possible (but not necessarily
- fully supported) resource limits, INFINITY being useful in
- setrlimit().
-
- NOTE: the level of 'support' for a resource varies. Not
- all the systems
-
- a) even recognise all those limits
- b) really track the consumption of a resource
- c) care (send those signals) if a resource limit get exceeded
-
- Again, please consult your usual C programming
- documentation.
-
- One notable exception: officially HP-UX 9 does not support
- getrlimit() at all but for the time being, it does seem
- to.
-
- getpriority
-
- The priorities returned by getpriority() are
- [PRIO_MIN,PRIO_MAX]. The $which argument can be any of
- PRIO_PROCESS (a process) PRIO_USER (a user), or PRIO_PGRP
- (a process group). The $pr_who argument tells which
- process/user/process group, 0 signifying the current one.
-
- setrlimit
-
- A normal user process can only lower its resource limits.
- Soft or hard limit RLIM_INFINITY means as much as
- possible, the real limits are normally buried inside the
- kernel.
-
- setpriority
-
- The priorities handled by setpriority() are
- [PRIO_MIN,PRIO_MAX]. A normal user process can only lower
- its priority (make it more positive).
+Author: Jarkko Hietaniemi <jhi@iki.fi>
+WWW: http://search.cpan.org/search?dist=BSD-Resource
diff --git a/devel/p5-BSD-Resource/pkg-plist b/devel/p5-BSD-Resource/pkg-plist
index 738996a5f455..b207c6d4ce3c 100644
--- a/devel/p5-BSD-Resource/pkg-plist
+++ b/devel/p5-BSD-Resource/pkg-plist
@@ -1,4 +1,7 @@
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/BSD/Resource.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD/Resource/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD/Resource/Resource.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD/Resource/Resource.so
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD/Resource/_g.al
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD/Resource/autosplit.ix
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD/Resource/get_rlimits.al
@@ -8,6 +11,7 @@ lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD/Resource/getrusage.al
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD/Resource/hard.al
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD/Resource/idrss.al
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD/Resource/inblock.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD/Resource/isrss.al
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD/Resource/ixrss.al
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD/Resource/majflt.al
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD/Resource/maxrss.al
@@ -25,9 +29,6 @@ lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD/Resource/soft.al
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD/Resource/stime.al
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD/Resource/times.al
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD/Resource/utime.al
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD/Resource/Resource.bs
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD/Resource/Resource.so
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD/Resource/.packlist
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD/Resource
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/BSD
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/BSD 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/BSD 2>/dev/null || true