aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2004-01-24 14:42:16 +0800
committeroliver <oliver@FreeBSD.org>2004-01-24 14:42:16 +0800
commit1cd9317574dbd41b1c2e2faba16a65922206f00f (patch)
treeb666453f2941ec131d732606c615fd4ff2bdf9b6 /devel
parentd9d6d8108f1047b965f6f19c6fd84a7c9516de94 (diff)
downloadfreebsd-ports-gnome-1cd9317574dbd41b1c2e2faba16a65922206f00f.tar.gz
freebsd-ports-gnome-1cd9317574dbd41b1c2e2faba16a65922206f00f.tar.zst
freebsd-ports-gnome-1cd9317574dbd41b1c2e2faba16a65922206f00f.zip
use OPTIONS macro
use USE_SDL macro [1] PR: ports/61807 [1] Submitted By: edwin [1]
Diffstat (limited to 'devel')
-rw-r--r--devel/libuta/Makefile11
-rw-r--r--devel/wftk/Makefile11
2 files changed, 6 insertions, 16 deletions
diff --git a/devel/libuta/Makefile b/devel/libuta/Makefile
index 15dace3f5a94..4411145bf83c 100644
--- a/devel/libuta/Makefile
+++ b/devel/libuta/Makefile
@@ -17,9 +17,11 @@ COMMENT= A Graphical User Interface library for C++
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
sigc.1:${PORTSDIR}/devel/libsigc++
+OPTIONS= SDL_MIXER "music and sound support" off
+
USE_FREETYPE= yes
USE_LIBTOOL= yes
-USE_SDL= yes
+USE_SDL= sdl
GNU_CONFIGURE= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
@@ -41,13 +43,6 @@ WITH_SDL_MIXER= yes
USE_SDL= mixer sdl
.endif
-pre-everything::
- @${ECHO} ""
- @${ECHO} "You may use the following build options:"
- @${ECHO} ""
- @${ECHO} " WITH_SDL_MIXER=yes Enable music and sound support"
- @${ECHO} ""
-
post-patch:
.for i in ${SDL11_FILES}
@${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/$i
diff --git a/devel/wftk/Makefile b/devel/wftk/Makefile
index 15dace3f5a94..4411145bf83c 100644
--- a/devel/wftk/Makefile
+++ b/devel/wftk/Makefile
@@ -17,9 +17,11 @@ COMMENT= A Graphical User Interface library for C++
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
sigc.1:${PORTSDIR}/devel/libsigc++
+OPTIONS= SDL_MIXER "music and sound support" off
+
USE_FREETYPE= yes
USE_LIBTOOL= yes
-USE_SDL= yes
+USE_SDL= sdl
GNU_CONFIGURE= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
@@ -41,13 +43,6 @@ WITH_SDL_MIXER= yes
USE_SDL= mixer sdl
.endif
-pre-everything::
- @${ECHO} ""
- @${ECHO} "You may use the following build options:"
- @${ECHO} ""
- @${ECHO} " WITH_SDL_MIXER=yes Enable music and sound support"
- @${ECHO} ""
-
post-patch:
.for i in ${SDL11_FILES}
@${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/$i