aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2001-04-02 21:29:03 +0800
committerolgeni <olgeni@FreeBSD.org>2001-04-02 21:29:03 +0800
commit285f755b1285b407f3eaa8f159b2035f4ed851bd (patch)
treedce020d4a844778a0304885bfa6f1b249fa59cc6 /devel
parent1e385822cea857e153efd2c79f21499f7160fec1 (diff)
downloadfreebsd-ports-gnome-285f755b1285b407f3eaa8f159b2035f4ed851bd.tar.gz
freebsd-ports-gnome-285f755b1285b407f3eaa8f159b2035f4ed851bd.tar.zst
freebsd-ports-gnome-285f755b1285b407f3eaa8f159b2035f4ed851bd.zip
Add wedit, a native LCC-Win32 port to Unix-like operating systems.
It features an user friendly IDE, project wizard, generation of GNU makefiles and automake/autoconf skeletons, fast run-time source parsing with syntax coloring and autoformating of C, Fortran, and Eiffel sources.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/wedit/Makefile24
-rw-r--r--devel/wedit/distinfo1
-rw-r--r--devel/wedit/pkg-comment1
-rw-r--r--devel/wedit/pkg-descr10
-rw-r--r--devel/wedit/pkg-plist120
6 files changed, 157 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 20fded3c57c4..cd1dc7d7f79b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -447,6 +447,7 @@
SUBDIR += veepee
SUBDIR += viewcvs
SUBDIR += vtcl
+ SUBDIR += wedit
SUBDIR += xmake
SUBDIR += xwpe
SUBDIR += xxgdb
diff --git a/devel/wedit/Makefile b/devel/wedit/Makefile
new file mode 100644
index 000000000000..92ccda17e3e6
--- /dev/null
+++ b/devel/wedit/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: wedit
+# Date created: 02 Apr 2001
+# Whom: olgeni@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= wedit
+PORTVERSION= 0.9.8
+CATEGORIES= devel editors
+MASTER_SITES= http://www.q-software-solutions.com/download/weditpub/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-libc6-src
+
+MAINTAINER= olgeni@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_X_PREFIX= yes
+USE_XPM= yes
+USE_GTK= yes
+WANT_GNOME= yes
+USE_LIBTOOL= yes
+
+.include <bsd.port.mk>
diff --git a/devel/wedit/distinfo b/devel/wedit/distinfo
new file mode 100644
index 000000000000..71dc00f8e409
--- /dev/null
+++ b/devel/wedit/distinfo
@@ -0,0 +1 @@
+MD5 (wedit-0.9.8-libc6-src.tar.gz) = aee25c462dd72ab4c8d8d73431b1b62b
diff --git a/devel/wedit/pkg-comment b/devel/wedit/pkg-comment
new file mode 100644
index 000000000000..78c67e26c551
--- /dev/null
+++ b/devel/wedit/pkg-comment
@@ -0,0 +1 @@
+A native LCC-Win32 port to the FreeBSD operating system
diff --git a/devel/wedit/pkg-descr b/devel/wedit/pkg-descr
new file mode 100644
index 000000000000..9c61535ddb69
--- /dev/null
+++ b/devel/wedit/pkg-descr
@@ -0,0 +1,10 @@
+Wedit is a native LCC-Win32 port to Unix-like operating systems.
+
+It features an user friendly IDE, project wizard, generation of GNU
+makefiles and automake/autoconf skeletons, fast run-time source parsing
+with syntax coloring and autoformating of C, Fortran, and Eiffel sources.
+
+It also has complete analysis of source code and object files, many charts
+and plots, and an integrated debugger.
+
+WWW: http://www.q-software-solutions.com/weditlinux/index.shtml
diff --git a/devel/wedit/pkg-plist b/devel/wedit/pkg-plist
new file mode 100644
index 000000000000..8f542c78c495
--- /dev/null
+++ b/devel/wedit/pkg-plist
@@ -0,0 +1,120 @@
+bin/wedit
+bin/wedit_gdb
+share/wedit/askeleton/AUTHORS
+share/wedit/askeleton/ChangeLog
+share/wedit/askeleton/Makefile.am
+share/wedit/askeleton/NEWS
+share/wedit/askeleton/README
+share/wedit/askeleton/acconfig.h
+share/wedit/askeleton/aclocal.m4
+share/wedit/askeleton/autogen.sh
+share/wedit/askeleton/config.h.in
+share/wedit/askeleton/configure
+share/wedit/askeleton/configure.in
+share/wedit/askeleton/install-sh
+share/wedit/askeleton/missing
+share/wedit/askeleton/mkinstalldirs
+share/wedit/help/acknowledgements.html
+share/wedit/help/basics.html
+share/wedit/help/bugreport.html
+share/wedit/help/canvas.html
+share/wedit/help/contact.html
+share/wedit/help/contents.css
+share/wedit/help/contents.html
+share/wedit/help/images/1.gif
+share/wedit/help/images/10.gif
+share/wedit/help/images/11.gif
+share/wedit/help/images/12.gif
+share/wedit/help/images/13.gif
+share/wedit/help/images/14.gif
+share/wedit/help/images/15.gif
+share/wedit/help/images/16.gif
+share/wedit/help/images/17.gif
+share/wedit/help/images/18.gif
+share/wedit/help/images/19.gif
+share/wedit/help/images/2.gif
+share/wedit/help/images/20.gif
+share/wedit/help/images/21.gif
+share/wedit/help/images/22.gif
+share/wedit/help/images/23.gif
+share/wedit/help/images/24.gif
+share/wedit/help/images/25.gif
+share/wedit/help/images/26.gif
+share/wedit/help/images/27.gif
+share/wedit/help/images/28.gif
+share/wedit/help/images/29.gif
+share/wedit/help/images/3.gif
+share/wedit/help/images/30.gif
+share/wedit/help/images/31.gif
+share/wedit/help/images/32.gif
+share/wedit/help/images/33.gif
+share/wedit/help/images/34.gif
+share/wedit/help/images/35.gif
+share/wedit/help/images/36.gif
+share/wedit/help/images/37.gif
+share/wedit/help/images/38.gif
+share/wedit/help/images/39.gif
+share/wedit/help/images/4.gif
+share/wedit/help/images/40.gif
+share/wedit/help/images/41.gif
+share/wedit/help/images/42.gif
+share/wedit/help/images/43.gif
+share/wedit/help/images/44.gif
+share/wedit/help/images/45.gif
+share/wedit/help/images/46.gif
+share/wedit/help/images/47.gif
+share/wedit/help/images/48.gif
+share/wedit/help/images/49.gif
+share/wedit/help/images/5.gif
+share/wedit/help/images/50.gif
+share/wedit/help/images/51.gif
+share/wedit/help/images/52.gif
+share/wedit/help/images/53.gif
+share/wedit/help/images/54.gif
+share/wedit/help/images/6.gif
+share/wedit/help/images/7.gif
+share/wedit/help/images/8.gif
+share/wedit/help/images/9.gif
+share/wedit/help/images/wedit-logo1.gif
+share/wedit/help/index.html
+share/wedit/help/menus.html
+share/wedit/help/tips.html
+share/wedit/help/wedit-logo1.gif
+share/wedit/pixmaps/bkpt.xpm
+share/wedit/pixmaps/dbgcur.xpm
+share/wedit/pixmaps/dir.xpm
+share/wedit/pixmaps/dirup.xpm
+share/wedit/pixmaps/ed.xpm
+share/wedit/pixmaps/execute.xpm
+share/wedit/pixmaps/file.xpm
+share/wedit/pixmaps/find.xpm
+share/wedit/pixmaps/findnext.xpm
+share/wedit/pixmaps/goto.xpm
+share/wedit/pixmaps/grep.xpm
+share/wedit/pixmaps/make.xpm
+share/wedit/pixmaps/new.xpm
+share/wedit/pixmaps/open.xpm
+share/wedit/pixmaps/run.xpm
+share/wedit/pixmaps/save.xpm
+share/wedit/pixmaps/saveall.xpm
+share/wedit/pixmaps/setbookmark.xpm
+share/wedit/pixmaps/start.xpm
+share/wedit/pixmaps/stepin.xpm
+share/wedit/pixmaps/stepout.xpm
+share/wedit/pixmaps/stepover.xpm
+share/wedit/pixmaps/stop.xpm
+share/wedit/pixmaps/undo.xpm
+share/wedit/pixmaps/w1.xpm
+share/wedit/pixmaps/w2h.xpm
+share/wedit/pixmaps/w2v.xpm
+share/wedit/pixmaps/w4.xpm
+share/wedit/registry.dat
+share/wedit/tutorial/example.c
+share/wedit/tutorial/tutorial
+share/wedit/wedit-hlp.sh
+@dirrm share/wedit/help/images
+@dirrm share/wedit/tutorial
+@dirrm share/wedit/help
+@dirrm share/wedit/askeleton
+@dirrm share/wedit/pixmaps
+@dirrm share/wedit