aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-04-18 11:59:21 +0800
committerdinoex <dinoex@FreeBSD.org>2003-04-18 11:59:21 +0800
commit2beb342728929d81a0c13419923a1941f24166dc (patch)
tree4d30f5128276464a2fb98fb8301b5d3416cd6b8b /devel
parentb478e75fc5e556e2205a2d4c49df30558d8edc47 (diff)
downloadfreebsd-ports-gnome-2beb342728929d81a0c13419923a1941f24166dc.tar.gz
freebsd-ports-gnome-2beb342728929d81a0c13419923a1941f24166dc.tar.zst
freebsd-ports-gnome-2beb342728929d81a0c13419923a1941f24166dc.zip
- use lang/gnustep-objc so libobjc.so is be used
PR: 50479 Approved by: knu
Diffstat (limited to 'devel')
-rw-r--r--devel/ruby-gnustep/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/devel/ruby-gnustep/Makefile b/devel/ruby-gnustep/Makefile
index 63c785bde696..8b71054ab379 100644
--- a/devel/ruby-gnustep/Makefile
+++ b/devel/ruby-gnustep/Makefile
@@ -23,6 +23,7 @@ BUILD_DEPENDS= ${GNUSTEP_PREFIX}/System/Makefiles/GNUstep.sh:${PORTSDIR}/devel/g
${COMBOLIBDIR}/libgnustep-base.so:${PORTSDIR}/lang/gnustep-base \
${COMBOLIBDIR}/libgnustep-gui.so:${PORTSDIR}/x11-toolkits/gnustep-gui \
${BACKBUNDLEDIR}/libgnustep-back:${PORTSDIR}/x11-toolkits/gnustep-back
+LIB_DEPENDS+= objc:${PORTSDIR}/${GNUSTEP_OBJC_PORT}
RUN_DEPENDS= ${GNUSTEP_PREFIX}/System/Makefiles/GNUstep.sh:${PORTSDIR}/devel/gnustep-make \
${COMBOLIBDIR}/libgnustep-base.so:${PORTSDIR}/lang/gnustep-base \
${COMBOLIBDIR}/libgnustep-gui.so:${PORTSDIR}/x11-toolkits/gnustep-gui \
@@ -31,8 +32,10 @@ RUN_DEPENDS= ${GNUSTEP_PREFIX}/System/Makefiles/GNUstep.sh:${PORTSDIR}/devel/gnu
USE_RUBY= yes
RUBY_WITH_PTHREAD= yes
USE_GMAKE= yes
-USE_GCC= 3.2
+CC= gcc32
+CXX= g++32
+GNUSTEP_OBJC_PORT?= lang/gnustep-objc
GNUSTEP_PREFIX= ${LOCALBASE}/GNUstep
GNUSTEP_LOCAL_ROOT= ${GNUSTEP_PREFIX}/Local
GNUSTEP_SYSTEM_ROOT= ${GNUSTEP_PREFIX}/System