aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-01-02 15:40:39 +0800
committerjgh <jgh@FreeBSD.org>2013-01-02 15:40:39 +0800
commit34524da12229902b43512241386cf7296f477193 (patch)
treec328e054f6db7a434670a8b21da81113b1d977a1 /devel
parent9a6b3df36176e123310fe200d0464ae39e3294d9 (diff)
downloadfreebsd-ports-gnome-34524da12229902b43512241386cf7296f477193.tar.gz
freebsd-ports-gnome-34524da12229902b43512241386cf7296f477193.tar.zst
freebsd-ports-gnome-34524da12229902b43512241386cf7296f477193.zip
- add new port : devel/rbenv
rbenv lets you easily switch between multiple versions of Ruby. It's simple, unobtrusive, and follows the UNIX tradition of single-purpose tools that do one thing well. WWW: https://github.com/sstephenson/rbenv PR: 174735 Submitted by: fmb@onibox.net
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rbenv/Makefile31
-rw-r--r--devel/rbenv/distinfo2
-rw-r--r--devel/rbenv/pkg-descr5
-rw-r--r--devel/rbenv/pkg-plist25
5 files changed, 64 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b7529ad6a2d6..ab74c71f0a1c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3781,6 +3781,7 @@
SUBDIR += ragel
SUBDIR += raknet
SUBDIR += rapidsvn
+ SUBDIR += rbenv
SUBDIR += rbtools
SUBDIR += rclint
SUBDIR += rcs
diff --git a/devel/rbenv/Makefile b/devel/rbenv/Makefile
new file mode 100644
index 000000000000..301cc3af2e91
--- /dev/null
+++ b/devel/rbenv/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= rbenv
+PORTVERSION= 0.3.0
+CATEGORIES= devel ruby
+MASTER_SITES= GH
+
+MAINTAINER= fmb@onibox.net
+COMMENT= Manage multiple versions of ruby
+
+LICENSE= RBENV
+LICENSE_NAME= Sam Stephenson
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= ${_LICENSE_PERMS_DEFAULT}
+
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+USE_GITHUB= yes
+GH_ACCOUNT= sstephenson
+GH_PROJECT= rbenv
+GH_COMMIT= b10bdb1
+GH_TAGNAME= v${PORTVERSION}
+
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/ruby-local-exec ${PREFIX}/bin
+ ( cd ${WRKSRC}/libexec && ${COPYTREE_BIN} \* ${PREFIX}/libexec )
+ @${LN} -sf ${PREFIX}/libexec/rbenv ${PREFIX}/bin/rbenv
+
+.include <bsd.port.mk>
diff --git a/devel/rbenv/distinfo b/devel/rbenv/distinfo
new file mode 100644
index 000000000000..21fba4069ccc
--- /dev/null
+++ b/devel/rbenv/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rbenv-0.3.0.tar.gz) = 445b8d742bbb72a4e65280e655122914d13954566fe7f46c7706f7730bbeaa35
+SIZE (rbenv-0.3.0.tar.gz) = 13703
diff --git a/devel/rbenv/pkg-descr b/devel/rbenv/pkg-descr
new file mode 100644
index 000000000000..06fb0fb25493
--- /dev/null
+++ b/devel/rbenv/pkg-descr
@@ -0,0 +1,5 @@
+rbenv lets you easily switch between multiple versions of Ruby.
+It's simple, unobtrusive, and follows the UNIX tradition of
+single-purpose tools that do one thing well.
+
+WWW: https://github.com/sstephenson/rbenv
diff --git a/devel/rbenv/pkg-plist b/devel/rbenv/pkg-plist
new file mode 100644
index 000000000000..85f31ddffcbf
--- /dev/null
+++ b/devel/rbenv/pkg-plist
@@ -0,0 +1,25 @@
+bin/rbenv
+bin/ruby-local-exec
+libexec/rbenv
+libexec/rbenv-commands
+libexec/rbenv-completions
+libexec/rbenv-exec
+libexec/rbenv-global
+libexec/rbenv-help
+libexec/rbenv-hooks
+libexec/rbenv-init
+libexec/rbenv-local
+libexec/rbenv-prefix
+libexec/rbenv-rehash
+libexec/rbenv-root
+libexec/rbenv-sh-shell
+libexec/rbenv-shims
+libexec/rbenv-version
+libexec/rbenv-version-file
+libexec/rbenv-version-file-read
+libexec/rbenv-version-file-write
+libexec/rbenv-version-name
+libexec/rbenv-version-origin
+libexec/rbenv-versions
+libexec/rbenv-whence
+libexec/rbenv-which