aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2003-09-26 14:48:08 +0800
committerdaichi <daichi@FreeBSD.org>2003-09-26 14:48:08 +0800
commit4ef0e1e1ced03b164601807af0722a958900e75d (patch)
tree7ea63aed2b099e3cb616982a2c535aeaf5a5e82f /devel
parente6424b892dc1c0da6c490b7de69a7dcf3361b528 (diff)
downloadfreebsd-ports-gnome-4ef0e1e1ced03b164601807af0722a958900e75d.tar.gz
freebsd-ports-gnome-4ef0e1e1ced03b164601807af0722a958900e75d.tar.zst
freebsd-ports-gnome-4ef0e1e1ced03b164601807af0722a958900e75d.zip
update devel/pcsc-lite: 1.1.2.b.5 -> 1.2.0-rc1
PR: 56019 Submitted by: Toni Andjelkovic <toni@soth.at> (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/pcsc-lite/Makefile24
-rw-r--r--devel/pcsc-lite/distinfo2
-rw-r--r--devel/pcsc-lite/files/patch-ltmain.sh12
-rw-r--r--devel/pcsc-lite/files/patch-src::configfile.c12
-rw-r--r--devel/pcsc-lite/files/patch-src::tokenparser.c12
-rw-r--r--devel/pcsc-lite/pkg-descr8
-rw-r--r--devel/pcsc-lite/pkg-plist7
7 files changed, 38 insertions, 39 deletions
diff --git a/devel/pcsc-lite/Makefile b/devel/pcsc-lite/Makefile
index cf01615e83c1..84d13d2c74b3 100644
--- a/devel/pcsc-lite/Makefile
+++ b/devel/pcsc-lite/Makefile
@@ -6,22 +6,21 @@
#
PORTNAME= pcsc-lite
-PORTVERSION= 1.1.2.b.5
+PORTVERSION= 1.2.0-rc1
CATEGORIES= devel security
-MASTER_SITES= http://alioth.debian.org/download.php/160/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.b./beta/}
+MASTER_SITES= http://alioth.debian.org/download.php/373/
MAINTAINER= toni@soth.at
COMMENT= A smartcard development library
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.b.5//}
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}"
-CONFIGURE_ARGS+=--enable-debug \
+CONFIGURE_ARGS+=--prefix=${PREFIX} \
+ --enable-debug \
--enable-syslog \
--enable-runpid=/var/run/pcscd.pid \
--enable-ipcdir=/var/tmp/ \
@@ -33,6 +32,17 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
MAN1= formaticc.1
MAN8= bundleTool.8 pcscd.8
+.if defined(WITH_USB)
+LIB_DEPENDS+= usb-0.1.7:${PORTSDIR}/devel/libusb
+CONFIGURE_ARGS+=--enable-libusb=${PREFIX}
+.endif
+
+pre-everything::
+ @${ECHO_MSG}
+ @${ECHO_MSG} "pcsc-lite has the following option(s):"
+ @${ECHO_MSG} " WITH_USB=yes Enable USB support"
+ @${ECHO_MSG}
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -40,6 +50,10 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/pcsc-lite-0.8.7.pdf ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/muscle-api-1.3.0.pdf ${DOCSDIR}
.endif
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/example/Makefile.am ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/example/Makefile.in ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/example/pcsc_demo.c ${EXAMPLESDIR}
@${MKDIR} ${PREFIX}/pcsc/drivers
@${MKDIR} ${PREFIX}/pcsc/services
${INSTALL_DATA} ${WRKSRC}/etc/reader.conf \
diff --git a/devel/pcsc-lite/distinfo b/devel/pcsc-lite/distinfo
index f8c22aae05e0..35e2486621b9 100644
--- a/devel/pcsc-lite/distinfo
+++ b/devel/pcsc-lite/distinfo
@@ -1 +1 @@
-MD5 (pcsc-lite-1.1.2beta5.tar.gz) = 38791ef76bd0c731d26893317d24fe3b
+MD5 (pcsc-lite-1.2.0-rc1.tar.gz) = 540fc780d948dfcc087b8e79ea9063f6
diff --git a/devel/pcsc-lite/files/patch-ltmain.sh b/devel/pcsc-lite/files/patch-ltmain.sh
index 160d8e579d9f..5397812c60bf 100644
--- a/devel/pcsc-lite/files/patch-ltmain.sh
+++ b/devel/pcsc-lite/files/patch-ltmain.sh
@@ -2,15 +2,15 @@ $FreeBSD$
--- build/ltmain.sh 2001/08/27 09:51:26 1.1
+++ build/ltmain.sh 2001/08/27 09:51:42
-@@ -1072,7 +1072,7 @@
+@@ -1278,7 +1278,7 @@
esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
- *-*-openbsd* | *-*-freebsd*)
+ *-*-openbsd*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
@@ -2408,6 +2408,9 @@
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
diff --git a/devel/pcsc-lite/files/patch-src::configfile.c b/devel/pcsc-lite/files/patch-src::configfile.c
deleted file mode 100644
index 9ae42643e4af..000000000000
--- a/devel/pcsc-lite/files/patch-src::configfile.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/configfile.c.bak Sun Jun 1 23:43:39 2003
-+++ src/configfile.c Sun Jun 1 23:43:59 2003
-@@ -20,7 +20,9 @@
- #include <string.h>
- #include <errno.h>
- #include <stdlib.h>
-+#ifdef HAVE_STDINT_H
- #include <stdint.h> /* May break IA64 test-noansi-r */
-+#endif
-
- /* end standard C headers. */
-
diff --git a/devel/pcsc-lite/files/patch-src::tokenparser.c b/devel/pcsc-lite/files/patch-src::tokenparser.c
deleted file mode 100644
index de52df7de96c..000000000000
--- a/devel/pcsc-lite/files/patch-src::tokenparser.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/tokenparser.c.bak Sun Jun 1 23:44:13 2003
-+++ src/tokenparser.c Sun Jun 1 23:44:31 2003
-@@ -20,7 +20,9 @@
- #include <string.h>
- #include <errno.h>
- #include <stdlib.h>
-+#ifdef HAVE_STDINT_H
- #include <stdint.h> /* May break IA64 test-noansi-r */
-+#endif
-
- /* end standard C headers. */
-
diff --git a/devel/pcsc-lite/pkg-descr b/devel/pcsc-lite/pkg-descr
index 82c78cf54fdc..a85cd684c50d 100644
--- a/devel/pcsc-lite/pkg-descr
+++ b/devel/pcsc-lite/pkg-descr
@@ -3,7 +3,9 @@ Allows easy porting of Windows smartcard software to other
operating systems. Supports many types of serial, PCMCIA,
and USB smartcard readers and cryptographic tokens.
Tested under Linux, Solaris 8, HPUX 11, OS X (10.1),
-OpenBSD, FreeBSD 4.
+OpenBSD, FreeBSD.
-Author: David Corcoran <corcoran@linuxnet.com>
-WWW: http://www.linuxnet.com/middle.html
+Authors: David Corcoran <corcoran@linuxnet.com>,
+ Ludovic Rousseau <ludovic.rousseau@free.fr>
+
+WWW: http://alioth.debian.org/projects/pcsclite/
diff --git a/devel/pcsc-lite/pkg-plist b/devel/pcsc-lite/pkg-plist
index c7d88deb93e1..6190512f0095 100644
--- a/devel/pcsc-lite/pkg-plist
+++ b/devel/pcsc-lite/pkg-plist
@@ -1,9 +1,13 @@
bin/bundleTool
bin/formaticc
bin/installifd
+bin/pcsc_demo
%%PORTDOCS%%share/doc/pcsc-lite/README.DAEMON
%%PORTDOCS%%share/doc/pcsc-lite/pcsc-lite-0.8.7.pdf
%%PORTDOCS%%share/doc/pcsc-lite/muscle-api-1.3.0.pdf
+share/examples/pcsc-lite/Makefile.am
+share/examples/pcsc-lite/Makefile.in
+share/examples/pcsc-lite/pcsc_demo.c
etc/rc.d/pcscd.sh.sample
etc/reader.conf.sample
include/debuglog.h
@@ -15,8 +19,11 @@ include/wintypes.h
lib/libpcsclite.a
lib/libpcsclite.so
lib/libpcsclite.so.0
+lib/pkgconfig/libpcsclite.pc
sbin/pcscd
%%PORTDOCS%%@dirrm share/doc/pcsc-lite
+@dirrm share/examples/pcsc-lite
+@dirrm lib/pkgconfig
@dirrm pcsc/drivers
@dirrm pcsc/services
@dirrm pcsc