aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjoerg <joerg@FreeBSD.org>2001-03-16 01:02:30 +0800
committerjoerg <joerg@FreeBSD.org>2001-03-16 01:02:30 +0800
commit51b55eb360f15438623aea30fd00f87865e668ce (patch)
tree44b8c487fad70e79f300f8197d94f3b3045bb172 /devel
parent48d9df61341b943d354fd07fea86d65411779abb (diff)
downloadfreebsd-ports-gnome-51b55eb360f15438623aea30fd00f87865e668ce.tar.gz
freebsd-ports-gnome-51b55eb360f15438623aea30fd00f87865e668ce.tar.zst
freebsd-ports-gnome-51b55eb360f15438623aea30fd00f87865e668ce.zip
Crude hack to get all this running on the alpha architecutre as well.
Since gcc (in the assumption of generating a native compiler) doesn't want to cbe configured for an alpha*-*-freebsd* system, we hack the configure script to allow this (similarly to netbsd). In the end, all this will be ignored anyway since it's getting to become a cross-compiler.
Diffstat (limited to 'devel')
-rw-r--r--devel/avr-gcc-3/files/patch-aa22
-rw-r--r--devel/avr-gcc/files/patch-aa22
2 files changed, 44 insertions, 0 deletions
diff --git a/devel/avr-gcc-3/files/patch-aa b/devel/avr-gcc-3/files/patch-aa
new file mode 100644
index 000000000000..32f7da28a8ac
--- /dev/null
+++ b/devel/avr-gcc-3/files/patch-aa
@@ -0,0 +1,22 @@
+--- gcc/configure.in.orig Sat Mar 10 22:07:33 2001
++++ gcc/configure.in Sat Mar 10 22:13:54 2001
+@@ -626,7 +626,7 @@
+ thread_file='posix'
+ fi
+ ;;
+- alpha*-*-netbsd*)
++ alpha*-*-netbsd*|alpha*-*-freebsd*)
+ tm_file="${tm_file} alpha/elf.h alpha/netbsd.h alpha/netbsd-elf.h"
+ target_cpu_default="MASK_GAS"
+ tmake_file="alpha/t-crtbe alpha/t-ieee"
+--- gcc/configure.orig Wed Oct 13 09:58:02 1999
++++ gcc/configure Thu Mar 15 17:52:27 2001
+@@ -3059,7 +3059,7 @@
+ thread_file='posix'
+ fi
+ ;;
+- alpha*-*-netbsd*)
++ alpha*-*-netbsd*|alpha*-*-freebsd*)
+ tm_file="${tm_file} alpha/elf.h alpha/netbsd.h alpha/netbsd-elf.h"
+ target_cpu_default="MASK_GAS"
+ tmake_file="alpha/t-crtbe alpha/t-ieee"
diff --git a/devel/avr-gcc/files/patch-aa b/devel/avr-gcc/files/patch-aa
new file mode 100644
index 000000000000..32f7da28a8ac
--- /dev/null
+++ b/devel/avr-gcc/files/patch-aa
@@ -0,0 +1,22 @@
+--- gcc/configure.in.orig Sat Mar 10 22:07:33 2001
++++ gcc/configure.in Sat Mar 10 22:13:54 2001
+@@ -626,7 +626,7 @@
+ thread_file='posix'
+ fi
+ ;;
+- alpha*-*-netbsd*)
++ alpha*-*-netbsd*|alpha*-*-freebsd*)
+ tm_file="${tm_file} alpha/elf.h alpha/netbsd.h alpha/netbsd-elf.h"
+ target_cpu_default="MASK_GAS"
+ tmake_file="alpha/t-crtbe alpha/t-ieee"
+--- gcc/configure.orig Wed Oct 13 09:58:02 1999
++++ gcc/configure Thu Mar 15 17:52:27 2001
+@@ -3059,7 +3059,7 @@
+ thread_file='posix'
+ fi
+ ;;
+- alpha*-*-netbsd*)
++ alpha*-*-netbsd*|alpha*-*-freebsd*)
+ tm_file="${tm_file} alpha/elf.h alpha/netbsd.h alpha/netbsd-elf.h"
+ target_cpu_default="MASK_GAS"
+ tmake_file="alpha/t-crtbe alpha/t-ieee"