aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-03-25 07:35:16 +0800
committerbapt <bapt@FreeBSD.org>2014-03-25 07:35:16 +0800
commit574d945c5423b184c65ca238ce9bda62b643bbba (patch)
treeb101f5ea42386b687b221ad4f17952d18b57bb4b /devel
parent976295523abe8f8d64eb479f4cf2e2d5a00ac4a7 (diff)
downloadfreebsd-ports-gnome-574d945c5423b184c65ca238ce9bda62b643bbba.tar.gz
freebsd-ports-gnome-574d945c5423b184c65ca238ce9bda62b643bbba.tar.zst
freebsd-ports-gnome-574d945c5423b184c65ca238ce9bda62b643bbba.zip
Support stage
Diffstat (limited to 'devel')
-rw-r--r--devel/libmsocket/Makefile25
1 files changed, 12 insertions, 13 deletions
diff --git a/devel/libmsocket/Makefile b/devel/libmsocket/Makefile
index c87c87c2f653..af616da9c2ac 100644
--- a/devel/libmsocket/Makefile
+++ b/devel/libmsocket/Makefile
@@ -8,11 +8,13 @@ CATEGORIES= devel net
MASTER_SITES= SF/kageki/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= rodrigo@FreeBSD.org
-COMMENT= A socket abstraction library for C programmers
+COMMENT= Socket abstraction library for C programmers
-LIB_DEPENDS= event:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= libevent-1.4.so:${PORTSDIR}/devel/libevent
-USE_BZIP2= yes
+OPTIONS_DEFINE= DEBUG
+
+USES= tar:bzip2 desthack
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-throttling \
@@ -24,19 +26,16 @@ PLIST_FILES= lib/libmsocket.so \
include/msocket.h \
include/msocketutils.h
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} != "i386"
-CFLAGS+= -fPIC -DPIC
-.endif
+CFLAGS_amd64+= -fPIC -DPIC
+CFLAGS_iad64+= -fPIC -DPIC
-.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+= --enable-debug
-.endif
+DEBUG_CONFIGURE_ON= --enable-debug
post-patch:
${REINPLACE_CMD} 's, withval=$$with_libevent; cf_enable_libevent=$$enableval, withval=$$with_libevent; cf_enable_libevent=$$with_libevent,' \
${WRKSRC}/configure
-.include <bsd.port.post.mk>
+post-install:
+ ${LN} -sf libmsocket.so.0.1 ${STAGEDIR}${PREFIX}/lib/libmsocket.so
+
+.include <bsd.port.mk>