aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortabthorpe <tabthorpe@FreeBSD.org>2007-12-28 00:03:39 +0800
committertabthorpe <tabthorpe@FreeBSD.org>2007-12-28 00:03:39 +0800
commit5fc5f53135a69e21687eb179c5c27c6123d3c795 (patch)
treea4e64ba47563158bf82287b53d84ba7a6e089cd3 /devel
parent355966faf6ea24bb031fface5c805f8f058d350c (diff)
downloadfreebsd-ports-gnome-5fc5f53135a69e21687eb179c5c27c6123d3c795.tar.gz
freebsd-ports-gnome-5fc5f53135a69e21687eb179c5c27c6123d3c795.tar.zst
freebsd-ports-gnome-5fc5f53135a69e21687eb179c5c27c6123d3c795.zip
The SNMP-Persist module is a backend for pass_persist feature of
net-snmp. It simplifies the process of sharing user-specified data via SNMP and development of persistent net-snmp applications controlling a chosen MIB subtree. It is particularly useful if data gathering process takes too long. The responder is a separate thread, which is not influenced by updates of MIB subtree data. The answer to a snmp request is fast and doesn't rely on potentially slow source of data. WWW: http://search.cpan.org/~anias/SNMP-Persist-0.05/ PR: ports/117311 Submitted by: Philippe Audeoud <jadawin at tuxaco.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-SNMP-Persist/Makefile29
-rw-r--r--devel/p5-SNMP-Persist/distinfo3
-rw-r--r--devel/p5-SNMP-Persist/pkg-descr13
-rw-r--r--devel/p5-SNMP-Persist/pkg-plist5
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a048971e1290..35a4bbd47526 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1494,6 +1494,7 @@
SUBDIR += p5-Rose-Object
SUBDIR += p5-RunApp
SUBDIR += p5-SDL
+ SUBDIR += p5-SNMP-Persist
SUBDIR += p5-SPOPS
SUBDIR += p5-SSN-Validate
SUBDIR += p5-SVN-ACL
diff --git a/devel/p5-SNMP-Persist/Makefile b/devel/p5-SNMP-Persist/Makefile
new file mode 100644
index 000000000000..1efdedd3cd1d
--- /dev/null
+++ b/devel/p5-SNMP-Persist/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-SNMP-Persist
+# Date created: 2007-10-18
+# Whom: Philippe Audeoud <jadawin@tuxaco.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SNMP-Persist
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= SNMP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jadawin@tuxaco.net
+COMMENT= The module is a backend for pass_persist feature of net-snmp
+
+PERL_CONFIGURE= 5.8.0+
+
+MAN3= SNMP::Persist.3
+
+.include <bsd.port.pre.mk>
+
+PERL_THREADED!= ${PERL} -mthreads -e '' >/dev/null 2>&1 && ${ECHO_CMD} 'yes' || true
+. if ${PERL_THREADED} == ""
+IGNORE= must be built with a threaded Perl
+. endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-SNMP-Persist/distinfo b/devel/p5-SNMP-Persist/distinfo
new file mode 100644
index 000000000000..dc3da18f56fa
--- /dev/null
+++ b/devel/p5-SNMP-Persist/distinfo
@@ -0,0 +1,3 @@
+MD5 (SNMP-Persist-0.05.tar.gz) = 70f0b4025e2586110fdc22165bc1b985
+SHA256 (SNMP-Persist-0.05.tar.gz) = 7633b3da85fe5a412a4188e04a6aba93146af71ec88a94147e8b8804e1b63cbb
+SIZE (SNMP-Persist-0.05.tar.gz) = 5845
diff --git a/devel/p5-SNMP-Persist/pkg-descr b/devel/p5-SNMP-Persist/pkg-descr
new file mode 100644
index 000000000000..d6ab351eeaae
--- /dev/null
+++ b/devel/p5-SNMP-Persist/pkg-descr
@@ -0,0 +1,13 @@
+The SNMP-Persist module is a backend for pass_persist feature of
+net-snmp.
+
+It simplifies the process of sharing user-specified data via SNMP and
+development of persistent net-snmp applications controlling a chosen MIB
+subtree.
+
+It is particularly useful if data gathering process takes too long. The
+responder is a separate thread, which is not influenced by updates of
+MIB subtree data. The answer to a snmp request is fast and doesn't rely
+on potentially slow source of data.
+
+WWW: http://search.cpan.org/~anias/SNMP-Persist-0.05/
diff --git a/devel/p5-SNMP-Persist/pkg-plist b/devel/p5-SNMP-Persist/pkg-plist
new file mode 100644
index 000000000000..cb0fc38550fa
--- /dev/null
+++ b/devel/p5-SNMP-Persist/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/SNMP/Persist.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SNMP/Persist/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/SNMP/Persist/
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SNMP/
+@dirrmtry %%SITE_PERL%%/SNMP