aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2013-12-11 15:53:16 +0800
committermartymac <martymac@FreeBSD.org>2013-12-11 15:53:16 +0800
commit63085dbe7001d2c0ad3d43a25b2089bca2dd5d09 (patch)
tree8b4c5614f80c279b3ed53fa205279aa39e981bf9 /devel
parent1e44414ac1fc19649ac69a21f55d3d3aa4c83b75 (diff)
downloadfreebsd-ports-gnome-63085dbe7001d2c0ad3d43a25b2089bca2dd5d09.tar.gz
freebsd-ports-gnome-63085dbe7001d2c0ad3d43a25b2089bca2dd5d09.tar.zst
freebsd-ports-gnome-63085dbe7001d2c0ad3d43a25b2089bca2dd5d09.zip
- Update devel/tbb to 4.2.2
- Cleanup DISTNAME and WRKSRC definitions - Use INSTALL_LIB instead of INSTALL_DATA + STRIP_CMD - Bump dependent ports' revisions PR: ports/184526 Submitted by: delphij
Diffstat (limited to 'devel')
-rw-r--r--devel/tbb/Makefile15
-rw-r--r--devel/tbb/distinfo4
-rw-r--r--devel/tbb/pkg-plist157
3 files changed, 89 insertions, 87 deletions
diff --git a/devel/tbb/Makefile b/devel/tbb/Makefile
index 8ceebf0e095f..66759f7a7582 100644
--- a/devel/tbb/Makefile
+++ b/devel/tbb/Makefile
@@ -2,12 +2,11 @@
# $FreeBSD$
PORTNAME= tbb
-PORTVERSION= 4.1.3
-PORTREVISION= 1
+PORTVERSION= 4.2.2
CATEGORIES= devel
MASTER_SITES= http://threadingbuildingblocks.org/sites/default/files/software_releases/source/ \
LOCAL/martymac
-DISTNAME= tbb41_20130314oss_src
+DISTNAME= ${PORTNAME}${PORTVERSION:R:S/.//g}_20131118oss_src
EXTRACT_SUFX= .tgz
MAINTAINER= martymac@FreeBSD.org
@@ -22,7 +21,7 @@ USE_LDCONFIG= yes
USES= gmake
ALL_TARGET= default
-WRKSRC= ${WRKDIR}/tbb41_20130314oss
+WRKSRC= ${WRKDIR}/${DISTNAME:S/_src//}
post-extract:
.if ${CC} != "gcc"
@@ -36,19 +35,15 @@ post-patch:
do-install:
cd ${WRKSRC}; \
- ${INSTALL_DATA} build/FreeBSD*release/libtbb.so \
+ ${INSTALL_LIB} build/FreeBSD*release/libtbb.so \
${STAGEDIR}${PREFIX}/lib/libtbb.so.4; \
${LN} -sf ${PREFIX}/lib/libtbb.so.4 \
${STAGEDIR}${PREFIX}/lib/libtbb.so; \
- ${INSTALL_DATA} build/FreeBSD*release/libtbbmalloc.so \
+ ${INSTALL_LIB} build/FreeBSD*release/libtbbmalloc.so \
${STAGEDIR}${PREFIX}/lib/libtbbmalloc.so.4; \
${LN} -sf ${PREFIX}/lib/libtbbmalloc.so.4 \
${STAGEDIR}${PREFIX}/lib/libtbbmalloc.so; \
${MKDIR} ${STAGEDIR}${PREFIX}/include/tbb/; \
cd include/tbb/ && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/include/tbb/
-post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libtbb.so.4
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libtbbmalloc.so.4
-
.include <bsd.port.mk>
diff --git a/devel/tbb/distinfo b/devel/tbb/distinfo
index aac70937319d..e4780cdbcdba 100644
--- a/devel/tbb/distinfo
+++ b/devel/tbb/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tbb41_20130314oss_src.tgz) = 32fd5979971b772caa96d40646cee585ed0070516ba2dbbcb1f9b6033d08a92d
-SIZE (tbb41_20130314oss_src.tgz) = 2967843
+SHA256 (tbb42_20131118oss_src.tgz) = d95b816ac1618f5047d9ac4db1709d1f8bbeafaed597ce1ee7862b9577680882
+SIZE (tbb42_20131118oss_src.tgz) = 3134290
diff --git a/devel/tbb/pkg-plist b/devel/tbb/pkg-plist
index 1edd70ac7913..27b034519a9e 100644
--- a/devel/tbb/pkg-plist
+++ b/devel/tbb/pkg-plist
@@ -1,97 +1,104 @@
-include/tbb/concurrent_priority_queue.h
-include/tbb/task.h
-include/tbb/parallel_while.h
-include/tbb/task_scheduler_init.h
-include/tbb/tbb_config.h
-include/tbb/tbb_exception.h
-include/tbb/critical_section.h
-include/tbb/index.html
-include/tbb/parallel_invoke.h
+include/tbb/aggregator.h
+include/tbb/aligned_space.h
+include/tbb/atomic.h
+include/tbb/blocked_range.h
+include/tbb/blocked_range2d.h
+include/tbb/blocked_range3d.h
+include/tbb/cache_aligned_allocator.h
include/tbb/combinable.h
-include/tbb/parallel_reduce.h
-include/tbb/tbb_stddef.h
+include/tbb/compat/condition_variable
+include/tbb/compat/ppl.h
+include/tbb/compat/thread
+include/tbb/compat/tuple
+include/tbb/concurrent_hash_map.h
+include/tbb/concurrent_lru_cache.h
+include/tbb/concurrent_priority_queue.h
include/tbb/concurrent_queue.h
-include/tbb/partitioner.h
-include/tbb/parallel_do.h
-include/tbb/mutex.h
-include/tbb/atomic.h
-include/tbb/queuing_rw_mutex.h
-include/tbb/tick_count.h
-include/tbb/parallel_for.h
-include/tbb/recursive_mutex.h
+include/tbb/concurrent_unordered_map.h
include/tbb/concurrent_unordered_set.h
-include/tbb/memory_pool.h
+include/tbb/concurrent_vector.h
+include/tbb/critical_section.h
+include/tbb/enumerable_thread_specific.h
include/tbb/flow_graph.h
-include/tbb/runtime_loader.h
-include/tbb/concurrent_lru_cache.h
-include/tbb/aggregator.h
-include/tbb/task_arena.h
-include/tbb/machine/icc_generic.h
-include/tbb/machine/mic_common.h
+include/tbb/index.html
+include/tbb/internal/_aggregator_impl.h
+include/tbb/internal/_concurrent_queue_impl.h
+include/tbb/internal/_concurrent_unordered_impl.h
+include/tbb/internal/_flow_graph_impl.h
+include/tbb/internal/_flow_graph_item_buffer_impl.h
+include/tbb/internal/_flow_graph_join_impl.h
+include/tbb/internal/_flow_graph_node_impl.h
+include/tbb/internal/_flow_graph_or_impl.h
+include/tbb/internal/_flow_graph_tagged_buffer_impl.h
+include/tbb/internal/_flow_graph_trace_impl.h
+include/tbb/internal/_flow_graph_types_impl.h
+include/tbb/internal/_mutex_padding.h
+include/tbb/internal/_tbb_strings.h
+include/tbb/internal/_tbb_windef.h
+include/tbb/internal/_x86_eliding_mutex_impl.h
+include/tbb/internal/_x86_rtm_rw_mutex_impl.h
include/tbb/machine/gcc_armv7.h
-include/tbb/machine/gcc_ia32_common.h
-include/tbb/machine/msvc_ia32_common.h
include/tbb/machine/gcc_generic.h
-include/tbb/machine/windows_api.h
-include/tbb/machine/macos_common.h
-include/tbb/machine/sunos_sparc.h
-include/tbb/machine/xbox360_ppc.h
-include/tbb/machine/mac_ppc.h
+include/tbb/machine/gcc_ia32_common.h
+include/tbb/machine/gcc_itsx.h
include/tbb/machine/ibm_aix51.h
+include/tbb/machine/icc_generic.h
+include/tbb/machine/linux_common.h
include/tbb/machine/linux_ia32.h
include/tbb/machine/linux_ia64.h
-include/tbb/machine/linux_common.h
-include/tbb/machine/windows_intel64.h
include/tbb/machine/linux_intel64.h
+include/tbb/machine/mac_ppc.h
+include/tbb/machine/macos_common.h
+include/tbb/machine/mic_common.h
+include/tbb/machine/msvc_armv7.h
+include/tbb/machine/msvc_ia32_common.h
+include/tbb/machine/sunos_sparc.h
+include/tbb/machine/windows_api.h
include/tbb/machine/windows_ia32.h
-include/tbb/internal/_aggregator_impl.h
-include/tbb/internal/_flow_graph_tagged_buffer_impl.h
-include/tbb/internal/_flow_graph_impl.h
-include/tbb/internal/_flow_graph_join_impl.h
-include/tbb/internal/_flow_graph_or_impl.h
-include/tbb/internal/_flow_graph_node_impl.h
-include/tbb/internal/_flow_graph_types_impl.h
-include/tbb/internal/_tbb_windef.h
-include/tbb/internal/_concurrent_queue_impl.h
-include/tbb/internal/_concurrent_unordered_impl.h
-include/tbb/internal/_flow_graph_item_buffer_impl.h
-include/tbb/concurrent_vector.h
+include/tbb/machine/windows_intel64.h
+include/tbb/machine/xbox360_ppc.h
+include/tbb/memory_pool.h
+include/tbb/mutex.h
+include/tbb/null_mutex.h
+include/tbb/null_rw_mutex.h
+include/tbb/parallel_do.h
+include/tbb/parallel_for.h
include/tbb/parallel_for_each.h
-include/tbb/tbb_allocator.h
-include/tbb/queuing_mutex.h
-include/tbb/blocked_range2d.h
-include/tbb/parallel_sort.h
-include/tbb/task_scheduler_observer.h
-include/tbb/blocked_range.h
+include/tbb/parallel_invoke.h
+include/tbb/parallel_reduce.h
include/tbb/parallel_scan.h
-include/tbb/null_rw_mutex.h
-include/tbb/spin_rw_mutex.h
-include/tbb/blocked_range3d.h
+include/tbb/parallel_sort.h
+include/tbb/parallel_while.h
+include/tbb/partitioner.h
include/tbb/pipeline.h
-include/tbb/compat/ppl.h
-include/tbb/compat/thread
-include/tbb/compat/tuple
-include/tbb/compat/condition_variable
+include/tbb/queuing_mutex.h
+include/tbb/queuing_rw_mutex.h
+include/tbb/reader_writer_lock.h
+include/tbb/recursive_mutex.h
+include/tbb/runtime_loader.h
+include/tbb/scalable_allocator.h
include/tbb/spin_mutex.h
-include/tbb/tbbmalloc_proxy.h
-include/tbb/concurrent_unordered_map.h
-include/tbb/cache_aligned_allocator.h
+include/tbb/spin_rw_mutex.h
+include/tbb/task.h
+include/tbb/task_arena.h
+include/tbb/task_group.h
+include/tbb/task_scheduler_init.h
+include/tbb/task_scheduler_observer.h
include/tbb/tbb.h
+include/tbb/tbb_allocator.h
+include/tbb/tbb_config.h
+include/tbb/tbb_exception.h
include/tbb/tbb_machine.h
-include/tbb/scalable_allocator.h
-include/tbb/tbb_thread.h
include/tbb/tbb_profiling.h
-include/tbb/enumerable_thread_specific.h
-include/tbb/aligned_space.h
-include/tbb/concurrent_hash_map.h
-include/tbb/null_mutex.h
-include/tbb/reader_writer_lock.h
-include/tbb/task_group.h
-@dirrm include/tbb/internal
-@dirrm include/tbb/machine
-@dirrm include/tbb/compat
-@dirrm include/tbb
+include/tbb/tbb_stddef.h
+include/tbb/tbb_thread.h
+include/tbb/tbbmalloc_proxy.h
+include/tbb/tick_count.h
lib/libtbb.so
lib/libtbb.so.4
lib/libtbbmalloc.so
lib/libtbbmalloc.so.4
+@dirrm include/tbb/internal
+@dirrm include/tbb/machine
+@dirrm include/tbb/compat
+@dirrm include/tbb