aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2003-01-15 13:43:18 +0800
committerperky <perky@FreeBSD.org>2003-01-15 13:43:18 +0800
commit6d09e4ed7874a96bfd419550313773e7f7ece7b8 (patch)
tree2897d15e2597d954e354b6a258dc7f65286d0982 /devel
parent68b5ea0bc41eca90a10d9c6a7277c2f1e65930aa (diff)
downloadfreebsd-ports-gnome-6d09e4ed7874a96bfd419550313773e7f7ece7b8.tar.gz
freebsd-ports-gnome-6d09e4ed7874a96bfd419550313773e7f7ece7b8.tar.zst
freebsd-ports-gnome-6d09e4ed7874a96bfd419550313773e7f7ece7b8.zip
Disable python and tcl support by default. They are really rarely used and
generate too heavy dependencies. WITH_PYTHON and WITH_TCL is still available. Requested by: many
Diffstat (limited to 'devel')
-rw-r--r--devel/newt/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/newt/Makefile b/devel/newt/Makefile
index 001e3bda0cb9..60b69e71c3f8 100644
--- a/devel/newt/Makefile
+++ b/devel/newt/Makefile
@@ -28,7 +28,7 @@ MAKE_ENV+= CC=${CC} PCFLAGS="${CFLAGS}" TCLVERSION="${TCL_VERSION}"
PLIST_SUB+= SOVERSION=${SOVERSION} \
EXAMPLESDIR="${EXAMPLESDIR:S,${PREFIX}/,,}"
-.if !defined(WITHOUT_PYTHON)
+.if defined(WITH_PYTHON)
PYTHONSUFFIX= -${PYTHON_PKGNAMEPREFIX:S/-//}
BUILD_DEPENDS+= ${PYDISTUTILS}
USE_PYTHON= yes
@@ -38,7 +38,7 @@ PLIST_SUB+= PYTHONOPT=""
PLIST_SUB+= PYTHONOPT="@comment "
.endif
-.if !defined(WITHOUT_TCL)
+.if defined(WITH_TCL)
TCLSUFFIX= -${TCL_NODOT}
LIB_DEPENDS+= ${TCL_NODOT}:${PORTSDIR}/lang/${TCL_NODOT}
MAKE_ENV+= WITH_TCL=yes
@@ -62,7 +62,7 @@ post-patch:
${REINPLACE_CMD} -e 's,^\(SONAME=\).*,\1${SOVERSION},g' \
${WRKSRC}/configure
-.if !defined(WITHOUT_PYTHON)
+.if defined(WITH_PYTHON)
post-build:
@cd ${WRKSRC} && ${MAKE_ENV} ${PYTHON_CMD} ${FILESDIR}/setup.py build