aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2007-01-29 17:09:16 +0800
committertobez <tobez@FreeBSD.org>2007-01-29 17:09:16 +0800
commit6e2f3607359169a3f6b7b0fb239b48c611704f61 (patch)
treeef72896e30023fc3983510b31d35f1cd897c28be /devel
parent07cb4d4e6c325a0c5f8f575d3d58edc2ac230042 (diff)
downloadfreebsd-ports-gnome-6e2f3607359169a3f6b7b0fb239b48c611704f61.tar.gz
freebsd-ports-gnome-6e2f3607359169a3f6b7b0fb239b48c611704f61.tar.zst
freebsd-ports-gnome-6e2f3607359169a3f6b7b0fb239b48c611704f61.zip
Add missing dependency. Require perl from ports. Bump portrevision.
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Module-Load-Conditional/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/devel/p5-Module-Load-Conditional/Makefile b/devel/p5-Module-Load-Conditional/Makefile
index 06932da231ab..07d32bfd9394 100644
--- a/devel/p5-Module-Load-Conditional/Makefile
+++ b/devel/p5-Module-Load-Conditional/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Module-Load-Conditional
PORTVERSION= 0.16
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Module
@@ -18,7 +19,8 @@ COMMENT= Looking up Perl modules information/loading at runtime
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
${SITE_PERL}/Locale/Maketext/Simple.pm:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
${SITE_PERL}/Module/Load.pm:${PORTSDIR}/devel/p5-Module-Load \
- ${SITE_PERL}/Params/Check.pm:${PORTSDIR}/devel/p5-Params-Check
+ ${SITE_PERL}/Params/Check.pm:${PORTSDIR}/devel/p5-Params-Check \
+ p5-version>=0.69:${PORTSDIR}/devel/p5-version
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -34,4 +36,10 @@ post-install:
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>