aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbland <bland@FreeBSD.org>2006-04-04 20:31:16 +0800
committerbland <bland@FreeBSD.org>2006-04-04 20:31:16 +0800
commit729769e0e5f223fdf5ac0f0d3d3825226b29c1c3 (patch)
tree681b2ba67bc8d89dd6fd5bb979a20df937095415 /devel
parentbbe0dd4bbd57d07b227100f57c7a76602c28614f (diff)
downloadfreebsd-ports-gnome-729769e0e5f223fdf5ac0f0d3d3825226b29c1c3.tar.gz
freebsd-ports-gnome-729769e0e5f223fdf5ac0f0d3d3825226b29c1c3.tar.zst
freebsd-ports-gnome-729769e0e5f223fdf5ac0f0d3d3825226b29c1c3.zip
- Drop bash build dependency. [1]
- Remove obsolete USE_REINPLACE. Submitted by: Jean-Baptiste Quenot <jbq@caraldi.com> [1]
Diffstat (limited to 'devel')
-rw-r--r--devel/dbus/Makefile4
-rw-r--r--devel/dbus/files/patch-tools_run-with-tmp-session-bus.sh15
2 files changed, 11 insertions, 8 deletions
diff --git a/devel/dbus/Makefile b/devel/dbus/Makefile
index a79d85e3a469..ce0521c9bc59 100644
--- a/devel/dbus/Makefile
+++ b/devel/dbus/Makefile
@@ -14,14 +14,12 @@ MASTER_SITES= http://dbus.freedesktop.org/releases/
MAINTAINER?= gnome@FreeBSD.org
COMMENT?= A message bus system for inter-application communication
-BUILD_DEPENDS?= bash:${PORTSDIR}/shells/bash
LIB_DEPENDS?= expat.6:${PORTSDIR}/textproc/expat2
USE_GNOME?= gnomehack glib20 libxml2
USE_GMAKE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-USE_REINPLACE= yes
CONFIGURE_ARGS?=--disable-gtk \
--disable-python \
--disable-gcj \
@@ -60,8 +58,6 @@ PLIST_SUB+= QT="@comment "
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
- ${WRKSRC}/tools/run-with-tmp-session-bus.sh
@${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|' \
${WRKSRC}/bus/session.conf.in
diff --git a/devel/dbus/files/patch-tools_run-with-tmp-session-bus.sh b/devel/dbus/files/patch-tools_run-with-tmp-session-bus.sh
index ab5d6bc38a44..064503a1aaa0 100644
--- a/devel/dbus/files/patch-tools_run-with-tmp-session-bus.sh
+++ b/devel/dbus/files/patch-tools_run-with-tmp-session-bus.sh
@@ -1,8 +1,15 @@
---- tools/run-with-tmp-session-bus.sh.orig Sat Apr 2 14:52:51 2005
-+++ tools/run-with-tmp-session-bus.sh Sat Apr 2 14:53:05 2005
-@@ -1,4 +1,4 @@
+--- tools/run-with-tmp-session-bus.sh.orig Fri Mar 18 02:48:29 2005
++++ tools/run-with-tmp-session-bus.sh Tue Apr 4 20:40:12 2006
+@@ -1,10 +1,10 @@
-#! /bin/bash
-+#! %%LOCALBASE%%/bin/bash
++#! /bin/sh
SCRIPTNAME=$0
WRAPPED_SCRIPT=$1
+ shift
+
+-function die()
++die()
+ {
+ if ! test -z "$DBUS_SESSION_BUS_PID" ; then
+ echo "killing message bus "$DBUS_SESSION_BUS_PID >&2