aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-07-23 14:46:18 +0800
committerclsung <clsung@FreeBSD.org>2006-07-23 14:46:18 +0800
commit7f23c62171be05a0a49b67fcabaccd4ba501e9dd (patch)
treefeec8f5cf784f48fa1cac354e86486bd041e3939 /devel
parent820fc773eca8012d51aabb876d682ff80ddf0274 (diff)
downloadfreebsd-ports-gnome-7f23c62171be05a0a49b67fcabaccd4ba501e9dd.tar.gz
freebsd-ports-gnome-7f23c62171be05a0a49b67fcabaccd4ba501e9dd.tar.zst
freebsd-ports-gnome-7f23c62171be05a0a49b67fcabaccd4ba501e9dd.zip
Add p5-Env-Path 0.16, advanced operations on path variables.
PR: ports/100653 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Env-Path/Makefile23
-rw-r--r--devel/p5-Env-Path/distinfo3
-rw-r--r--devel/p5-Env-Path/pkg-descr6
-rw-r--r--devel/p5-Env-Path/pkg-plist7
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6f5120e6b0c2..d56ed173094a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -986,6 +986,7 @@
SUBDIR += p5-Dialog
SUBDIR += p5-Dir-Project
SUBDIR += p5-Env-PS1
+ SUBDIR += p5-Env-Path
SUBDIR += p5-Errno
SUBDIR += p5-Event
SUBDIR += p5-Event-Lib
diff --git a/devel/p5-Env-Path/Makefile b/devel/p5-Env-Path/Makefile
new file mode 100644
index 000000000000..cde63bfb0b7b
--- /dev/null
+++ b/devel/p5-Env-Path/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: p5-Env-Path
+# Date created: 2006-07-21
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Env-Path
+PORTVERSION= 0.16
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Env
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Advanced operations on path variables
+
+PERL_CONFIGURE= yes
+
+MAN1= envpath.1
+MAN3= Env::Path.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Env-Path/distinfo b/devel/p5-Env-Path/distinfo
new file mode 100644
index 000000000000..1b8e8bd7da40
--- /dev/null
+++ b/devel/p5-Env-Path/distinfo
@@ -0,0 +1,3 @@
+MD5 (Env-Path-0.16.tar.gz) = 4442fd8617b5b5cf7f8cfe1591a6c039
+SHA256 (Env-Path-0.16.tar.gz) = a9c66e06bb66b2b123249691f2e03c94bd044283863918291a149298705d9869
+SIZE (Env-Path-0.16.tar.gz) = 10075
diff --git a/devel/p5-Env-Path/pkg-descr b/devel/p5-Env-Path/pkg-descr
new file mode 100644
index 000000000000..86922f814c97
--- /dev/null
+++ b/devel/p5-Env-Path/pkg-descr
@@ -0,0 +1,6 @@
+Env::Path presents an object-oriented interface to path variables,
+defined as that subclass of environment variables which name an
+ordered list of filesystem elements separated by a platform-standard
+separator (typically ':' on UNIX and ';' on Windows).
+
+WWW: http://search.cpan.org/dist/Env-Path/
diff --git a/devel/p5-Env-Path/pkg-plist b/devel/p5-Env-Path/pkg-plist
new file mode 100644
index 000000000000..c98f18f51f64
--- /dev/null
+++ b/devel/p5-Env-Path/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+bin/envpath
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Env/Path/.packlist
+%%SITE_PERL%%/Env/Path.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Env/Path
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Env
+@dirrmtry %%SITE_PERL%%/Env