aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-02-07 19:39:40 +0800
committergahr <gahr@FreeBSD.org>2013-02-07 19:39:40 +0800
commit857329609428cb80e6345a6c02d8479827b0a222 (patch)
tree980d8f44d4a15a701aa9d7471b406c967cf5faa7 /devel
parent37f6ff35a4cad3cac24fb917b1a601f2f53bf907 (diff)
downloadfreebsd-ports-gnome-857329609428cb80e6345a6c02d8479827b0a222.tar.gz
freebsd-ports-gnome-857329609428cb80e6345a6c02d8479827b0a222.tar.zst
freebsd-ports-gnome-857329609428cb80e6345a6c02d8479827b0a222.zip
- Fix build with clang
Diffstat (limited to 'devel')
-rw-r--r--devel/libowfat/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/devel/libowfat/Makefile b/devel/libowfat/Makefile
index 84028802d9c6..37abbfb51fd6 100644
--- a/devel/libowfat/Makefile
+++ b/devel/libowfat/Makefile
@@ -48,6 +48,10 @@ post-extract:
@${MV} ${WRKSRC}/*/${i:S/libowfat_//} ${WRKSRC}/man/${i}
.endfor
+post-patch:
+# Clang cries when void functions return a value
+ ${REINPLACE_CMD} -e '56s|return ||' ${WRKSRC}/CAS.h
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}