aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-07-16 16:28:17 +0800
committerclsung <clsung@FreeBSD.org>2006-07-16 16:28:17 +0800
commit86526ef728c3617eaf3d2f96f3db88014dc11f06 (patch)
tree2ba8b92cd3b8a10f7c6c011c1d53d4aaad3b7b21 /devel
parent8340c5a140953dc7932a8dc1ad1bafbc27a8f517 (diff)
downloadfreebsd-ports-gnome-86526ef728c3617eaf3d2f96f3db88014dc11f06.tar.gz
freebsd-ports-gnome-86526ef728c3617eaf3d2f96f3db88014dc11f06.tar.zst
freebsd-ports-gnome-86526ef728c3617eaf3d2f96f3db88014dc11f06.zip
- temporary remove dependency of p5-version,
it will cause cyclic dependencies. - 3 patches are made for that (copy from version 0.2801) - bump PORTREVISION
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Module-Build/Makefile2
-rw-r--r--devel/p5-Module-Build/files/patch-lib-Module-Build-Base.pm16
-rw-r--r--devel/p5-Module-Build/files/patch-lib-Module-Build-ModuleInfo.pm20
-rw-r--r--devel/p5-Module-Build/files/patch-lib-Module-Build-Version.pm9
4 files changed, 46 insertions, 1 deletions
diff --git a/devel/p5-Module-Build/Makefile b/devel/p5-Module-Build/Makefile
index 683695996189..e79ef6303fa9 100644
--- a/devel/p5-Module-Build/Makefile
+++ b/devel/p5-Module-Build/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Module-Build
PORTVERSION= 0.28.03
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Module/KWILLIAMS
@@ -17,7 +18,6 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Build and install Perl modules
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
- ${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version \
${SITE_PERL}/ExtUtils/CBuilder.pm:${PORTSDIR}/devel/p5-ExtUtils-CBuilder
BUILD_DEPENDS= ${RUN_DEPENDS}
BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
diff --git a/devel/p5-Module-Build/files/patch-lib-Module-Build-Base.pm b/devel/p5-Module-Build/files/patch-lib-Module-Build-Base.pm
new file mode 100644
index 000000000000..a89fdc5455ba
--- /dev/null
+++ b/devel/p5-Module-Build/files/patch-lib-Module-Build-Base.pm
@@ -0,0 +1,16 @@
+--- lib/Module/Build/Base.pm.orig Sun Jul 16 04:42:38 2006
++++ lib/Module/Build/Base.pm Sun Jul 16 16:20:49 2006
+@@ -1232,8 +1232,11 @@
+ sub compare_versions {
+ my $self = shift;
+ my ($v1, $op, $v2) = @_;
+- $v1 = Module::Build::Version->new($v1)
+- unless UNIVERSAL::isa($v1,'Module::Build::Version');
++ #$v1 = Module::Build::Version->new($v1)
++ # unless UNIVERSAL::isa($v1,'Module::Build::Version');
++ # for alpha versions - this doesn't cover all cases, but should work for most:
++ $v1 =~ s/_(\d+)\z/$1/;
++ $v2 =~ s/_(\d+)\z/$1/;
+
+ my $eval_str = "\$v1 $op \$v2";
+ my $result = eval $eval_str;
diff --git a/devel/p5-Module-Build/files/patch-lib-Module-Build-ModuleInfo.pm b/devel/p5-Module-Build/files/patch-lib-Module-Build-ModuleInfo.pm
new file mode 100644
index 000000000000..dd550a064b4f
--- /dev/null
+++ b/devel/p5-Module-Build/files/patch-lib-Module-Build-ModuleInfo.pm
@@ -0,0 +1,20 @@
+--- lib/Module/Build/ModuleInfo.pm.orig Sun Jul 16 04:42:38 2006
++++ lib/Module/Build/ModuleInfo.pm Sun Jul 16 16:16:22 2006
+@@ -286,12 +286,16 @@
+ };
+
+ local $^W;
++ my $old_version = \&UNIVERSAL::VERSION;
++ eval {require version};
+ # Try and get the $VERSION
+ my $result = eval $eval;
++ * UNIVERSAL::VERSION = $old_version;
+ warn "Error evaling version line '$eval' in $self->{filename}: $@\n" if $@;
+
+ # Bless it into our own version class
+- $result = Module::Build::Version->new($result);
++ #$result = Module::Build::Version->new($result);
++ $result = $result->numify if UNIVERSAL::isa($result, 'version');
+
+ return $result;
+ }
diff --git a/devel/p5-Module-Build/files/patch-lib-Module-Build-Version.pm b/devel/p5-Module-Build/files/patch-lib-Module-Build-Version.pm
new file mode 100644
index 000000000000..a83fdbd29591
--- /dev/null
+++ b/devel/p5-Module-Build/files/patch-lib-Module-Build-Version.pm
@@ -0,0 +1,9 @@
+--- lib/Module/Build/Version.pm.orig Sun Jul 16 04:42:38 2006
++++ lib/Module/Build/Version.pm Sun Jul 16 16:07:54 2006
+@@ -1,5 +1,5 @@
+ package Module::Build::Version;
+-use base qw/version/;
++#use base qw/version/;
+
+ use overload (
+ '""' => \&stringify,