aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-02-06 02:39:23 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-02-06 02:39:23 +0800
commit91433be99d0f90d6903e1cbb989222e43c1c8785 (patch)
tree75e70abe993cae47ff6eea10855d0b7c45a0749e /devel
parent18fd21e0f802f8f72881302dca783337d9f3a611 (diff)
downloadfreebsd-ports-gnome-91433be99d0f90d6903e1cbb989222e43c1c8785.tar.gz
freebsd-ports-gnome-91433be99d0f90d6903e1cbb989222e43c1c8785.tar.zst
freebsd-ports-gnome-91433be99d0f90d6903e1cbb989222e43c1c8785.zip
- Convert to new options framework
- Cleanup Makefile header
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-DateTime-Set/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/devel/p5-DateTime-Set/Makefile b/devel/p5-DateTime-Set/Makefile
index 52252923517a..029c8a6b5ae0 100644
--- a/devel/p5-DateTime-Set/Makefile
+++ b/devel/p5-DateTime-Set/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-DateTime-Set
-# Date created: 26 june 2003
-# Whom: Mathieu Arnold <m@absolight.net>
-#
+# Created by: Mathieu Arnold <m@absolight.net>
# $FreeBSD$
-#
PORTNAME= DateTime-Set
PORTVERSION= 0.31
@@ -16,8 +12,9 @@ COMMENT= Datetime sets and set math
BUILD_DEPENDS= p5-DateTime>=0.12:${PORTSDIR}/devel/p5-DateTime \
p5-Set-Infinite>=0.59:${PORTSDIR}/devel/p5-Set-Infinite
-RUN_DEPENDS= p5-DateTime>=0.12:${PORTSDIR}/devel/p5-DateTime \
- p5-Set-Infinite>=0.59:${PORTSDIR}/devel/p5-Set-Infinite
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+OPTIONS_DEFINE= DOCS
PERL_CONFIGURE= yes
@@ -25,14 +22,15 @@ MAN3= DateTime::Set.3 \
DateTime::Span.3 \
DateTime::SpanSet.3 \
Set::Infinite::_recurrence.3
-
-.if !defined(NOPORTDOCS)
PORTDOCS= Changes README TODO
+.include <bsd.port.options.mk>
+
post-install:
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
- ${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
.include <bsd.port.mk>