aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorobraun <obraun@FreeBSD.org>2002-08-22 04:49:30 +0800
committerobraun <obraun@FreeBSD.org>2002-08-22 04:49:30 +0800
commita41fe06706513b9bbf49c1cfae620b048285fdf8 (patch)
treebf295b45750f0b45c09349431c432e21ee288114 /devel
parentac3d5e90e01afa2b703cd043bbc6d446622e495c (diff)
downloadfreebsd-ports-gnome-a41fe06706513b9bbf49c1cfae620b048285fdf8.tar.gz
freebsd-ports-gnome-a41fe06706513b9bbf49c1cfae620b048285fdf8.tar.zst
freebsd-ports-gnome-a41fe06706513b9bbf49c1cfae620b048285fdf8.zip
Add drift 2.0.r3, a type sensitive preprocessor for Haskell.
PR: ports/41616 Approved by: dwcjr (mentor)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/drift/Makefile37
-rw-r--r--devel/drift/distinfo1
-rw-r--r--devel/drift/pkg-comment1
-rw-r--r--devel/drift/pkg-descr16
-rw-r--r--devel/drift/pkg-plist4
-rw-r--r--devel/hs-drift/Makefile37
-rw-r--r--devel/hs-drift/distinfo1
-rw-r--r--devel/hs-drift/pkg-comment1
-rw-r--r--devel/hs-drift/pkg-descr16
-rw-r--r--devel/hs-drift/pkg-plist4
11 files changed, 119 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6f09d038eca8..2e986cf27a1e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -140,6 +140,7 @@
SUBDIR += domc
SUBDIR += dotconf
SUBDIR += doxygen
+ SUBDIR += drift
SUBDIR += e4graph
SUBDIR += ebnf2yacc
SUBDIR += ecb
diff --git a/devel/drift/Makefile b/devel/drift/Makefile
new file mode 100644
index 000000000000..51fbccac83f6
--- /dev/null
+++ b/devel/drift/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: drift
+# Date created: 13 August 2002
+# Whom: Oliver Braun <obraun@informatik.unibw-muenchen.de>
+#
+# $FreeBSD$
+
+PORTNAME= drift
+PORTVERSION= 2.0.r3
+CATEGORIES= devel
+MASTER_SITES= http://repetae.net/john/computer/haskell/DrIFT/
+DISTNAME= DrIFT-${PORTVERSION:S/.r/rc/}
+
+MAINTAINER= obraun@informatik.unibw-muenchen.de
+
+.if !defined(WITH_GHC)
+BUILD_DEPENDS= nhc98:${PORTSDIR}/lang/nhc98
+.else
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+.endif
+
+HAS_CONFIGURE= yes
+
+.if !defined(WITH_GHC)
+CONFIGURE_ARGS+= --with-hc=nhc98
+.else
+CONFIGURE_ARGS+= --with-hc=ghc
+.endif
+
+.if !defined(WITH_GHC)
+pre-everything:
+ @${ECHO} ""
+ @${ECHO} " DrIFT will be build with nhc98."
+ @${ECHO} " Define WITH_GHC to build with ghc."
+ @${ECHO} ""
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/drift/distinfo b/devel/drift/distinfo
new file mode 100644
index 000000000000..fd306d872ade
--- /dev/null
+++ b/devel/drift/distinfo
@@ -0,0 +1 @@
+MD5 (DrIFT-2.0rc3.tar.gz) = 7c30a950145181c6a79d813ce6f5eaad
diff --git a/devel/drift/pkg-comment b/devel/drift/pkg-comment
new file mode 100644
index 000000000000..d21ba3549932
--- /dev/null
+++ b/devel/drift/pkg-comment
@@ -0,0 +1 @@
+A type sensitive preprocessor for Haskell
diff --git a/devel/drift/pkg-descr b/devel/drift/pkg-descr
new file mode 100644
index 000000000000..29341782effb
--- /dev/null
+++ b/devel/drift/pkg-descr
@@ -0,0 +1,16 @@
+DrIFT is a type sensitive preprocessor for Haskell. It extracts type
+declarations and directives from modules. The directives cause rules to be
+fired on the parsed type declarations, generating new code which is then
+appended to the bottom of the input file. The rules are expressed as Haskell
+code, and it is intended that the user can add new rules as required.
+
+DrIFT automates instance derivation for classes that aren't supported by the
+standard compilers. In addition, instances can be produced in seperate modules
+to that containing the type declaration. This allows instances to be derived
+for a type after the original module has been compiled. As a bonus, simple
+utility functions can also be produced from a type.
+
+WWW: http://repetae.net/john/computer/haskell/DrIFT/
+
+-- Oliver Braun
+obraun@informatik.unibw-muenchen.de
diff --git a/devel/drift/pkg-plist b/devel/drift/pkg-plist
new file mode 100644
index 000000000000..cbb6bd37cd48
--- /dev/null
+++ b/devel/drift/pkg-plist
@@ -0,0 +1,4 @@
+bin/DrIFT
+@unexec install-info --delete %D/info/drift.info %D/info/dir
+info/drift.info
+@exec install-info %D/info/drift.info %D/info/dir
diff --git a/devel/hs-drift/Makefile b/devel/hs-drift/Makefile
new file mode 100644
index 000000000000..51fbccac83f6
--- /dev/null
+++ b/devel/hs-drift/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: drift
+# Date created: 13 August 2002
+# Whom: Oliver Braun <obraun@informatik.unibw-muenchen.de>
+#
+# $FreeBSD$
+
+PORTNAME= drift
+PORTVERSION= 2.0.r3
+CATEGORIES= devel
+MASTER_SITES= http://repetae.net/john/computer/haskell/DrIFT/
+DISTNAME= DrIFT-${PORTVERSION:S/.r/rc/}
+
+MAINTAINER= obraun@informatik.unibw-muenchen.de
+
+.if !defined(WITH_GHC)
+BUILD_DEPENDS= nhc98:${PORTSDIR}/lang/nhc98
+.else
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+.endif
+
+HAS_CONFIGURE= yes
+
+.if !defined(WITH_GHC)
+CONFIGURE_ARGS+= --with-hc=nhc98
+.else
+CONFIGURE_ARGS+= --with-hc=ghc
+.endif
+
+.if !defined(WITH_GHC)
+pre-everything:
+ @${ECHO} ""
+ @${ECHO} " DrIFT will be build with nhc98."
+ @${ECHO} " Define WITH_GHC to build with ghc."
+ @${ECHO} ""
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/hs-drift/distinfo b/devel/hs-drift/distinfo
new file mode 100644
index 000000000000..fd306d872ade
--- /dev/null
+++ b/devel/hs-drift/distinfo
@@ -0,0 +1 @@
+MD5 (DrIFT-2.0rc3.tar.gz) = 7c30a950145181c6a79d813ce6f5eaad
diff --git a/devel/hs-drift/pkg-comment b/devel/hs-drift/pkg-comment
new file mode 100644
index 000000000000..d21ba3549932
--- /dev/null
+++ b/devel/hs-drift/pkg-comment
@@ -0,0 +1 @@
+A type sensitive preprocessor for Haskell
diff --git a/devel/hs-drift/pkg-descr b/devel/hs-drift/pkg-descr
new file mode 100644
index 000000000000..29341782effb
--- /dev/null
+++ b/devel/hs-drift/pkg-descr
@@ -0,0 +1,16 @@
+DrIFT is a type sensitive preprocessor for Haskell. It extracts type
+declarations and directives from modules. The directives cause rules to be
+fired on the parsed type declarations, generating new code which is then
+appended to the bottom of the input file. The rules are expressed as Haskell
+code, and it is intended that the user can add new rules as required.
+
+DrIFT automates instance derivation for classes that aren't supported by the
+standard compilers. In addition, instances can be produced in seperate modules
+to that containing the type declaration. This allows instances to be derived
+for a type after the original module has been compiled. As a bonus, simple
+utility functions can also be produced from a type.
+
+WWW: http://repetae.net/john/computer/haskell/DrIFT/
+
+-- Oliver Braun
+obraun@informatik.unibw-muenchen.de
diff --git a/devel/hs-drift/pkg-plist b/devel/hs-drift/pkg-plist
new file mode 100644
index 000000000000..cbb6bd37cd48
--- /dev/null
+++ b/devel/hs-drift/pkg-plist
@@ -0,0 +1,4 @@
+bin/DrIFT
+@unexec install-info --delete %D/info/drift.info %D/info/dir
+info/drift.info
+@exec install-info %D/info/drift.info %D/info/dir