aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2006-04-16 02:32:11 +0800
committerarved <arved@FreeBSD.org>2006-04-16 02:32:11 +0800
commita502f45f22ec1e42042424bff88f6ec2eec1d7b8 (patch)
treeef45296674268b3d096e2a73a39d1dd002c3ccbb /devel
parent2e5831c5ded07d27982a53a77b8ff2508a95c677 (diff)
downloadfreebsd-ports-gnome-a502f45f22ec1e42042424bff88f6ec2eec1d7b8.tar.gz
freebsd-ports-gnome-a502f45f22ec1e42042424bff88f6ec2eec1d7b8.tar.zst
freebsd-ports-gnome-a502f45f22ec1e42042424bff88f6ec2eec1d7b8.zip
Update to 0.0.5
PR: 94858 Submitted by: maintainer
Diffstat (limited to 'devel')
-rw-r--r--devel/dotconf++/Makefile4
-rw-r--r--devel/dotconf++/distinfo6
-rw-r--r--devel/dotconf++/files/patch-README14
-rw-r--r--devel/dotconf++/files/patch-doc-dotconfpp.html15
-rw-r--r--devel/dotconf++/files/patch-src-Makefile.in4
-rw-r--r--devel/dotconf++/files/patch-src-dotconfpp.cc11
-rw-r--r--devel/dotconf++/files/patch-src-dotconfpp.h20
-rw-r--r--devel/dotconf++/files/patch-src-example1.cc11
-rw-r--r--devel/dotconf++/files/patch-src-example2.cc11
9 files changed, 5 insertions, 91 deletions
diff --git a/devel/dotconf++/Makefile b/devel/dotconf++/Makefile
index e6c62ab61ca5..712f59b26a52 100644
--- a/devel/dotconf++/Makefile
+++ b/devel/dotconf++/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= dotconfpp
-PORTVERSION= 0.0.4a
-PORTREVISION= 2
+PORTVERSION= 0.0.5
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://voodoo.com.ua/dotconfpp/
@@ -18,7 +17,6 @@ MAINTAINER= mark_sf@kikg.ifmo.ru
COMMENT= Configuration file parser written in C++
USE_AUTOTOOLS= libtool:15
-USE_REINPLACE= yes
INSTALLS_SHLIB= yes
diff --git a/devel/dotconf++/distinfo b/devel/dotconf++/distinfo
index d5126d22020b..f2ae9139f3df 100644
--- a/devel/dotconf++/distinfo
+++ b/devel/dotconf++/distinfo
@@ -1,3 +1,3 @@
-MD5 (dotconfpp-0.0.4a.tar.gz) = 0c43f864f7115916e39c1e14599d053b
-SHA256 (dotconfpp-0.0.4a.tar.gz) = c0a2ab7955ce87b4deb2942236c274a9fb7913662baefa772c6a0bebee4baac9
-SIZE (dotconfpp-0.0.4a.tar.gz) = 307253
+MD5 (dotconfpp-0.0.5.tar.gz) = c09f645ddec2f1fb279aea463974e256
+SHA256 (dotconfpp-0.0.5.tar.gz) = 2637b3b13f21d49b7cca4367bb5a2dc284b69d3a4b65add1c40dfaac75243668
+SIZE (dotconfpp-0.0.5.tar.gz) = 339240
diff --git a/devel/dotconf++/files/patch-README b/devel/dotconf++/files/patch-README
deleted file mode 100644
index 21ee2fb8ddae..000000000000
--- a/devel/dotconf++/files/patch-README
+++ /dev/null
@@ -1,14 +0,0 @@
---- README.orig Fri May 16 12:25:35 2003
-+++ README Thu Jul 7 17:01:27 2005
-@@ -80,9 +80,9 @@
- 1. Opening configuration file
- * Create configuration document object:
-
-- DOTCONFDocument * conf = new DOTCONFDocument(DOTCONFDocument::CASEINSENSETIVE);
-+ DOTCONFDocument * conf = new DOTCONFDocument(DOTCONFDocument::CASEINSENSITIVE);
- or
-- DOTCONFDocument * conf = new DOTCONFDocument(DOTCONFDocument::CASESENSETIVE);
-+ DOTCONFDocument * conf = new DOTCONFDocument(DOTCONFDocument::CASESENSITIVE);
- * [OPTIONAL] Set required options
-
- const char * requiredOptions[] = {"Users", NULL};
diff --git a/devel/dotconf++/files/patch-doc-dotconfpp.html b/devel/dotconf++/files/patch-doc-dotconfpp.html
deleted file mode 100644
index 31397771c61b..000000000000
--- a/devel/dotconf++/files/patch-doc-dotconfpp.html
+++ /dev/null
@@ -1,15 +0,0 @@
---- doc/dotconfpp.html.orig Fri May 16 12:26:05 2003
-+++ doc/dotconfpp.html Thu Jul 7 17:06:38 2005
-@@ -133,10 +133,10 @@
- <li>Create configuration document object:<br>
- <br style="color: rgb(0, 0, 255);">
- <span style="color: rgb(0, 0, 255);">DOTCONFDocument * conf =
--new DOTCONFDocument(DOTCONFDocument::CASEINSENSETIVE);<br>
-+new DOTCONFDocument(DOTCONFDocument::CASEINSENSITIVE);<br>
- <span style="color: rgb(0, 0, 0);">or<br>
- </span></span><span style="color: rgb(0, 0, 255);">DOTCONFDocument
--* conf = new DOTCONFDocument(DOTCONFDocument::CASESENSETIVE);<br>
-+* conf = new DOTCONFDocument(DOTCONFDocument::CASESENSITIVE);<br>
- <br>
- </span></li>
- <li><span style="color: rgb(0, 0, 255);"><span
diff --git a/devel/dotconf++/files/patch-src-Makefile.in b/devel/dotconf++/files/patch-src-Makefile.in
index e85c55507119..b0983854bdd5 100644
--- a/devel/dotconf++/files/patch-src-Makefile.in
+++ b/devel/dotconf++/files/patch-src-Makefile.in
@@ -12,9 +12,7 @@
@@ -132,7 +132,7 @@
target_alias = @target_alias@
EXTRA_DIST = dotconfpp.h mempool.h mempool.cc
-
--LIBdir = /usr/local/lib
+-LIBdir = ${prefix}/lib
+LIBdir = @prefix@/lib
SUBDIRS = . example1 example2
-
INCLUDES = -I.
diff --git a/devel/dotconf++/files/patch-src-dotconfpp.cc b/devel/dotconf++/files/patch-src-dotconfpp.cc
deleted file mode 100644
index 663040868b68..000000000000
--- a/devel/dotconf++/files/patch-src-dotconfpp.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/dotconfpp.cc.orig Fri Jun 25 14:03:20 2004
-+++ src/dotconfpp.cc Thu Jul 7 17:03:58 2005
-@@ -53,7 +53,7 @@
- mempool(NULL),
- curParent(NULL), curPrev(NULL), curLine(0), file(NULL), fileName(NULL)
- {
-- if(caseSensitivity == CASESENSETIVE){
-+ if(caseSensitivity == CASESENSITIVE){
- cmp_func = strcmp;
- } else {
- cmp_func = strcasecmp;
diff --git a/devel/dotconf++/files/patch-src-dotconfpp.h b/devel/dotconf++/files/patch-src-dotconfpp.h
deleted file mode 100644
index 6d25d9bb0422..000000000000
--- a/devel/dotconf++/files/patch-src-dotconfpp.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/dotconfpp.h.orig Wed May 14 19:10:26 2003
-+++ src/dotconfpp.h Thu Jul 7 17:02:43 2005
-@@ -75,7 +75,7 @@
- class DOTCONFDocument
- {
- public:
-- enum CaseSensitive { CASESENSETIVE, CASEINSENSETIVE };
-+ enum CaseSensitive { CASESENSITIVE, CASEINSENSITIVE };
- protected:
- AsyncDNSMemPool * mempool;
- private:
-@@ -103,7 +103,7 @@
- virtual void error(int lineNum, const char * fileName, const char * fmt, ...);
-
- public:
-- DOTCONFDocument(CaseSensitive caseSensitivity = CASESENSETIVE);
-+ DOTCONFDocument(CaseSensitive caseSensitivity = CASESENSITIVE);
- virtual ~DOTCONFDocument();
-
- int setContent(const char * _fileName);
diff --git a/devel/dotconf++/files/patch-src-example1.cc b/devel/dotconf++/files/patch-src-example1.cc
deleted file mode 100644
index 5428cdd9d9fc..000000000000
--- a/devel/dotconf++/files/patch-src-example1.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/example1/example1.cc.orig Sat Apr 10 15:22:00 2004
-+++ src/example1/example1.cc Wed Jul 13 20:20:47 2005
-@@ -54,7 +54,7 @@
-
- int main()
- {
-- DOTCONFDocument *conf = new DOTCONFDocument(DOTCONFDocument::CASEINSENSETIVE);
-+ DOTCONFDocument *conf = new DOTCONFDocument(DOTCONFDocument::CASEINSENSITIVE);
- const DOTCONFDocumentNode * node = NULL;
- const char * v = NULL;
- char * fqdn = NULL;
diff --git a/devel/dotconf++/files/patch-src-example2.cc b/devel/dotconf++/files/patch-src-example2.cc
deleted file mode 100644
index 5323d68ba424..000000000000
--- a/devel/dotconf++/files/patch-src-example2.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/example2/example2.cc.orig Wed May 14 17:10:26 2003
-+++ src/example2/example2.cc Wed Jul 13 20:21:29 2005
-@@ -51,7 +51,7 @@
-
- int main(int argc, char * argv[])
- {
-- DOTCONFDocument conf(DOTCONFDocument::CASEINSENSETIVE);
-+ DOTCONFDocument conf(DOTCONFDocument::CASEINSENSITIVE);
-
- conf.setRequiredOptionNames(requiredOptions);
-