aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorculot <culot@FreeBSD.org>2011-04-03 20:54:17 +0800
committerculot <culot@FreeBSD.org>2011-04-03 20:54:17 +0800
commitb86fc4af6f75202d2580f21b873ad995dbd12092 (patch)
treeaa75895b0b2d515679b1c7a8df13fa14c9f6f04e /devel
parentfae589022cb14006602b8c95122bcec111793b16 (diff)
downloadfreebsd-ports-gnome-b86fc4af6f75202d2580f21b873ad995dbd12092.tar.gz
freebsd-ports-gnome-b86fc4af6f75202d2580f21b873ad995dbd12092.tar.zst
freebsd-ports-gnome-b86fc4af6f75202d2580f21b873ad995dbd12092.zip
MooseX::ChainedAccessors is a Moose Trait which allows for method chaining on
accessors by returning $self on write/set operations. WWW: http://search.cpan.org/dist/MooseX-ChainedAccessors/ This new port is needed to update www/p5-HTML-FormFu.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-MooseX-ChainedAccessors/Makefile29
-rw-r--r--devel/p5-MooseX-ChainedAccessors/distinfo2
-rw-r--r--devel/p5-MooseX-ChainedAccessors/pkg-descr4
-rw-r--r--devel/p5-MooseX-ChainedAccessors/pkg-plist13
5 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5da214ca2e79..831abf5f4c77 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1970,6 +1970,7 @@
SUBDIR += p5-MooseX-Async
SUBDIR += p5-MooseX-Attribute-ENV
SUBDIR += p5-MooseX-AttributeHelpers
+ SUBDIR += p5-MooseX-ChainedAccessors
SUBDIR += p5-MooseX-ClassAttribute
SUBDIR += p5-MooseX-Clone
SUBDIR += p5-MooseX-CompileTime-Traits
diff --git a/devel/p5-MooseX-ChainedAccessors/Makefile b/devel/p5-MooseX-ChainedAccessors/Makefile
new file mode 100644
index 000000000000..21c9565e82b8
--- /dev/null
+++ b/devel/p5-MooseX-ChainedAccessors/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: MooseX-ChainedAccessors
+# Date created: 2011-04-03
+# Whom: Frederic Culot <culot@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MooseX-ChainedAccessors
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:PERLER
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Accessor class for chained accessors with Moose
+
+RUN_DEPENDS= p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-Try-Tiny>=0:${PORTSDIR}/lang/p5-Try-Tiny
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Moose::Meta::Attribute::Custom::Trait::Chained.3 \
+ MooseX::ChainedAccessors.3 \
+ MooseX::ChainedAccessors::Accessor.3 \
+ MooseX::Traits::Attribute::Chained.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-MooseX-ChainedAccessors/distinfo b/devel/p5-MooseX-ChainedAccessors/distinfo
new file mode 100644
index 000000000000..b3da2077649f
--- /dev/null
+++ b/devel/p5-MooseX-ChainedAccessors/distinfo
@@ -0,0 +1,2 @@
+SHA256 (MooseX-ChainedAccessors-0.02.tar.gz) = 5c2acbe96020fd538cc278259a71e4840adf1e7f78899dbdc678c30563e07efe
+SIZE (MooseX-ChainedAccessors-0.02.tar.gz) = 13162
diff --git a/devel/p5-MooseX-ChainedAccessors/pkg-descr b/devel/p5-MooseX-ChainedAccessors/pkg-descr
new file mode 100644
index 000000000000..4f221713d666
--- /dev/null
+++ b/devel/p5-MooseX-ChainedAccessors/pkg-descr
@@ -0,0 +1,4 @@
+MooseX::ChainedAccessors is a Moose Trait which allows for method chaining on
+accessors by returning $self on write/set operations.
+
+WWW: http://search.cpan.org/dist/MooseX-ChainedAccessors/
diff --git a/devel/p5-MooseX-ChainedAccessors/pkg-plist b/devel/p5-MooseX-ChainedAccessors/pkg-plist
new file mode 100644
index 000000000000..3717ced083c8
--- /dev/null
+++ b/devel/p5-MooseX-ChainedAccessors/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/Moose/Meta/Attribute/Custom/Trait/Chained.pm
+%%SITE_PERL%%/MooseX/ChainedAccessors.pm
+%%SITE_PERL%%/MooseX/ChainedAccessors/Accessor.pm
+%%SITE_PERL%%/MooseX/Traits/Attribute/Chained.pm
+@dirrm %%SITE_PERL%%/MooseX/ChainedAccessors
+@dirrmtry %%SITE_PERL%%/MooseX/Traits/Attribute
+@dirrmtry %%SITE_PERL%%/MooseX/Traits
+@dirrmtry %%SITE_PERL%%/MooseX
+@dirrmtry %%SITE_PERL%%/Moose/Meta/Attribute/Custom/Trait
+@dirrmtry %%SITE_PERL%%/Moose/Meta/Attribute/Custom
+@dirrmtry %%SITE_PERL%%/Moose/Meta/Attribute
+@dirrmtry %%SITE_PERL%%/Moose/Meta
+@dirrmtry %%SITE_PERL%%/Moose