aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2013-12-08 21:24:03 +0800
committermva <mva@FreeBSD.org>2013-12-08 21:24:03 +0800
commitbb9f66da1b3fbbe508e3ed3064b8dc794e05be17 (patch)
treedfbde7522626cd0a42dff5a52c988b020c96537f /devel
parentdf3ae8eb12eca4db7f3623fe82a656f5f955bb95 (diff)
downloadfreebsd-ports-gnome-bb9f66da1b3fbbe508e3ed3064b8dc794e05be17.tar.gz
freebsd-ports-gnome-bb9f66da1b3fbbe508e3ed3064b8dc794e05be17.tar.zst
freebsd-ports-gnome-bb9f66da1b3fbbe508e3ed3064b8dc794e05be17.zip
- Fix the usage of 'python' to get rid of the implicit lang/python
dependency Approved by: portmgr (blanket)
Diffstat (limited to 'devel')
-rw-r--r--devel/avro-cpp/Makefile5
-rw-r--r--devel/cvs2svn/Makefile7
-rw-r--r--devel/googletest/Makefile9
-rw-r--r--devel/libvirt-glib/Makefile1
-rw-r--r--devel/mongo-cxx-driver/Makefile2
-rw-r--r--devel/ninja/Makefile2
-rw-r--r--devel/py-gamin/Makefile2
-rw-r--r--devel/py-itools/Makefile3
8 files changed, 25 insertions, 6 deletions
diff --git a/devel/avro-cpp/Makefile b/devel/avro-cpp/Makefile
index ac68982c96f1..3771a37e8001 100644
--- a/devel/avro-cpp/Makefile
+++ b/devel/avro-cpp/Makefile
@@ -22,4 +22,9 @@ USE_PYTHON= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/lang/c++
NO_STAGE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|COMMAND python|COMMAND "${PYTHON_CMD}"|' \
+ ${WRKSRC}/CMakeLists.txt
+
.include <bsd.port.mk>
diff --git a/devel/cvs2svn/Makefile b/devel/cvs2svn/Makefile
index ce482d00df46..7f60406f326c 100644
--- a/devel/cvs2svn/Makefile
+++ b/devel/cvs2svn/Makefile
@@ -21,10 +21,15 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
# 2.4.0 -> svn r5392
PATCHREV= 5433
-USE_PYTHON= -2.7
+USES= shebangfix
+USE_PYTHON= 2
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
+python_OLD_CMD= /usr/bin/env python
+python_CMD= /usr/bin/env python2
+SHEBANG_FILES= cvs2svn cvs2git cvs2bzr
+
OPTIONS_MULTI= SCM
OPTIONS_MULTI_SCM= SUBVERSION GIT BAZAAR
OPTIONS_DEFAULT= SUBVERSION
diff --git a/devel/googletest/Makefile b/devel/googletest/Makefile
index 376c2ab9acd1..71813c415e61 100644
--- a/devel/googletest/Makefile
+++ b/devel/googletest/Makefile
@@ -10,11 +10,18 @@ DISTNAME= gtest-${PORTVERSION}
MAINTAINER= clsung@FreeBSD.org
COMMENT= A framework for writing C++ tests on a variety of platforms
+USES= shebangfix
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_PYTHON_BUILD= yes
+USE_PYTHON_BUILD= 2
+
+python_OLD_CMD= /usr/bin/env python
+python_CMD= /usr/bin/env python2
+SHEBANG_FILES= scripts/fuse_gtest_files.py scripts/gen_gtest_pred_impl.py \
+ scripts/pump.py
regression-test:
cd ${WRKSRC}; ${MAKE} check
+
.include <bsd.port.mk>
diff --git a/devel/libvirt-glib/Makefile b/devel/libvirt-glib/Makefile
index c9b2af229342..3ba749c76e19 100644
--- a/devel/libvirt-glib/Makefile
+++ b/devel/libvirt-glib/Makefile
@@ -16,6 +16,7 @@ USES= pathfix pkgconfig gmake
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
USE_GNOME= intltool introspection
+USE_PYTHON= -2.7
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -fstack-protector
CONFIGURE_ARGS+= --enable-introspection
diff --git a/devel/mongo-cxx-driver/Makefile b/devel/mongo-cxx-driver/Makefile
index 47bc29a5d986..cfa29973b37c 100644
--- a/devel/mongo-cxx-driver/Makefile
+++ b/devel/mongo-cxx-driver/Makefile
@@ -20,7 +20,7 @@ GH_ACCOUNT= waitman
GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= 41691d5
-USE_PYTHON= yes
+USE_PYTHON_BUILD= 2
NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/devel/ninja/Makefile b/devel/ninja/Makefile
index 06a6f9cca288..18c641e07ce8 100644
--- a/devel/ninja/Makefile
+++ b/devel/ninja/Makefile
@@ -26,7 +26,7 @@ PORTDOCS= COPYING HACKING.md README manual.asciidoc
do-build:
@(cd ${WRKSRC} && \
- CXX=${CXX} CFLAGS="${CXXFLAGS}" ./bootstrap.py --verbose)
+ CXX=${CXX} CFLAGS="${CXXFLAGS}" ${PYTHON_CMD} bootstrap.py --verbose)
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/ninja ${STAGEDIR}${PREFIX}/bin
diff --git a/devel/py-gamin/Makefile b/devel/py-gamin/Makefile
index 26b3b82b49a2..62d970bc0627 100644
--- a/devel/py-gamin/Makefile
+++ b/devel/py-gamin/Makefile
@@ -20,7 +20,7 @@ GAMIN_SLAVE= yes
USES= pathfix
USE_PYTHON= yes
-CONFIGURE_ARGS= --with-python=${LOCALBASE} \
+CONFIGURE_ARGS= --with-python=${PYTHON_CMD} \
--disable-gtk-doc --with-html-dir=${PREFIX}/share/doc
NO_STAGE= yes
diff --git a/devel/py-itools/Makefile b/devel/py-itools/Makefile
index 37debebd30cd..8fb1d5106961 100644
--- a/devel/py-itools/Makefile
+++ b/devel/py-itools/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}reportlab2>=2.3:${PORTSDIR}/print/py-repo
${PYTHON_PKGNAMEPREFIX}imaging>0:${PORTSDIR}/graphics/py-imaging \
${PYTHON_PKGNAMEPREFIX}matplotlib>0:${PORTSDIR}/math/py-matplotlib \
${PYTHON_PKGNAMEPREFIX}gobject>=2.16.1:${PORTSDIR}/devel/py-gobject \
- ${PYTHON_PKGNAMEPREFIX}pygit2>=0:${PORTSDIR}/devel/py-pygit2
+ ${PYTHON_PKGNAMEPREFIX}pygit2>=0:${PORTSDIR}/devel/py-pygit2 \
+ python:${PORTSDIR}/lang/python
RUN_DEPENDS+= ${BUILD_DEPENDS}
LIB_DEPENDS= glib:${PORTSDIR}/devel/glib20 \
soup:${PORTSDIR}/devel/libsoup