aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-04-12 01:53:43 +0800
committernork <nork@FreeBSD.org>2003-04-12 01:53:43 +0800
commitc19a188fd461d663d01cdb27fd5d46db4f7093a4 (patch)
treeb1d6534870495242616619be60201c5c87e5f66a /devel
parenta517a2e0c95439b2598216a998e804b5b11f1144 (diff)
downloadfreebsd-ports-gnome-c19a188fd461d663d01cdb27fd5d46db4f7093a4.tar.gz
freebsd-ports-gnome-c19a188fd461d663d01cdb27fd5d46db4f7093a4.tar.zst
freebsd-ports-gnome-c19a188fd461d663d01cdb27fd5d46db4f7093a4.zip
Add p5-Locale-Maketext-Lexicon 0.16, use other catalog formats in
Locale::Maketext. PR: ports/48659, ports/50785 Submitted by: Mathieu Arnold <m@absolight.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Locale-Maketext-Lexicon/Makefile38
-rw-r--r--devel/p5-Locale-Maketext-Lexicon/distinfo1
-rw-r--r--devel/p5-Locale-Maketext-Lexicon/files/patch-lib::Locale::Maketext::Lexicon::Gettext.pm11
-rw-r--r--devel/p5-Locale-Maketext-Lexicon/pkg-descr2
-rw-r--r--devel/p5-Locale-Maketext-Lexicon/pkg-plist10
6 files changed, 63 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6fa3828f228e..95d1a7a4f1c4 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -566,6 +566,7 @@
SUBDIR += p5-Inline-Tcl
SUBDIR += p5-Ioctl
SUBDIR += p5-Locale-Maketext
+ SUBDIR += p5-Locale-Maketext-Lexicon
SUBDIR += p5-Locale-PGetText
SUBDIR += p5-Locale-gettext
SUBDIR += p5-LockFile-Simple
diff --git a/devel/p5-Locale-Maketext-Lexicon/Makefile b/devel/p5-Locale-Maketext-Lexicon/Makefile
new file mode 100644
index 000000000000..93e1883ea91a
--- /dev/null
+++ b/devel/p5-Locale-Maketext-Lexicon/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: p5-Locale-Maketext-Lexicon
+# Date created: February 23, 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Locale-Maketext-Lexicon
+PORTVERSION= 0.16
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Locale
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Use other catalog formats in Locale::Maketext
+
+BUILD_DEPENDS= ${SITE_PERL}/Regexp/Common.pm:${PORTSDIR}/textproc/p5-Regexp-Common \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-PodParser \
+ ${SITE_PERL}/Locale/Maketext.pm:${PORTSDIR}/devel/p5-Locale-Maketext
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+MAN3= Locale::Maketext::Lexicon::Auto.3 \
+ Locale::Maketext::Lexicon::Gettext.3 \
+ Locale::Maketext::Lexicon::Msgcat.3 \
+ Locale::Maketext::Lexicon::Tie.3 \
+ Locale::Maketext::Lexicon.3
+
+MAN1= xgettext.pl.1
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Locale-Maketext-Lexicon/distinfo b/devel/p5-Locale-Maketext-Lexicon/distinfo
new file mode 100644
index 000000000000..51430cec928c
--- /dev/null
+++ b/devel/p5-Locale-Maketext-Lexicon/distinfo
@@ -0,0 +1 @@
+MD5 (Locale-Maketext-Lexicon-0.16.tar.gz) = f38b230a7cc91349d06d1a2e3ed20830
diff --git a/devel/p5-Locale-Maketext-Lexicon/files/patch-lib::Locale::Maketext::Lexicon::Gettext.pm b/devel/p5-Locale-Maketext-Lexicon/files/patch-lib::Locale::Maketext::Lexicon::Gettext.pm
new file mode 100644
index 000000000000..1d073e017fc3
--- /dev/null
+++ b/devel/p5-Locale-Maketext-Lexicon/files/patch-lib::Locale::Maketext::Lexicon::Gettext.pm
@@ -0,0 +1,11 @@
+--- lib/Locale/Maketext/Lexicon/Gettext.pm~ Thu Dec 5 07:36:16 2002
++++ lib/Locale/Maketext/Lexicon/Gettext.pm Thu Apr 10 17:26:52 2003
+@@ -101,7 +101,7 @@
+ } :
+
+ /^"(.*)" *$/ ? do { # continued strings
+- $var{$key} .= $1."\n";
++ $var{$key} .= $1;
+ } :
+
+ /^#, +(.*) *$/ ? do { # control variables
diff --git a/devel/p5-Locale-Maketext-Lexicon/pkg-descr b/devel/p5-Locale-Maketext-Lexicon/pkg-descr
new file mode 100644
index 000000000000..34008757ee38
--- /dev/null
+++ b/devel/p5-Locale-Maketext-Lexicon/pkg-descr
@@ -0,0 +1,2 @@
+This module provides lexicon-handling modules to read from other localization
+formats, such as Gettext, Msgcat, and so on.
diff --git a/devel/p5-Locale-Maketext-Lexicon/pkg-plist b/devel/p5-Locale-Maketext-Lexicon/pkg-plist
new file mode 100644
index 000000000000..b77432cb3d40
--- /dev/null
+++ b/devel/p5-Locale-Maketext-Lexicon/pkg-plist
@@ -0,0 +1,10 @@
+bin/xgettext.pl
+lib/perl5/site_perl/5.8.0/mach/auto/Locale/Maketext/Lexicon/.packlist
+lib/perl5/site_perl/5.8.0/mach/perllocal.pod
+lib/perl5/site_perl/5.8.0/Locale/Maketext/Lexicon.pm
+lib/perl5/site_perl/5.8.0/Locale/Maketext/Lexicon/Gettext.pm
+lib/perl5/site_perl/5.8.0/Locale/Maketext/Lexicon/Auto.pm
+lib/perl5/site_perl/5.8.0/Locale/Maketext/Lexicon/Msgcat.pm
+lib/perl5/site_perl/5.8.0/Locale/Maketext/Lexicon/Tie.pm
+@dirrm lib/perl5/site_perl/5.8.0/mach/auto/Locale/Maketext/Lexicon
+@dirrm lib/perl5/site_perl/5.8.0/Locale/Maketext/Lexicon