aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2006-06-05 15:18:30 +0800
committerijliao <ijliao@FreeBSD.org>2006-06-05 15:18:30 +0800
commitcc227b6a2e5b5596e7656cc5ca264bacda6f3f0b (patch)
treefb7232358981e00ef71c0236c9098597d07c9d99 /devel
parent98c79b83576337f46de980ad3c77d949fed7bba5 (diff)
downloadfreebsd-ports-gnome-cc227b6a2e5b5596e7656cc5ca264bacda6f3f0b.tar.gz
freebsd-ports-gnome-cc227b6a2e5b5596e7656cc5ca264bacda6f3f0b.tar.zst
freebsd-ports-gnome-cc227b6a2e5b5596e7656cc5ca264bacda6f3f0b.zip
add p5-Inline-Files 0.62
Multiple virtual files at the end of your code
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Inline-Files/Makefile28
-rw-r--r--devel/p5-Inline-Files/distinfo3
-rw-r--r--devel/p5-Inline-Files/pkg-descr5
-rw-r--r--devel/p5-Inline-Files/pkg-plist7
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8bdb45312399..9e929fc38730 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1053,6 +1053,7 @@
SUBDIR += p5-Inline
SUBDIR += p5-Inline-ASM
SUBDIR += p5-Inline-CPP
+ SUBDIR += p5-Inline-Files
SUBDIR += p5-Inline-Filters
SUBDIR += p5-Inline-Java
SUBDIR += p5-Inline-Tcl
diff --git a/devel/p5-Inline-Files/Makefile b/devel/p5-Inline-Files/Makefile
new file mode 100644
index 000000000000..a751da036db5
--- /dev/null
+++ b/devel/p5-Inline-Files/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: Inline::Files
+# Date created: Jun 5, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= Inline-Files
+PORTVERSION= 0.62
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Inline
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Multiple virtual files at the end of your code
+
+BUILD_DEPENDS= p5-Inline>=0:${PORTSDIR}/devel/p5-Inline \
+ p5-Filter>=0:${PORTSDIR}/devel/p5-Filter
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Inline::Files.3 \
+ Inline::Files::Virtual.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Inline-Files/distinfo b/devel/p5-Inline-Files/distinfo
new file mode 100644
index 000000000000..f9d2bc1cd06d
--- /dev/null
+++ b/devel/p5-Inline-Files/distinfo
@@ -0,0 +1,3 @@
+MD5 (Inline-Files-0.62.tar.gz) = 1beb4548be878a28cafb379945c402b8
+SHA256 (Inline-Files-0.62.tar.gz) = b67f09e6c07b10a920c202abbea1f3f77dbdf40c274071df74b4ad4c0f5a8df2
+SIZE (Inline-Files-0.62.tar.gz) = 13603
diff --git a/devel/p5-Inline-Files/pkg-descr b/devel/p5-Inline-Files/pkg-descr
new file mode 100644
index 000000000000..ec5a99d7692b
--- /dev/null
+++ b/devel/p5-Inline-Files/pkg-descr
@@ -0,0 +1,5 @@
+Inline::Files generalizes the notion of the __DATA__ marker and the
+associated <DATA> filehandle, to an arbitrary number of markers and
+associated filehandles.
+
+WWW: http://search.cpan.org/dist/Inline-Files/
diff --git a/devel/p5-Inline-Files/pkg-plist b/devel/p5-Inline-Files/pkg-plist
new file mode 100644
index 000000000000..3fb29603d600
--- /dev/null
+++ b/devel/p5-Inline-Files/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Inline/Files/.packlist
+%%SITE_PERL%%/Inline/Files.pm
+%%SITE_PERL%%/Inline/Files/Virtual.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Inline/Files
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Inline
+@dirrm %%SITE_PERL%%/Inline/Files
+@dirrmtry %%SITE_PERL%%/Inline