aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2005-03-16 05:58:25 +0800
committerflz <flz@FreeBSD.org>2005-03-16 05:58:25 +0800
commitd2f8fd43a920aec8afb8edaaa71c79eb3271887e (patch)
treecc384f840d2826bb98be63696de6786a7b419b0d /devel
parent7024ac21dc07286ed76add507f88734ec0cf17c0 (diff)
downloadfreebsd-ports-gnome-d2f8fd43a920aec8afb8edaaa71c79eb3271887e.tar.gz
freebsd-ports-gnome-d2f8fd43a920aec8afb8edaaa71c79eb3271887e.tar.zst
freebsd-ports-gnome-d2f8fd43a920aec8afb8edaaa71c79eb3271887e.zip
- Add p5-Class-Gomor-Hash 0.20, yet another class builder. This one adds
parameter checking in new constructor, that is to check for attributes existence, and definedness. Since objects are built as hashes, this module is suffixed by Hash. PR: ports/76979 Submitted by: GomoR <netpkt@gomor.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Class-Gomor-Hash/Makefile29
-rw-r--r--devel/p5-Class-Gomor-Hash/distinfo2
-rw-r--r--devel/p5-Class-Gomor-Hash/pkg-descr8
-rw-r--r--devel/p5-Class-Gomor-Hash/pkg-plist7
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1295818885dd..5b51b3b4c294 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -683,6 +683,7 @@
SUBDIR += p5-Class-Factory-Util
SUBDIR += p5-Class-Fields
SUBDIR += p5-Class-Generate
+ SUBDIR += p5-Class-Gomor-Hash
SUBDIR += p5-Class-Handle
SUBDIR += p5-Class-Hook
SUBDIR += p5-Class-ISA
diff --git a/devel/p5-Class-Gomor-Hash/Makefile b/devel/p5-Class-Gomor-Hash/Makefile
new file mode 100644
index 000000000000..6153ffc03e85
--- /dev/null
+++ b/devel/p5-Class-Gomor-Hash/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: Class-Gomor-Hash
+# Date created: 01 Feb 2005
+# Whom: GomoR <netpkt@gomor.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Gomor-Hash
+PORTVERSION= 0.20
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
+ http://www.gomor.org/netpkt/
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= netpkt@gomor.org
+COMMENT= Class and object builder, hash version
+
+PERL_CONFIGURE= yes
+
+MAN3= Class::Gomor::Hash.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= "Needs perl 5.6.0 or higher, install lang/perl5.6 and try again"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Class-Gomor-Hash/distinfo b/devel/p5-Class-Gomor-Hash/distinfo
new file mode 100644
index 000000000000..ac272095f3e1
--- /dev/null
+++ b/devel/p5-Class-Gomor-Hash/distinfo
@@ -0,0 +1,2 @@
+MD5 (Class-Gomor-Hash-0.20.tar.gz) = 35f199e6295ea016a9ed89708c5c120f
+SIZE (Class-Gomor-Hash-0.20.tar.gz) = 5380
diff --git a/devel/p5-Class-Gomor-Hash/pkg-descr b/devel/p5-Class-Gomor-Hash/pkg-descr
new file mode 100644
index 000000000000..386b66b786f9
--- /dev/null
+++ b/devel/p5-Class-Gomor-Hash/pkg-descr
@@ -0,0 +1,8 @@
+This module is yet another class builder. This one adds parameter checking in
+new constructor, that is to check for attributes existence, and definedness.
+Since objects are built as hashes, this module is suffixed by Hash.
+
+WWW: http://search.cpan.org/~gomor/
+
+- GomoR
+netpkt@gomor.org
diff --git a/devel/p5-Class-Gomor-Hash/pkg-plist b/devel/p5-Class-Gomor-Hash/pkg-plist
new file mode 100644
index 000000000000..08fd82fba108
--- /dev/null
+++ b/devel/p5-Class-Gomor-Hash/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Class/Gomor/Hash.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Gomor/Hash/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Gomor/Hash
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Gomor
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Class/Gomor
+@unexec rmdir %D/%%SITE_PERL%%/Class 2>/dev/null || true