aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-09-16 02:57:10 +0800
committerijliao <ijliao@FreeBSD.org>2002-09-16 02:57:10 +0800
commitd4f9d6d0d23ebfe145d73b99ac3f46f40ce000f1 (patch)
tree4f79b946eae51d36682e41b56743ca2e762285ac /devel
parent5451e2918f6235faba031265fdb2838756f9f941 (diff)
downloadfreebsd-ports-gnome-d4f9d6d0d23ebfe145d73b99ac3f46f40ce000f1.tar.gz
freebsd-ports-gnome-d4f9d6d0d23ebfe145d73b99ac3f46f40ce000f1.tar.zst
freebsd-ports-gnome-d4f9d6d0d23ebfe145d73b99ac3f46f40ce000f1.zip
add eboxy 0.3
Create simple GUI interfaces for entertainment PC
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/eboxy/Makefile36
-rw-r--r--devel/eboxy/distinfo1
-rw-r--r--devel/eboxy/files/patch-Makefile.in11
-rw-r--r--devel/eboxy/files/patch-main.cpp10
-rw-r--r--devel/eboxy/pkg-comment1
-rw-r--r--devel/eboxy/pkg-descr6
-rw-r--r--devel/eboxy/pkg-plist3
8 files changed, 69 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 16e942f57f89..109421540014 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -145,6 +145,7 @@
SUBDIR += doxygen
SUBDIR += e4graph
SUBDIR += ebnf2yacc
+ SUBDIR += eboxy
SUBDIR += ecb
SUBDIR += ecb-emacs20
SUBDIR += ecgi
diff --git a/devel/eboxy/Makefile b/devel/eboxy/Makefile
new file mode 100644
index 000000000000..0c5fbf85cb38
--- /dev/null
+++ b/devel/eboxy/Makefile
@@ -0,0 +1,36 @@
+# ex:ts=8
+# Ports collection makefile for: eboxy
+# Date created: Sep 14, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= eboxy
+PORTVERSION= 0.3
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://www.bluelightning.org/ebox/files/eboxy/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libSDL_gui.a:${PORTSDIR}/x11-toolkits/sdl_gui
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt \
+ xml2:${PORTSDIR}/textproc/libxml2 \
+ SDL-1.1:${PORTSDIR}/devel/sdl12 \
+ SDL_ttf:${PORTSDIR}/graphics/sdl_ttf \
+ SDL_image:${PORTSDIR}/graphics/sdl_image
+
+USE_REINPLACE= yes
+USE_LIBTOOL= yes
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
+ CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt -lstdc++"
+
+post-patch:
+ @${GREP} -lR "malloc.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \
+ -e "s|malloc.h|stdlib.h|g"
+
+.include <bsd.port.mk>
diff --git a/devel/eboxy/distinfo b/devel/eboxy/distinfo
new file mode 100644
index 000000000000..b5d48e61b17c
--- /dev/null
+++ b/devel/eboxy/distinfo
@@ -0,0 +1 @@
+MD5 (eboxy-0.3.tar.gz) = 2a85c84e6bc4e2e6de78aa41184b74c5
diff --git a/devel/eboxy/files/patch-Makefile.in b/devel/eboxy/files/patch-Makefile.in
new file mode 100644
index 000000000000..0f29a20d1c1e
--- /dev/null
+++ b/devel/eboxy/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- eboxy/Makefile.in.orig Mon Sep 16 02:51:19 2002
++++ eboxy/Makefile.in Mon Sep 16 02:51:38 2002
+@@ -327,7 +327,7 @@
+ @list='$(bin_PROGRAMS)'; for p in $$list; do \
+ if test -f $$p; then \
+ echo " $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`"; \
+- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`; \
++ $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed 's/$$/$(EXEEXT)/'`; \
+ else :; fi; \
+ done
+
diff --git a/devel/eboxy/files/patch-main.cpp b/devel/eboxy/files/patch-main.cpp
new file mode 100644
index 000000000000..4b707d10678b
--- /dev/null
+++ b/devel/eboxy/files/patch-main.cpp
@@ -0,0 +1,10 @@
+--- eboxy/main.cpp.orig Mon Sep 16 02:35:53 2002
++++ eboxy/main.cpp Mon Sep 16 02:36:03 2002
+@@ -19,6 +19,7 @@
+ #include "config.h"
+ #endif
+
++#define __GNU_LIBRARY__
+ #include <ctype.h>
+ #include <stdio.h>
+ #include <iostream.h>
diff --git a/devel/eboxy/pkg-comment b/devel/eboxy/pkg-comment
new file mode 100644
index 000000000000..88603eca92b1
--- /dev/null
+++ b/devel/eboxy/pkg-comment
@@ -0,0 +1 @@
+Create simple GUI interfaces for entertainment PC
diff --git a/devel/eboxy/pkg-descr b/devel/eboxy/pkg-descr
new file mode 100644
index 000000000000..7bc3485ba3bb
--- /dev/null
+++ b/devel/eboxy/pkg-descr
@@ -0,0 +1,6 @@
+eboxy is an application for building user interfaces for set-top boxes,
+suitable for use on a TV. It reads an XML file describing a simple GUI
+consisting of pages, images, labels and buttons, and creates the GUI on the
+screen.
+
+WWW: http://www.bluelightning.org/ebox/eboxy/
diff --git a/devel/eboxy/pkg-plist b/devel/eboxy/pkg-plist
new file mode 100644
index 000000000000..231c5c488054
--- /dev/null
+++ b/devel/eboxy/pkg-plist
@@ -0,0 +1,3 @@
+bin/eboxy
+share/eboxy/eboxy.dtd
+@dirrm share/eboxy