aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-07-22 00:27:11 +0800
committerclsung <clsung@FreeBSD.org>2006-07-22 00:27:11 +0800
commitdb5c5e283422bc267769dea43fd35c274fd369c5 (patch)
tree80a45c2082efda4e69a97e9b87886c4859d1a992 /devel
parente0843419764a7a492aa131ee7353c22b4ebb459a (diff)
downloadfreebsd-ports-gnome-db5c5e283422bc267769dea43fd35c274fd369c5.tar.gz
freebsd-ports-gnome-db5c5e283422bc267769dea43fd35c274fd369c5.tar.zst
freebsd-ports-gnome-db5c5e283422bc267769dea43fd35c274fd369c5.zip
Add p5-Scalar-Defer 0.04, calculate values on demand.
PR: ports/100597 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Scalar-Defer/Makefile25
-rw-r--r--devel/p5-Scalar-Defer/distinfo3
-rw-r--r--devel/p5-Scalar-Defer/pkg-descr8
-rw-r--r--devel/p5-Scalar-Defer/pkg-plist6
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2c3a5b4aafdf..2e0643638ce8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1265,6 +1265,7 @@
SUBDIR += p5-SVN-Simple
SUBDIR += p5-SVN-Statistics
SUBDIR += p5-SVN-Web
+ SUBDIR += p5-Scalar-Defer
SUBDIR += p5-Scalar-Util-Clone
SUBDIR += p5-Search-Binary
SUBDIR += p5-Set-Array
diff --git a/devel/p5-Scalar-Defer/Makefile b/devel/p5-Scalar-Defer/Makefile
new file mode 100644
index 000000000000..a3f067b0062a
--- /dev/null
+++ b/devel/p5-Scalar-Defer/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Scalar-Defer
+# Date created: 2006-07-20
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Scalar-Defer
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Scalar
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Calculate values on demand
+
+RUN_DEPENDS= ${SITE_PERL}/Class/InsideOut.pm:${PORTSDIR}/devel/p5-Class-InsideOut \
+ ${SITE_PERL}/Exporter/Lite.pm:${PORTSDIR}/devel/p5-Exporter-Lite
+
+PERL_CONFIGURE= yes
+
+MAN3= Scalar::Defer.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Scalar-Defer/distinfo b/devel/p5-Scalar-Defer/distinfo
new file mode 100644
index 000000000000..35da4422e934
--- /dev/null
+++ b/devel/p5-Scalar-Defer/distinfo
@@ -0,0 +1,3 @@
+MD5 (Scalar-Defer-0.04.tar.gz) = ef8f621cf4a73a6c91855262646c9153
+SHA256 (Scalar-Defer-0.04.tar.gz) = 6bc596ee5daa3215fa1392bb21d433f39c797a5990ea5e26d5d285a8c16f5025
+SIZE (Scalar-Defer-0.04.tar.gz) = 24951
diff --git a/devel/p5-Scalar-Defer/pkg-descr b/devel/p5-Scalar-Defer/pkg-descr
new file mode 100644
index 000000000000..3d802cadc5d8
--- /dev/null
+++ b/devel/p5-Scalar-Defer/pkg-descr
@@ -0,0 +1,8 @@
+Unlike the tie-based Data::Lazy, this module operates on values, not
+variables. Therefore, assigning into $dv and $lv above will simply
+replace the value, instead of triggering a STORE method call.
+
+Also, thanks to the overload-based implementation, this module is
+about 2x faster than Data::Lazy.
+
+WWW: http://search.cpan.org/dist/Scalar-Defer/
diff --git a/devel/p5-Scalar-Defer/pkg-plist b/devel/p5-Scalar-Defer/pkg-plist
new file mode 100644
index 000000000000..f8956bea9c06
--- /dev/null
+++ b/devel/p5-Scalar-Defer/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Scalar/Defer/.packlist
+%%SITE_PERL%%/Scalar/Defer.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Scalar/Defer
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Scalar
+@dirrmtry %%SITE_PERL%%/Scalar