aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2015-06-29 23:47:44 +0800
committeradamw <adamw@FreeBSD.org>2015-06-29 23:47:44 +0800
commite7fc5f1c94dfecb3142340a33be0d452c8201cfe (patch)
treedcef53546d337dcb8a7502e40f3ea25ca1cca685 /devel
parentbaa9187ba5e96d0c7d3c9dbd366214f81129e083 (diff)
downloadfreebsd-ports-gnome-e7fc5f1c94dfecb3142340a33be0d452c8201cfe.tar.gz
freebsd-ports-gnome-e7fc5f1c94dfecb3142340a33be0d452c8201cfe.tar.zst
freebsd-ports-gnome-e7fc5f1c94dfecb3142340a33be0d452c8201cfe.zip
After r390893, chmod u+w/u-w for stripping perl XS modules is unnecessary,
and in fact now leads to incorrect permissions. Remove all instances of it from perl@ ports.
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-B-Hooks-Parser/Makefile2
-rw-r--r--devel/p5-Data-Peek/Makefile2
-rw-r--r--devel/p5-DateTime/Makefile2
-rw-r--r--devel/p5-Devel-LexAlias/Makefile2
-rw-r--r--devel/p5-Goo-Canvas/Makefile2
-rw-r--r--devel/p5-Locale-libintl/Makefile2
-rw-r--r--devel/p5-MooseX-Role-WithOverloading/Makefile2
-rw-r--r--devel/p5-PPerl/Makefile8
-rw-r--r--devel/p5-PerlIO-eol/Makefile2
-rw-r--r--devel/p5-Scope-Upper/Makefile2
-rw-r--r--devel/p5-Set-Object/Makefile2
-rw-r--r--devel/p5-String-LRC/Makefile2
12 files changed, 2 insertions, 28 deletions
diff --git a/devel/p5-B-Hooks-Parser/Makefile b/devel/p5-B-Hooks-Parser/Makefile
index e2c4d8a2d748..83e89ff55f23 100644
--- a/devel/p5-B-Hooks-Parser/Makefile
+++ b/devel/p5-B-Hooks-Parser/Makefile
@@ -21,8 +21,6 @@ USES= perl5
USE_PERL5= configure
post-install:
- ${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/B/Hooks/Parser/Parser.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/B/Hooks/Parser/Parser.so
- ${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/B/Hooks/Parser/Parser.so
.include <bsd.port.mk>
diff --git a/devel/p5-Data-Peek/Makefile b/devel/p5-Data-Peek/Makefile
index 67bbe7a89831..5379a68b0af3 100644
--- a/devel/p5-Data-Peek/Makefile
+++ b/devel/p5-Data-Peek/Makefile
@@ -19,8 +19,6 @@ USES= perl5 tar:tgz
USE_PERL5= configure
post-stage:
- ${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Data/Peek/Peek.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Data/Peek/Peek.so
- ${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Data/Peek/Peek.so
.include <bsd.port.mk>
diff --git a/devel/p5-DateTime/Makefile b/devel/p5-DateTime/Makefile
index 4975dfe0e5a9..d3d26b39a5d4 100644
--- a/devel/p5-DateTime/Makefile
+++ b/devel/p5-DateTime/Makefile
@@ -26,8 +26,6 @@ USES= perl5
USE_PERL5= modbuild
post-install:
- ${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/DateTime/DateTime.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/DateTime/DateTime.so
- ${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/DateTime/DateTime.so
.include <bsd.port.mk>
diff --git a/devel/p5-Devel-LexAlias/Makefile b/devel/p5-Devel-LexAlias/Makefile
index 9f26d593cfad..b1ab4f854a08 100644
--- a/devel/p5-Devel-LexAlias/Makefile
+++ b/devel/p5-Devel-LexAlias/Makefile
@@ -21,8 +21,6 @@ USES= perl5
USE_PERL5= configure
post-install:
- ${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Devel/LexAlias/LexAlias.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Devel/LexAlias/LexAlias.so
- ${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Devel/LexAlias/LexAlias.so
.include <bsd.port.mk>
diff --git a/devel/p5-Goo-Canvas/Makefile b/devel/p5-Goo-Canvas/Makefile
index 40455c62ca0f..609c53aa0225 100644
--- a/devel/p5-Goo-Canvas/Makefile
+++ b/devel/p5-Goo-Canvas/Makefile
@@ -33,8 +33,6 @@ USES= perl5
MAKE_JOBS_UNSAFE= yes
post-install:
- ${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Goo/Canvas/Canvas.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Goo/Canvas/Canvas.so
- ${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Goo/Canvas/Canvas.so
.include <bsd.port.mk>
diff --git a/devel/p5-Locale-libintl/Makefile b/devel/p5-Locale-libintl/Makefile
index 945381dfd7c5..56257de28555 100644
--- a/devel/p5-Locale-libintl/Makefile
+++ b/devel/p5-Locale-libintl/Makefile
@@ -18,8 +18,6 @@ USES= gettext perl5
USE_PERL5= configure
post-install:
- ${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Locale/gettext_xs/gettext_xs.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Locale/gettext_xs/gettext_xs.so
- ${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Locale/gettext_xs/gettext_xs.so
.include <bsd.port.mk>
diff --git a/devel/p5-MooseX-Role-WithOverloading/Makefile b/devel/p5-MooseX-Role-WithOverloading/Makefile
index 565dd4c1d6e4..9064ed977bf7 100644
--- a/devel/p5-MooseX-Role-WithOverloading/Makefile
+++ b/devel/p5-MooseX-Role-WithOverloading/Makefile
@@ -25,8 +25,6 @@ USES= perl5
USE_PERL5= configure
post-install:
- ${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/MooseX/Role/WithOverloading/WithOverloading.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/MooseX/Role/WithOverloading/WithOverloading.so
- ${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/MooseX/Role/WithOverloading/WithOverloading.so
.include <bsd.port.mk>
diff --git a/devel/p5-PPerl/Makefile b/devel/p5-PPerl/Makefile
index 041176eeffae..196e3664754d 100644
--- a/devel/p5-PPerl/Makefile
+++ b/devel/p5-PPerl/Makefile
@@ -19,11 +19,7 @@ USES= perl5
USE_PERL5= configure
post-install:
- @${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/PPerl/PPerl.so
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/PPerl/PPerl.so
- @${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/PPerl/PPerl.so
- @${CHMOD} u+w ${STAGEDIR}${PREFIX}/bin/pperl
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/pperl
- @${CHMOD} u-w ${STAGEDIR}${PREFIX}/bin/pperl
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/PPerl/PPerl.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/pperl
.include <bsd.port.mk>
diff --git a/devel/p5-PerlIO-eol/Makefile b/devel/p5-PerlIO-eol/Makefile
index 8e2e45afa905..ead79e5ee4f2 100644
--- a/devel/p5-PerlIO-eol/Makefile
+++ b/devel/p5-PerlIO-eol/Makefile
@@ -18,8 +18,6 @@ USES= perl5
USE_PERL5= configure
post-install:
- ${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/PerlIO/eol/eol.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/PerlIO/eol/eol.so
- ${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/PerlIO/eol/eol.so
.include <bsd.port.mk>
diff --git a/devel/p5-Scope-Upper/Makefile b/devel/p5-Scope-Upper/Makefile
index 3678f75e46b1..ad07df997e93 100644
--- a/devel/p5-Scope-Upper/Makefile
+++ b/devel/p5-Scope-Upper/Makefile
@@ -18,8 +18,6 @@ USES= perl5
USE_PERL5= configure
post-install:
- ${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Scope/Upper/Upper.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Scope/Upper/Upper.so
- ${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Scope/Upper/Upper.so
.include <bsd.port.mk>
diff --git a/devel/p5-Set-Object/Makefile b/devel/p5-Set-Object/Makefile
index f934abbf4441..b5719ea7e2ab 100644
--- a/devel/p5-Set-Object/Makefile
+++ b/devel/p5-Set-Object/Makefile
@@ -19,8 +19,6 @@ USES= perl5
USE_PERL5= configure
post-install:
- ${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Set/Object/Object.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Set/Object/Object.so
- ${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Set/Object/Object.so
.include <bsd.port.mk>
diff --git a/devel/p5-String-LRC/Makefile b/devel/p5-String-LRC/Makefile
index d8f07415b01f..b71917b2a1e4 100644
--- a/devel/p5-String-LRC/Makefile
+++ b/devel/p5-String-LRC/Makefile
@@ -15,8 +15,6 @@ USES= perl5
USE_PERL5= configure
post-install:
- ${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/String/LRC/LRC.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/String/LRC/LRC.so
- ${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/String/LRC/LRC.so
.include <bsd.port.mk>