aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2013-01-31 08:58:29 +0800
committervanilla <vanilla@FreeBSD.org>2013-01-31 08:58:29 +0800
commitf593dea643b9d82b8fde63018fed55473e81a45a (patch)
tree1859974e9225f2020b375f356c8fa6db1a1a6d90 /devel
parentf02113ca326ec51e54bdd9bd7ea31b2a2ff1b3e4 (diff)
downloadfreebsd-ports-gnome-f593dea643b9d82b8fde63018fed55473e81a45a.tar.gz
freebsd-ports-gnome-f593dea643b9d82b8fde63018fed55473e81a45a.tar.zst
freebsd-ports-gnome-f593dea643b9d82b8fde63018fed55473e81a45a.zip
Add nglogc 1.1.0, flexible C logging API.
PR: ports/175691 Submitted by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/nglogc/Makefile47
-rw-r--r--devel/nglogc/distinfo2
-rw-r--r--devel/nglogc/files/patch-src_nglogc_Makefile.am10
-rw-r--r--devel/nglogc/files/patch-src_nglogc_Makefile.in10
-rw-r--r--devel/nglogc/pkg-descr13
-rw-r--r--devel/nglogc/pkg-plist21
7 files changed, 104 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8efe32442038..de1ff8c8bcfe 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1250,6 +1250,7 @@
SUBDIR += netscape-java40
SUBDIR += newfile
SUBDIR += newt
+ SUBDIR += nglogc
SUBDIR += nini
SUBDIR += ninja
SUBDIR += ninja-ide
diff --git a/devel/nglogc/Makefile b/devel/nglogc/Makefile
new file mode 100644
index 000000000000..1b7986f59cb9
--- /dev/null
+++ b/devel/nglogc/Makefile
@@ -0,0 +1,47 @@
+# Created by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+# $FreeBSD$
+
+PORTNAME= nglogc
+PORTVERSION= 1.1.0
+CATEGORIES= devel
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Flexible C logging API
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+MAN3= \
+ logc_changeLogLevel.3 \
+ logc_defines.3 \
+ logc_log.3 \
+ logc_logArray.3 \
+ logc_logArrayBasic.3 \
+ logc_logArrayFine.3 \
+ logc_logArrayFinest.3 \
+ logc_logArrayInfo.3 \
+ logc_logArrayWarning.3 \
+ logc_logBasic.3 \
+ logc_logEnter.3 \
+ logc_logError.3 \
+ logc_logErrorBasic.3 \
+ logc_logErrorFine.3 \
+ logc_logErrorFinest.3 \
+ logc_logErrorInfo.3 \
+ logc_logErrorWarning.3 \
+ logc_logFine.3 \
+ logc_logFinest.3 \
+ logc_logInfo.3 \
+ logc_logLeave.3 \
+ logc_logWarning.3 \
+ logc_logger.3 \
+ logc_readRingbuffer.3 \
+ logc_registerLogger.3 \
+ logc_removeLogger.3 \
+ logc_resetRingbuffer.3 \
+ logc_setLogFile.3 \
+ logc_setLogFormat.3 \
+ logc_setRingbuffer.3
+
+.include <bsd.port.mk>
diff --git a/devel/nglogc/distinfo b/devel/nglogc/distinfo
new file mode 100644
index 000000000000..a6567a8aaa7b
--- /dev/null
+++ b/devel/nglogc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (nglogc-1.1.0.tar.gz) = 5b994fabb791edf1f65ac62fe0551fbf595e7dc2a38d1ee79701adac54817b29
+SIZE (nglogc-1.1.0.tar.gz) = 466794
diff --git a/devel/nglogc/files/patch-src_nglogc_Makefile.am b/devel/nglogc/files/patch-src_nglogc_Makefile.am
new file mode 100644
index 000000000000..6d484d3edacd
--- /dev/null
+++ b/devel/nglogc/files/patch-src_nglogc_Makefile.am
@@ -0,0 +1,10 @@
+--- src/nglogc/Makefile.am.orig 2013-01-30 10:33:19.426104658 +0400
++++ src/nglogc/Makefile.am 2013-01-30 10:33:43.512184313 +0400
+@@ -51,6 +51,7 @@
+ nflf_logtrace.h \
+ nflf_logarray.h \
+ nflf_logerror.h \
++ ringbuffer.h \
+ types.h \
+ log_priv.h
+
diff --git a/devel/nglogc/files/patch-src_nglogc_Makefile.in b/devel/nglogc/files/patch-src_nglogc_Makefile.in
new file mode 100644
index 000000000000..dc97d75f96ea
--- /dev/null
+++ b/devel/nglogc/files/patch-src_nglogc_Makefile.in
@@ -0,0 +1,10 @@
+--- src/nglogc/Makefile.in.orig 2013-01-30 10:33:50.121624340 +0400
++++ src/nglogc/Makefile.in 2013-01-30 10:34:05.433457827 +0400
+@@ -269,6 +269,7 @@
+ nflf_logtrace.h \
+ nflf_logarray.h \
+ nflf_logerror.h \
++ ringbuffer.h \
+ types.h \
+ log_priv.h
+
diff --git a/devel/nglogc/pkg-descr b/devel/nglogc/pkg-descr
new file mode 100644
index 000000000000..b86c8a129b01
--- /dev/null
+++ b/devel/nglogc/pkg-descr
@@ -0,0 +1,13 @@
+The intention of the nglogc library is to provide an easy to use and powerful
+logging API with mechanism which allows to cram source codes with log
+statements at the start of implementation and decide at the level of building
+or at runtime which statements should be processed.
+
+Therefore the log statements could be controlled by various log levels and
+define switches are available to completely remove the call of the functions at
+pre-processor time. So it is possible to switch on the logging only if it is
+necessary or only print selected messages without any changes in the source
+code. Different publishers are provided also as different formats of outputs to
+fulfil the requirements for software development.
+
+WWW: http://code.google.com/p/nglogc/
diff --git a/devel/nglogc/pkg-plist b/devel/nglogc/pkg-plist
new file mode 100644
index 000000000000..4a099ee40421
--- /dev/null
+++ b/devel/nglogc/pkg-plist
@@ -0,0 +1,21 @@
+include/nglogc/flf_log.h
+include/nglogc/flf_logarray.h
+include/nglogc/flf_logerror.h
+include/nglogc/flf_logtrace.h
+include/nglogc/log.h
+include/nglogc/log_priv.h
+include/nglogc/logger.h
+include/nglogc/logger_type.h
+include/nglogc/nflf_log.h
+include/nglogc/nflf_logarray.h
+include/nglogc/nflf_logerror.h
+include/nglogc/nflf_logtrace.h
+include/nglogc/ringbuffer.h
+include/nglogc/types.h
+lib/libnglogc.a
+lib/libnglogc.la
+lib/libnglogc.so
+lib/libnglogc.so.0
+%%DOCSDIR%%/nglogc_manual.pdf
+@dirrm %%DOCSDIR%%
+@dirrm include/nglogc